New answers tagged

2

The strings aren't actually ANSI sequences. Rather, they started as ANSI sequences, but are translated (due to some scripting error) on your remote machine so that most of the characters are converted to a different form. An ANSI sequence for instance would have escape[A possibly with an optional ; before the A, but the problematic output shows a 133 ([ ...


0

This data very much looks like ANSI escape sequences. Those can be used to switch color of your characters, to change the title bar of your terminal emulator and much more. They work by printing those codes directly to screen and hoping that your terminal emulator understands them correctly. Some (like changing color) are implemented in pretty much every ...


0

CentOS 6 has 2.31.3; CentOS 7 has 3.14.3 (where the feature works). It is not a new feature, having been introduced in 2007: Bug 118967 – single line scrolling with "Ctrl+Shift+ArrowUp/ArrowDown" while 2.31.3 dates from 2010 (a noticeable delay even for the enterprise releases). However, it does not work with CentOS 6 and incidentally, the git-commit logs ...


0

On more recent versions of gnome-terminal, Shift+Ctrl+↑ and Shift+Ctrl+↓ work for scrolling by line, but I have no way of checking for 2.31.


1

The source-code (runner.py) does this: term = os.environ.get('TERMCMD', os.environ.get('TERM')) if term not in get_executables(): term = 'x-terminal-emulator' if term not in get_executables(): term = 'xterm' if isinstance(action, str): action = term + ' -e ' + action else: ...


1

How much is selected on double click can be configured via adding additional character classes to the default set. That means that adding a colon and other special characters that may show up in URLs leads to double click also selecting complete URLs. This can be configured via the gnome config database. For that one has to get the id of the gnome shell ...


1

Go to Edit->Keyboard Shortcuts And uncheck "Enable the menu shortcut key" to turn it off. Reference link : here.


1

Edit .bashrc nano ~/.bashrc Add alias notes='cd ~/project/notes' and save file. Run . ~/.bashrc to activate the alias in an existing terminal.


1

Assuming you are using the Gnome desktop environment and not the legacy CDE one, I'm afraid this functionality which I believe required the plugin nautilus-open-terminal was not available. If you find its source code for the nautilus release Solaris 10 uses, you might try to build it from source. Otherwise, transitioning to Solaris 11 would be a smart move ...


1

New versions of gnome-terminal just thrown away most helpful professional features. :-( I have tried to setup and get an older version of gnome-terminal running and also compared alternatives. If terminator is too exotic for you, the mate-terminal is a great option! It is a fork of gnome-terminal and just keeps all the good features: you can open ...


0

Vim ~/.vimrc: set t_Co=256 colorscheme <name> Tmux ~/.tmux.conf: set -g default-terminal "screen-256color" Shell After the previous changes, you should adapt your workflow to one of these options: Option #1: always start tmux with the -2 argument: tmux -2 Option #2: set up an alias in your shell config file (~/.bashrc, ~/.zshrc): alias ...


1

If you don't need "live" data, you could, by reading man bash, use per-PID $HISTFILEs and send the saved commands off to the internet later. A simple matter of scripting rather than source modification. However, uncooperative users can defeat this approach. One of my answers on AskUbuntu discusses the first part of the method. ~/.bash_logout (man bash again)...


1

From your description of what you want to achieve it sounds like it's not so much the terminal as it's you shell (and judging from your tags that's bash) that you want to extend. The way to that is by modifying the source code, you can find that on the project's home page. Another way of achieving what you want might be to make sure that every users shells ...


1

Download the gnome-terminal source, add your custom processing and recompile. Source is at https://git.gnome.org/browse/gnome-terminal/ Not clear what the 'custom processing' entails, from your original question.


1

For some reason, it was just a Vim issue: when started in tmux, it loaded default colorsheme, but when started from plain terminal, it loaded desert colorscheme but still calling it default when asked via :colorsheme. Forcing :colorsheme default resolved an issue, so I added colorsheme line in my ~/.vimrc and now it's OK. I have no idea why Vim was doing ...



Top 50 recent answers are included