Tag Info

Hot answers tagged

21

Here's an actual fix. Add the following to .tmux.conf: set -s escape-time 0


21

You can use tput reset. Besides reset and tput reset you can use following shell script. #!/bin/sh echo -e \\033c This sends control characters Esc-C to the console which resets the terminal. Google Keywords: Linux Console Control Sequences man console_codes says: The sequence ESC c causes a terminal reset, which is what you want if the screen ...


16

Yes. Here's an example for bash using PS1 that should be distro-agnostic: Specifically, the escape sequence \[\e]0; __SOME_STUFF_HERE__ \a\] is of interest. I've edited this to be set in a separate variable for more clarity. # uncomment for a colored prompt, if the terminal has the capability; turned # off by default to not distract the user: the focus ...


16

Solarized gives very specific colours. You can't really achieve these colours in a standard 256 colour palette. The only way you can achieve this is through setting up the exact colours in your terminal emulator, then apps think they're just using standard 16 colours (8 + 8 brights) but these have been accurately mapped to the Solarized palette. Gnome ...


16

What is $TERM for? The $TERM variable is for use by applications to take advantage of capabilities of that terminal. For example, if a program want's to display colored text, it must first find out if the terminal you're using supports colored text, and then if it does, how to do colored text. The way this works is that the system keeps a library of known ...


13

If the output of echo $0 command is -bash it means that bash was invoked as a login shell. If the output is only bash, then you are in a non-login shell. man bash says somewhere at line 126: A login shell is one whose first character of argument zero is a -, or one started with the --login option. See more about here: Difference between Login Shell ...


12

The difference is down to the way these were started. bash will initialise differently (read different startup scripts) depending on it's argv[0]. If the string starts with a hyphen - as in -bash then it runs as a login shell, if not, it will run as an interactive shell. It can also run as a non-interactive shell (ie. in a shell script). To find out more, ...


11

There is a nautilus (gnome's file manager) extension for that: http://packages.debian.org/sid/nautilus-open-terminal That is the package for debian. You should look in the repository of your distribution for a similar package.


11

From Edit -> Keyboard Shortcuts... you can set a shortcut to Set Title. I don't have a default one.


11

There is a bug related to this issue All you need to do is add the following line to your .bashrc or .zshrc: . /etc/profile.d/vte.sh At least on Arch, the script checks if you are running either bash or zsh and exits if you are not.


8

$TERM is to tell applications what terminal they're talking to so they know how to talk to it. Change it to a value supported by the remote host and that matches as closely as possible your terminal (screen). Most Linux systems should at least have a screen terminfo entry. If not, screen implements a superset of vt100 and vt100 is universal. So: ...


8

You can use the builtin command, bind to map a keyboard shortcut so that it executes a command/shell script. Example Say we want to run the command, pwd, when we press the F12 key. $ bind '"\e[24~":"pwd\n"' Now when I press F12 at my prompt, $: $ pwd /home/saml Determining keyboard shortcuts You can use the following technique to determine the ...


8

The TERM environment variable indicates the terminal type, not the terminal application. TERM has a specific purpose: it tells applications running in that terminal how to interact with the terminal. Applications interact with terminals by writing escape sequences — sequences of characters that include nonprintable characters and have effects such as moving ...


7

You can make Ctrl+V paste by changing the settings in the Edit->Keyboard Shortcuts menu. But you might not want to do it, because Ctrl+V is normally used by your shell as a way of typing characters literally. For example, Tab normally makes the shell try to tab-complete a file name. If you need to actually type a tab, Ctrl+V Tab lets you do that. You can ...


7

You can launch any program with a different language by setting the LC_MESSAGES environment variable (or LANG to include other regional settings besides display language such as sort order, number and date formatting, etc). $ LANG=en_US gnome-terminal Keep in mind that anything you launch FROM that terminal will inherit the language. If you specifically ...


7

Here is a simple solution for the problem described: For gtk-3 apps like gnome-terminal and nautilus just craete (or edit if you have one) the file ~/.config/gtk-3.0/gtk.css with following content: $ cat ~/.config/gtk-3.0/gtk.css @binding-set NoKeyboardNavigation { unbind "F10" } * { gtk-key-bindings: NoKeyboardNavigation } More on the problem see at ...


7

You can use screen(1) within your terminal emulator of choice (xterm, gnome-terminal, ...). The functionality you need is built-in in screen. You need to get familiar with the way it works: by default, the "command" keybinding is Ctrl + A, you compose commands by issuing the "command" sequence plus the specific action. the "copy" command is: AltGr + [ ...


7

A shell is started when you login, but it's also started by programs like make, or when you run a shell script, or when you type :sh to vi, or when you create a new terminal window. Originally, the shell read in ~/.profile when you logged in or ran su. This script would do things like announce whether you had new email, customize your erase and kill ...


6

You can use gconftool with the key /apps/gnome-terminal/profiles/Default/background_type (you might have to use a different profile name than "Default"): gconftool -s -t string /apps/gnome-terminal/profiles/Default/background_type solid gconftool -s -t string /apps/gnome-terminal/profiles/Default/background_type transparent This was tested in version ...


6

You can use the reset command, that will reset the terminal settings.


6

You can use gconftool-2 - GNOME configuration tool. First, you can list all your gnome profiles with: $ gconftool-2 --get /apps/gnome-terminal/global/profile_list [Default,Profile0] Now you can print values for selected profile: $ gconftool-2 -a "/apps/gnome-terminal/profiles/Default" Store value of foreground and background color: $ gconftool-2 ...


6

The xsel utility is similar to xclip, but implemented a little differently. Normally I would expect them to behave in the same way, but they don't make exactly the same X library call, so it's possible that in some corner cases xsel will work but not xclip, or vice versa. Try: bind C-c run "tmux save-buffer - | xsel -ib" bind C-v run "tmux set-buffer ...


6

Ctrl+a [ followed by ?SEARCH_TEXT seems working.


5

The solution was pretty elegant and simple: editing /etc/inputrc and disabling vi mode. Here's the renewed inputrc file: # /etc/inputrc - global inputrc for libreadline # See readline(3readline) and `info rluserman' for more information. # Be 8 bit clean. set input-meta on set output-meta on #set editing-mode vi # To allow the use of 8bit-characters ...


5

If you are using Nautilus as your 'File Browser', it is as simple as a few entries in nautilus-actions GUI... Any 'actions' you create are available via a right-click of the mouse, and also via the Nautilus Toolbar if you wish (and I think also via the menu). ..Command: gnome-terminal Parameters: --window --maximize --working-directory=%d and a couple ...


5

mouse support is disabled by default, so something is turning it on. Likely the reason your set mouse= is failing is because it's running before whatever is turning it on. I'd look through the rest of your vimrc, and possibly the system wide vimrc (/etc/vim/vimrc is a standard location). As a last resort, you can do this really ugly hack which will cause ...


5

Problem solved! To enable native xterm mouse scrolling in tmux, a lot of wiki, Q & A site, blog post suggest adding a line like: set -g terminal-overrides 'xterm*:smcup@:rmcup@' to ~/.tmux.conf. And it is the culprit. To allow xterm titles in terminal window, you also need to add the XT flag, something like this: set -g terminal-overrides ...


5

You could check if you are running in a graphical terminal and only set TMOUT if you are not. An easy way to do this is the tty command: tty - print the file name of the terminal connected to standard input When run from a GUI terminal emulator: $ tty /dev/pts/5 When run from a virtual console: $ tty /dev/tty2 So, adding these lines to your ...


5

The above is a bitmap font (looks very much like -misc-fixed-*-r-semicondensed). What you need is to enable TrueType fonts in XTerm. Provided your XTerm has been compiled with TrueType support, you want to set the xterm*renderFont property to true in your ~/.Xdefaults (or wherever you may have it). XTerm*renderFont: true Alternatively you can do it in the ...


4

The defaults in Gnome Terminal are Ctrl+Shift+c for copy and Ctrl+Shift+v for paste. I don't think you can do right click Copy and Paste because Gnome Terminal uses right click to open the context menu. And as Mikel said, Ctrl+v is interpreted differently by the shell.



Only top voted, non community-wiki answers of a minimum length are eligible