Tag Info

New answers tagged

2

I had the exact same problem and was puzzled. The clue was in the error line: configure: error: invalid feature name: libstdc++-v3 make[1]: *** [configure-gmp] Error 1 evidently the configure-gmp target (in make) was passed the feature name from the parent project. The trick is to spell it out as follows in the command line: --disable-libstdc__-v3 ...


0

To be a tiny bit more explicit than @Miroslav answer: 1 The dependencies #64-bit (`x86_64`) C library and headers yum install libgcc yum install glibc-devel # 32-bit (‘i386’) C library and headers yum install libgcc.i686 yum install glibc-devel.i686 See all of them in GCC Prerequesites. 2 Then compile with --enable-multilib ../configure ...


1

This is GCC bug #65387. And as you can see it is closed as not a bug. The C/C++ preprocessor is emitting C/C++ code into your post-processed Fortran program, because it's a C/C++ preprocessor. If you're going to use the C/C++ preprocessor with Fortran programs per GCC's own Fortran doco, then do the part that the GCC Fortran doco doesn't tell you and use ...


0

The problem is with the .F source files. You're attempting to use C/C++ style comments, and the Fortran compiler isn't seeing them as comments. It seems them as bad syntax.


1

openSUSE has some "extended" repositories, that include various tools (gcc-4.9 and gcc-5.0 beta are there). From root shell add repository and enable it: # zypper ar http://download.opensuse.org/repositories/devel:/gcc/openSUSE_13.1/ devel-gcc Refresh repository cached metadata: # zypper ref Install g++ 4.9 # zypper in gcc49-c++ To use it, ...


-1

compile code using following command gcc filename.c -lpthread -lrt



Top 50 recent answers are included