Tag Info

New answers tagged

0

I tried to comment on this but it says I do not have a high enough rep (50) to comment so I have to add as an answer. Sorry about that Just curious, can you mount it as root, then change ownership? Otherwise, I'm guessing it is something on the synology side. You will need to change ownership on the synology side and unfortunately I do not know this ...


3

Although I don't understand why there is a difference in Mint and Lubuntu, I recommend you react to power outages with running the command which solves your problem: mount -a You can either run this command periodically or poll the battery status: upower -i /org/freedesktop/UPower/devices/battery_BAT0 NOTE: Your device may be different. You can ...


0

Given the simplicity of the /etc/fstab parser I would expect, removing the quotes around the UUID in the affected entry might help that is, use UUID=064ced5e-19c1-43d1-876f-3de0c115b65e /mnt/Data ... instead of UUID="064ced5e-19c1-43d1-876f-3de0c115b65e" /mnt/Data ...


3

Your problem: /myhdd ... /mnt/myhdd/... /mnt/myhdd/... It should read either: /mnt/myhddd ... /mnt/myhdd/... /mnt/myhdd/... or... /myhdd ... /myhdd/... /myhdd/...


1

Use normal Linux/Unix permissions on your dude/photos to make sure that popolo can't access them. Assuming that popolo isn't the owner of those files and directories and isn't in the group, then a simple chmod -R o-rwx dude/photos should make sure that popolo can't access those files. Or: An alternative way would be to give popolo and empty chroot home ...


3

Linux definitely does provide the tools to do this automatically. Rather than using mount, you should be using findmnt. man mount 2>/dev/null | grep -m1 -B1 findmnt For more robust and customizable output use findmnt(8), especially in your scripts. printf '%s%s 0 0\n' '/dev/disk/by-uuid/' \ "$(findmnt -n -o ...


0

You need to manually edit the file fstab. To find out what to put in there, issue the mount command and look at its output.


1

Files in /proc are generated by the kernel, not by the mount utility. The kernel omits options that are in their default kernel setting. The defaults of the mount utility don't always match the kernel defaults. You can check the defaults for your kernel version in the source code, in fs/proc_namespace.c. For example, as of version 3.15, noexec is displayed ...


1

man mount has a good list. But induvidual filesystem can define their own flags -> there is a separate list for every filesystem. But there are common flags and they are listed on the mount manpage. exec is a default flag. The list of the defaults mount flags are also in the man mount (AFAIK in the kernel sys_mount() syscall there is no such thing). But if ...


2

The reason is probably that exec is the opposite of noexec, and it is noexec that is listed. Thus if noexec is absent, the user knows that exec is in effect. This is similar to dev / nodev. It seems that the exception is rw, which is listed even though it is in the default list. Note: while the mount(8) man page says that defaults is a fixed list of default ...


0

If 0, dump will ignore the file system; This statement is incorrect: -level# The dump level (any integer). A level 0, full backup, specified by -0 guarantees the entire file system is copied (but see also the -h option below). A level number above 0, incremental backup, tells dump to copy all files new or ...


1

Try changing options => "-o loop", to options => "loop", The error shows mount -o -o loop so you'd want to get rid of one of the -o arguments


1

From man fstab: Instead of giving the device explicitly, one may indicate the (ext2 or xfs) filesystem that is to be mounted by its UUID or volume label (cf. e2label(8) or xfs_admin(8)), writing LABEL= or UUID=, e.g., 'LABEL=Boot' or 'UUID=3e6be9de-8139-11d1-9106- a43f08d823a6'. This will make the system more robust: adding or removing a ...



Top 50 recent answers are included