Tag Info

New answers tagged

2

instead of choosing automatic recovery, select an emergency shell, then try: $ e2fsck -fy /dev/sda1 $ e2fsck -fy /dev/sda3 $ e2fsck -fy /dev/sda7 This will check the filesystems, option -f forces the checking to continue even if the filesystem seems clean and option -y forces a 'yes' answer to any interactive questions. If you are happy to sit and watch ...


3

The dirty bit is set and cleared in the kernel, when mounting and unmounting a device; see http://lxr.free-electrons.com/source/fs/fat/inode.c?v=3.19#L578 for the implementation. There's no way currently to access this function outside the kernel, except by mounting and unmounting... To set it yourself, you'd need to tweak the device directly; the state ...


0

I pretty much had the same issue, trying to mount gave: $sudo mount /dev/sda2 ./oldfs/ mount: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so I tried the above mentioned re-writing of the part-table, without success. ...


0

Add the fsck.mode=force Kernel parameter on your bootloader. Append this option to the GRUB_CMDLINE_LINUX_DEFAULT= variable inside /etc/default/grub. As root, generate a new grub configuration file: [root@host]# grub-mkconfig -o /boot/grub/grub.cfg This parameter have the same effect as creating the forcefsck file inside the root of the mount point.


0

I am editing my answer: The command is: sudo tune2fs -c 1 /dev/sdX according to manpages -c argument for tune2fs counts number of instances of mounts for a partition. Hence, 1 forces to check the fs after every mounting instance. (http://man7.org/linux/man-pages/man8/tune2fs.8.html)



Top 50 recent answers are included