New answers tagged

4

short: xterm uses a single font (except for the special cases of double-width characters), while the other terminals use additional fonts (and they use those fonts for the characters not found in your requested font). long: the character you are interested in is not part of the font, which appears to be something like fonts-hack-tty in Debian. The missing ...


0

This is the default Font settings from my Antergos Installation: Basically Sans Regular and Monospace Regular. And all fonts are Truetype Fonts


1

The "System Settings" and "Font" dialog will (as a rule) affect only desktop applications which have been integrated with it. In your configuration, those are KDE applications. In X, most applications manage their fontsizes by themselves, and are not affected by these dialogs. Or, even if there is some nominal integration, it may not be maintained. For ...


1

The menu fonts should change based on your GTK font, but the font used in web pages is a combination of firefox settings and fontconfig. To change the setting in Firefox for example, go to Edit > Preferences > 'Content' tab > and click the 'Advanced' button next to 'Default font'. Here you can change the setting for various languages. If you want to see ...


3

The xterm manual shows an option which may help (added in patch #298 in 2013): -report-fonts Print a report to the standard output showing information about fonts which are loaded. This corresponds to the reportFonts resource. Also, appres is useful for showing what resources are used, e.g., ...


0

There is a script for ImageMagick tools to show fonts with several bells & whistles http://www.imagemagick.org/Usage/scripts/show_fonts.


2

So there are a few open source fonts targeting programmers that support ligatures, namely FiraCode Hasklig Monoid Iosevka However, very few opensource terminals that run natively on Linux yet support this. But you can find an current list in the FiraCode docs Black Screen (slow in browser terminal emulator that runs on node) Konsole (terminal editor ...


2

An XTerm's size is determined by the number of characters its displaying, the font it is using, and the size of the window manager decorations (title bar, outlines, etc.). You're probably using a different (larger) font on LFS. Ubuntu's xterm settings are probably in /etc/X11/app-defaults/{XTerm,XTerm-color} (at least that's where they are in Debian). You ...


0

A possible solution is to prepend the Emoji font like this: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig> <match target="font"> <edit name="family" mode="prepend_first"> <string>Emoji One Color</string> </edit> </match> ...


0

I found solution! first: $ sudo nano /etc/environment Second (add this string to config): _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=setting' But I did't understand something. According to this article setting is not a value. Also above described parameter earlier is not specified at all and this problem been present.


2

I came across this in 2016. A single TTF/OTF font is never going to cover all utf-8 characters. There is a hard limit of 65535 glyphs in a font, and over 1 million utf-8 glphys. You will need to use a font-family for this to work. A good font-family is the noto font family: https://www.google.com/get/noto/



Top 50 recent answers are included