Hot answers tagged

42

Often times when in a Unix/Linux terminal (Bash) for example you'll use the commands more or less or cat to view a file. When you do this and the file isn't meant to be viewed (such as /bin/ls) you'll get output like this:                  What's going on here is that you just ...


20

gnome-font-viewer (part of GNOME of course) can do this (this is the default association for fonts under GNOME); indeed, it comes with a button to install the font, which obviously wouldn't make sense if the font needed to be installed already. fontmatrix lets you organize groups of fonts to be installed or uninstalled, and you can preview them and see ...


20

I use character maps heavily and decides to make one which you access from anywhere using a web interface and requires no installation. Works best on Chrome. Features Select your own font file Provides font and character information Character copy-able Supports TTF/OTF Supports Icon fonts Simple interface No installation necessary No server upload ...


14

The hands-down most comprehensive coverage would be Roman Czyborra’s GNU Unicode font project. It is intended to collect a complete and free 8×16/16×16 pixel Unicode font. It currently covers over 34,000 characters (out of ~40,000+ defined characters). Most distributions have Gnu Unifont in their repositories. There is a comprehensive list of unicode ...


14

If you use the Linux console, the best way I found is: in /etc/default/console-setup put, for example CHARMAP="UTF-8" CODESET="Lat7" FONTFACE="Terminus" FONTSIZE="28x14" Another way is to use setfont: setfont /usr/share/consolefonts/Lat7-Terminus28x14.psf This works for my Debian; it may be different for you. In Debian, you can also run ...


12

After some research based on the answers of @fpmurphy and @hesse, also based on a comprehensive thread at ubuntuforums and on Fedora Wiki, I found out how to reduce the font size of GRUB2. Choose a font, in this example I chose DejaVuSansMono.ttf Convert the font in a format GRUB understands: sudo grub2-mkfont -s 14 -o /boot/grub2/DejaVuSansMono.pf2 ...


12

There are two mechanisms for fonts in X land: server-side and client-side. The traditional way to render fonts is for the client to tell the server “render foo at position (x,y) in font F” (where a font specification includes a face, size, encoding and other attributes). Either the X server itself, or a specialized program called a font server, opens the ...


12

The font is Donald Knuth's Computer Modern. The documentation was no doubt created with LaTeX (or maybe even plain TeX). (Actually, these are both confirmed by the PDF metadata.) (Edit: Poking around a bit more, it looks like, strictly speaking the documentation is created in a base format, which, thanks to GNU texinfo is exported to a variety of formats, ...


11

From the man page: CHANGING FONTS Changing fonts (or font sizes, respectively) via the keypad is not yet supported in rxvt-unicode. Bug me if you need this. You can, however, switch fonts at runtime using escape sequences, e.g.: printf '\e]710;%s\007' "9x15bold,xft:Kochi Gothic" You can use keyboard shortcuts, ...


11

I think you're looking for otfinfo. There doesn't seem to be an option to get at the Subfamily directly, but you could do: otfinfo --info *.ttf | grep Subfamily Note that a number of the fonts I looked at use "Oblique" instead of "Italic".


9

You could include these color definitions in a script or source file. Could look something like this. #!/bin/bash PATH=/bin:/usr/bin: NONE='\033[00m' RED='\033[01;31m' GREEN='\033[01;32m' YELLOW='\033[01;33m' PURPLE='\033[01;35m' CYAN='\033[01;36m' WHITE='\033[01;37m' BOLD='\033[1m' UNDERLINE='\033[4m' echo -e "This text is ${RED}red${NONE} and ...


9

On most if not all terminal emulators, you can't set different font sizes or different fonts, only colors and a few attributes (bold, underlined, standout). In bash (or in zsh or any other shell), you can use the terminal escape sequences directly (apart from a few exotic ones, all terminals follow xterm's lead these days). CSI is ESC [, written $'\e[' in ...


8

You should edit the file /etc/default/console-setup and change the FONTSIZE variable. Once you've made your changes you must reconfigure your terminal by running: $ sudo service console-setup restart


8

I spent the better part of tonight solving this same issue, even though it's 2 years later! So to avoid a DenverCoder9 moment for future visitors, here's what solved my issue. From this email thread: As root, edit /usr/lib/systemd/system/systemd-vconsole-setup.service Change the After= and Before= lines to: After=sysinit.target Before=shutdown.target ...


8

In short: you cannot with the current version of Emacs (checked with 23.2), but see below for a possible workaround. Longer story: support for italics is encoded in the terminfo database as the sitm (enter italics) and ritm (exit italics) capabilities (also called ZH and ZR for termcap compatibility); you can check that your terminal supports them via: ...


8

This is slightly modified from the instructions found here (and I haven't even checked if they work): Install the chkfontpath package from ATrpms (Click on either the i686 or x86_64 package, depending on whether you have a 32-bit or 64-bit machine). As root, install some packages you'll need for the following steps: yum install rpm-build cabextract ...


8

Font Manager is very handy for previewing and comparing fonts. It allows you to install TTF files, even if zipped, and will preview them pretty quickly. It does install them in your ~/.fonts directory, but it's pretty easy to remove them.


7

As Gilles said, to use a TrueType font like Consolas in Emacs 23 you must link it with the Freetype and Fontconfig libraries. In Gentoo, you do that by turning on the xft USE flag when building Emacs. You'll need to turn that flag on (either globally or just for app-editors/emacs) and reinstall Emacs.


7

xfontsel lets you browse through the available X11 fonts and provides rendered previews so you can see what they actually look like. It's fairly plain-looking and basic but it is provided with most Xorg installations by default.


7

You can effectively disable bold fonts by just applying the same font string for both urxvt's regular and bold fonts in .Xresources, for example: URxvt.font:xft:droid sans mono slashed:size=10.5 URxvt.boldFont:xft:droid sans mono slashed:size=10.5


7

Have you tried ? fc-list | grep -i "media" Also give a try to fc-scan, fc-match


7

I tried the same commands and got the same results. $ printf "\u2318" | convert -size 100x100 label:@- \ -font unifont-Medium command.png ...


7

The Liberation font doesn't seem to have this symbol. But using XTerm*faceName: DejaVu Sans Mono (which is also a truetype font) allows ☠ to be displayed. EDIT: Do not use LibreOffice or OpenOffice to determine whether a glyph is supported in a font, as it silently falls back to another font: OpenOffice bug 45128.


6

Urxvt has an option for basic kerning: letterSpace. See man urxvt: -letsp number Compile frills: Amount to adjust the computed character width by to control overall letter spacing. Negative values will tighten up the letter spacing, positive values will space letters out more. Useful to work around odd font metrics; ...


6

fc-match is the utility to use. For example, fc-match monospace will tell you the font used for monospace, and fc-match -s monospace will tell you fallback fonts as well, in order. The first font on the list will be what is used in most cases, and all fonts after are fallback fonts for missing glyphs.


6

If you need to install a lot of fonts, then copy the files to ~/.fonts or /usr/share/fonts for system-wide installation and issue the command fc-cache -fv.


6

According to the manual, setting URxvt.boldFont to empty will disable the bold font, and uses regular font instead. This is the preferred way I think. URxvt.boldFont:


6

Firefox's rendering engine will substitute glyphs from other installed fonts (if it can find one with the required glyph) instead of displaying broken glyphs. Chromium will stick to the specified font(s) instead, and will display a "missing glyph" character if the glyph is not found. For Chromium and possibly other programs, you need to install Chinese ...


6

Okay, I figured this out. From the man page of fonts-conf, the property weight sets the weight of the bold face, and not the weight of the font. This was why changing weight lead to a bolder boldface rather than change the whole font. What I was looking for was emboldening which enables synthetic font emboldening. Using that in ~/.fonts.conf solved the ...


6

This fixed the problem for me. Install the dejavu fonts. sudo pacman -S ttf-dejavu



Only top voted, non community-wiki answers of a minimum length are eligible