Hot answers tagged

5

This worked for me. Add the following to your kernel parameter. selinux=1 enforcing=0 This sets the SELinux enforcement mode from strict to permissive. This is a temporary solution until I figure out what is going on, or until an update fixes the problem. Hope it helps.


4

PackageKit is being run by GNOME Software. It's not doing automatic updates, but it is downloading them so they're ready. There is work on making this be smarter, including not doing it over bandwidth-constrained connections, but it hasn't landed yet. In the meantime, you can disable this by running: dconf write /org/gnome/software/download-updates false ...


3

This is a bug in bash completion in dnf (not the first one and not the last one). Let's see what I can find out. Running the same with set -x will reveal the source of this: python3 -c 'import sys; from dnf.cli import completion_helper as ch; ch.main(sys.argv[1:])' _cmds sear -d 0 -q -C does not return the list of options, but basically some error. It ...


3

You can use timeout command to run your command or script in a given timeout. Something similar to this: timeout 10m command Which waits for the command to finish withing 10 minutes otherwise kills it and exits with status 124. Then you can check exit status of timeout and print the appropriate message based on it. See here for more: timeout manpage. If ...


3

This isn't via bash, but the GNOME Shell extension Auto Move Windows lets you define rules so that programs are automatically opened on predefined workspaces. If that doesn't do you what you need, you could consider extending the extension (source here; it's in Javascript) to better fit your specific need.


2

There wouldn't be any overwrite issues with rm but whatever the scenario, if you abort during the process, it will blindly stop where it was when it got interrupted. There is unfortunately no way of knowing where it stopped unless you previously made a listing of what should be removed.


2

Answering my own question: I was able to solve the problem by restoring the configuration of my /etc/proftpd.conf to AuthOrder mod_auth_pam.c* mod_auth_unix.c SELinux was configured by setting the following flags: setsebool ftpd_full_access 1 setsebool ftp_home_dir 1 Apparently the problem was related with mod_auth_unix.c which is forbidden by SELinux ...


2

To answer your specific question, you can use iproute2 to assign the IP address like this: sudo ip addr add 169.254.169.254/8 dev lo It will just add a new IP to the interface, no need for aliasing with :0, :1, etc. Note this is going to be lost after a reboot. And to quickly emulate the metadata service you can use netcat like this: while true; do sudo ...


2

This is caused by a bug in the SELinux policy. See https://bugzilla.redhat.com/show_bug.cgi?id=1331668 — as of May 2, 2016, there is an update in testing which should resolve the issue. In the meantime, booting with enforcing=0 will work around the problem.


2

The solution I used was Change default.target to multi-user.target (Was graphical.) setenforce 0 systemctl isolate graphical


2

To set up networking for your chrooted session you need to copy the DNS configuration into the chroot environment : cp /etc/resolv.conf /mnt/etc/resolv.conf Or ln -s /etc/resolv.conf /mnt/etc/resolv.conf


2

I think you use, Vino. Vino is the GNOME desktop sharing server. This (vino) is default package in most of the distribution along with gnome.


2

Subshells do have overhead. On my system, the minimal fork-exec cost (when you run a program from disk when the file ins't cold) is about 2ms and the minimal forking cost is about 1ms. With subshells, you're talking the forking cost alone, as no file needs to be execed. If the subshells are kept reasonable low, 1ms is quite negligible in human-facing ...


1

You tftp server setting can be viewed in /etc/xinetd.d/tftp. server_args = -s /tftproot # tftproot is where your tftp base directory. Say you tftp server is hostx From hosty, try this command tftp hostx > tftp get file # file is any file under this /tftproot directory. > tftp quit ls -l file


1

Wayland needs to be supported by the video driver. At the moment only some open source drivers included in the kernel have support.


1

You can comment the bind-address in /etc/my.cnf: #skip-networking #bind-address = 127.0.0.1 also check that it is of the above format , var = value if you are connecting to the database remotely , check your interface ip by using ip addr show or ifconfig command , get the ip and bind it to mysql. bind-address = ...


1

This is a hardware error. Specifically, it's an ECC memory error which was detected but not corrected. How can you tell? Pipe the output above through mcelog --ascii, and you'll get: Hardware event. This is not a software error. CPU 4 0 data cache TSC 22cd709f356 ADDR 5989fdd80 TIME 1462430327 Thu May 5 02:38:47 2016 Data cache ECC error (syndrome a0) ...


1

I had to copy the modules from Qubes and regenerate the initramfs using the sudo dracut -f command.


1

For the sake of completeness, i will add that this is a problem with selinux-policy and selinux-policy-targeted version 3.13.1-183.fc24. Downgrading these to previous versions or using 3.13.1-184.fc24 fixes this issue. Also see bugzilla entries here and here.


1

As the accepted answer already says, you can use yum shell to run multiple commands at once, which is fine for interactive use. But if you want to invoke this command from a script, you can also run it against a file, eg yum shell translist.txt, where the file could contain, for example: remove squid install squid34 run Append the -y switch to assume yes ...


1

I believe the FTP server is forbidden to access /etc/passwd or /etc/shadow. This is not true. From the AVC message, you see tcontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 which is some part of ftpd_t, not shadow or passwd (these files have different context, as you can see from ls -Z /etc/passwd). It is not complete solution, but moving forward. ...


1

This is still happening in Fedora 23. My solution was to update both packages: sudo dnf update vim-common vim-minimal If I tried to update either package separately, I got the conflict. But I was able to successfully update both of them at the same time.



Only top voted, non community-wiki answers of a minimum length are eligible