New answers tagged

0

See details in answers above: I updated {/dev/sda3, /boot} from filesystem type=ext2 to ext4, then ran sudo dpkg-reconfigure grub-pc --frontend=text. I now see and boot to the updated kernel and have no boot-time error messages.


1

summary: ext2 is a bad choice for /boot, since (unless I'm missing something or am very unlucky) it appears to prevent "normal" update of GRUB2. details: Today I was updating a 2010-vintage laptop that runs a Debian distro (LMDE2) shipped with win7, which I dualbooted with an unmanaged Linux /boot partition and a managed (LVM2-on-LUKS) partition: $ sudo ...


0

Answer I ran across this thread on the FreeBSD Forums. While it was nearly identical to my issue in almost every way, the main differentiating point was it was in reference to ext4, not ext2. Since ext4 is technically backward compatible with ext2/3, I I decided to take the chance and see if I could try this solution - it worked. Here's what I did to ...


2

I don't agree with the squashfs recommendations. You don't usually write a squashfs to a raw block device; think of it as an easily-readable tar archive. That means you would still need an underlaying filesystem. ext2 has several severe limitations that limit its usefulness today; I would therefore recommend ext4. Since this is meant for archiving, you ...


2

SquashFS is a compressible read-only filesystem that fits your requirements well, has been in the kernel for a few years, and is already widely used (e.g., in LiveCDs). The latest documentation for the userspace tools is on GitHub. From the documentation: Squashfs is a highly compressed read-only filesystem for Linux. It uses either gzip/xz/lzo/lz4 ...


1

You'd probably be better served by a compressed filesystem. There are ways of compressing various Linux filesystems (FUSE can do it), but since this will be read-only once you've created it, you might consider squashfs. You create the filesystem with mksquashfs. Linux has had squashfs in the main kernel since 2.6.something, so it should work from pretty ...


2

The ext2fs file system is optional on FreeBSD and needs to be loaded. Add the following line to /boot/loader.conf to have it loaded at boot time: ext2fs_load="YES"


1

use -T option to print file system type [root@centos6 ~]# df -T Filesystem Type 1K-blocks Used Available Use% Mounted on /dev/mapper/VolGroup-lv_root ext4 6795192 6367072 76276 99% / tmpfs tmpfs 639164 0 639164 0% /dev/shm /dev/sda1 ext4 487652 28684 433368 7% ...



Top 50 recent answers are included