Tag Info

New answers tagged

6

With traditional unix mail clients, /var/spool/mail/$USER is the user's inbox. The emails remain there as long as the user decides not to archive the mail. Some mail clients insist on moving emails to a proprietary file, or offer the option to move emails to a different file after reading. Users can choose which mail client they use and how they configure ...


1

I got it working with fetch mail and msmtp. My target was iCloud, so I will leave in the MX of iCloud. First the .fetchmailrc: poll pop.gmx.net with proto POP3 user "user@pop-server" there with password "secretpassword" mda "/usr/bin/msmtp -- someuser@icloud.com" options no keep ssl sslcertck sslcertpath /etc/ssl/certs set daemon 300 Then the .msmtprc: ...


3

It does not appear that fetchmail supports TLS to the SMTP server. This is normally not a problem, as it usually delivers emails locally. You can work around this by delivering to a local SMTP server and have it handle the delivery. If your don't need or want a full service server like exim4 or postfix, you can use a light-weight relay like esmtp or ...


1

Seem to have figured out a working method. Avoiding $IFS and not trying to handle the entire directory list as a string or array - working on each entry as it is found. Replaced last loop with the following: find "$DIR" -type f -mtime -2 -name '*.xls*' -exec sh -c ' for file do # Check to see if we found any files or not if [ -z "$file" ]; then ...


1

The problem is $FILE is not an array but you're accessing it like it is for datafile in ${FILES[*]} It's just returning a giant string, hence all the files at once. To work around this, append a newline to each file in $FILE then in the loop use echo -e to return each line indivivually # Get the list of files to send FILES=$(find "$DIR" -type f -mtime ...


0

I found the problem! Munpack will work just in case you have one mail in your mailbox text file. If you have more than that munpack will not work!


2

set "/home/user/path to files/"*.xls for f do [ "$f" -nt "$two_day_old_file" ] && set "$@" "$f" ; shift ; done touch "$two_day_old_file" echo $MBODY | mutt -s "Data files for $TODAY" -a "$@" -- $EMAILS To mail them one at a time change the echo line to: for mailf do echo "$MBODY" | mutt -s "Data files for $TODAY" -a "$mailf" -- $EMAILS ...


3

Use a transport map: Find or add the following line in your main.cf (alter the file location to fit your CentOS setup): transport_maps = hash:/etc/postfix/transport Edit the transport map file above to: localhost : <your FQDN> : * error: Outgoing mail from this system has been disabled. localhost and your FQDN will use local delivery. ...


0

Like others have said, you'll need to set up a local mail server (sendmail, postfix, or whatever is your preference). My assumption is that you're doing this from your home and you get an IP that changes every so often. If this is the case, then you'll find other problems with sending email. A lot of servers will simply deny you because of your IP address ...


0

You can use Postfix, which is a widely used SMTP server and is also simple to set up for a testing environment. Here the Debian docs explain about Postfix. Also you can check different configurations on Postfix Docs.


1

The IP of the host mail.mydomain.com is sending too many mails, unsolicited emails which is worse, too fast. This is clear from the error message: Our system has detected an unusual rate of 421-4.7.0 unsolicited mail originating from your IP address. To protect our 421-4.7.0 users from spam, mail sent from your IP address has been temporarily 421-4.7.0 ...


0

I examined master.cf, not sure what ISPConfig update did and upgrading to Ubuntu 14.04 but it appears to have maildrop and dovecot configured. I've never had dovecot installed. courier-imap is what I've been using. I noticed master.cf also had maildrop configured. So I did the following: main.cf: virtual_transport = maildrop Ran command to force ...


3

With zsh: mutt -s "Log" -a /path/to/*.log(.om[1]) example@example.com That uses zsh glob qualifiers. While other shell globs can only generate filenames based on their name, in zsh, you can use those qualifiers ((.om[1]) above), to select based on file attributes (type, size, times, permissions...) or other criteria of your own, affect the order, apply ...


1

Get_Attachment_Name () { file_attachment_dir="Whatever you want your directory to be" file_attachment=`ls -lrt -- "$file_attachment_dir" | grep -v "^[bcdl]"| tail -n 1 | awk '{print $9}'` } Grepping out any output lines starting with b, c, d, or l will eliminate trying to send block special files, character special files, directories or symbolic ...


0

If you want postfix to deliver mails for aevidi.com by doing an MX lookup (i.e to Zoho mail servers, in your case), then you should remove $domain i.e aevidi.com from mydestination.


0

Your /etc/postfix/main.cf file doesn't mention procmail anywhere. This is the problem, AFAIK. In my case, I have: mailbox_command = procmail -a "$EXTENSION" and my procmail config file is in ~user/.procmailrc. However this is a real user on the machine. It seems that you're using virtual transport, in which case I suppose that you should use something ...


1

With the Heirloom mailx, convenient way is mailx -s "$(echo -e "Newsletter issue 3\nContent-Type: text/html")" user@server.com < /tmp/htmlmail.txt Thanks, Dude Tested on Fedora 17, and worked


2

Can somebody please explain how this works? Who copies the emails into /var/spool/postfix/maildrop, is it the email client (heirloom in my case) ? Local mail submissions, are received with the Postfix sendmail compatibility command, are queued in maildrop queue by postdrop program. The postdrop command is designed to run with set-group ID ...


0

To avoid the URIBL block, you must either point to a recursive DNS server that isn't itself blocked, or you must run your own fully recursive DNS server on your own IP address (that presumably isn't blocked). As suggested, you can run something full-featured such as bind or djbdns. You can't get away with a "lightweight" DNS server such as dnsmasq that ...


2

I don't know the details of your setup, but I would suggest that you check that your Thunderbird clients are properly configured, before you start troubleshooting your IMAP server. In particular, you should make sure that in: Edit -> Account Settings -> Synchronization & Storage -> Message Synchronizing -> Advanced You have all ...


0

Use verbose mode (-v) to avoid ctrl+d echo -e 'Mail body'| mail -v -s 'Mail Subject' my@email.com



Top 50 recent answers are included