Tag Info

Hot answers tagged

6

Situation: you have an encrypted home directory. Step 1: you log in over SSH. Your encrypted data is not mounted, so what you see is your “real” home directory on the (unencrypted) main filesystem. This home directory doesn't contain much that's directly usable: ~/.ecryptfs/ contains control data for your encrypted data ~/.Private/ contains your encrypted ...


4

Mounting does not change your current working directory. I guess that the mountpoint is the directory you are in. You either have to do the mount from elsewhere or to get out of that directory: ls -al ecryptfs-mount-private ls -al cd .. cd - ls -al or cd .. ecryptfs-mount-private cd - ls -al All symlinks have lrwxrwxrwx. This doesn't matter as the ...


3

Not possible. Someone, or something has to supply the password for decryption. Obviously it can't be on your home directory (as that is encrypted). It should not be on your hard disk at all, as that would be pointless: An attacker could extract it from there. So I don't see a way to make this automated (i.e, not requiring you) while preserving that only ...


1

If you fiddled with your home directory, you needed root to get at the /home directory that contains it. Possibly your home now contains some stuff owned by something other than you, that the sudo obviates. An aggressive approach might be "sudo chown -R myname:users ~myname" A more cautious person might do "find ~myname ! -user myname" to look for such ...


1

If you didn't have an initramfs, you could do it with kernel parameters. Just add a random string as kernel parameter and then use /proc/cmdline as the key for your encryption. If it's not easy to add such parameters to your boot loader, the Linux kernel has a CMDLINE config option that lets you compile it in. (Note: it is possible for kernel parameters to ...


1

Hidden files are files with a name starting with a period, they are not displayed unless explicitely requested, by using the -a option or specifically mentioning dot in the argument list. eg `ls -la or ls -l .* file aliases are called links, they can be hard or symbolic. you have symbolic links there (the first character of permissions is an l denoting ...


1

I think the behaviour you see is just because the Vim backup process is slow. On my plain Ext4 system, this problem manifests as a "file is empty" error from the compiler. To check the timings, I used this Bash sequence: strace -tt -o /dev/stdout gvim --nofork main.cxx | grep 'main.cxx\|close' With backups turned on, I see a 200 ms gap between the file ...



Only top voted, non community-wiki answers of a minimum length are eligible