New answers tagged

0

I'm about to attempt this as well. From what I've read elsewhere, Kali doesn't include lvm in their default initrd. I'd suggest installing lvm and rebuilding initrd. Alternatively, reinstalling Fedora will likely result in getting the Fedora grub image, which should boot Kali fine.


2

As per the Manjaro Wiki entry on bootloader configuration: To deal with windows partitions, you will need to install the mtools and os-prober utilities: pacman -S mtools os-prober Then run the grub auto-update utility, which will now be able to access your windows partition update-grub Note: The config file /boot/grub/menu.lst is used by the old grub, ...


0

If no bootloader shows up in the boot process, this could be because you installed the bootloader on your ssd. Go into bios and tell bios to boot into your ssd instead of booting into your other harddrive where windows is installed.


0

You can always modify windows so that it loads the ubuntu bootloader instead of it's own. In windows, just open up cmd as admin, then enter: bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi Make sure that this is actually the right path for the elementary OS bootloader, otherwise your system might not boot at all anymore.


0

you can try sudo update-grub and see if windows is detected


0

I solved my issue by getting hints from this thread: http://superuser.com/questions/376470/how-to-reinstall-grub2-efi I did not need to use a live installation, I just booted into my ubuntu session through the grub window. I then reinstalled grub: $ apt-get install --reinstall grub-efi-amd64 This also did an update-grub automatically. It works and updated ...


0

So /dev/sda1 is probably the EFI system partition used by Windows, LFS and Mint. You can boot into them because the relevant files for these operating systems are inside /dev/sda1 and so is GRUB. Therefore, GRUB can detect them. However, the FreeBSD installation has created it's own EFI system partition in /dev/sda8 and this is the reason why update-grub ...


0

as it turns out it was a bootloader issue. This guide on the wiki fixed it for me. you will need a manjaro live disk for it to work though.


0

There is another solution mentioned here: Add FreeBSD to GRUB2 boot menu, which is: menuentry "FreeBSD" --class freebsd --class bsd --class os { insmod ufs2 insmod bsd set root=(hd0,1) kfreebsd /boot/kernel/kernel kfreebsd_loadenv /boot/device.hints set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ada0s1a set kFreeBSD.vfs.root.mountfrom.options=rw set ...


-1

Install Easy BCD. Delete existing Linux entry. Add new Linux entry. Save and exit.


1

You need to recreate the grub.cfg using the following command: grub2-mkconfig -o /boot/grub2/grub.cfg Or grub-mkconfig -o /boot/grub/grub.cfg


0

While I know this is a laptop, I don't know the brand so this is a bit of a leap. I had this happen a while back myself but due to different circumstances. I did a little digging and found this that should help you. Removing the CMOS battery did the trick for me. Link to resetting BIOS password


0

Some new laptop has new features which is secure boot. Disable it from bios and boot the system. More information can be find at https://blog.malwarebytes.org/security-world/2014/05/uefi-secureboot-and-dual-booting-windows-8-and-linux/


0

Disable Hibernation and Fast startup - boot into Windows - open command prompt as administrator and execute : powercfg /h off. Then open the Windows Control Panel, go to the Power Settings and uncheck Fast startup. Shutdown the PC completely - do NOT restart. Turn on the PC and boot into the BIOS, select Fedora to be the default system - reboot - now you can ...


1

I followed these instructions from It's F.O.S.S. to use bcdedit in an admin-priveledged command prompt, but with a slightly different path since it was Fedora instead of Ubuntu: bcdedit /set {bootmgr} path \EFI\fedora\grubx64.efi When I next rebooted I got to GRUB, which allowed me to boot into either Fedora or Windows.


0

Use Ubuntu live usb. Open gparted and format partition that you used for Arch.


4

There is no need to uninstall anything. You simply need to install Ubuntu and once you chose the partition to install on (your current ArchLinux partition), the installer will give you the option to format it.


1

If you hibernate a dual-boot machine, unmount all shared partitions. Make sure that the hibernation fails if any of the shared partitions can't be unmounted. You can relax this a little and set one of the OSes as the “owner” of a shared partition, under the following conditions: Only the owner ever mounts the partition read-write. Other OSes only mount it ...


5

It will use the swap partition, (especially) if it has an fstab entry for it. However your problem is not only with the swap partition, but also with all other filesystem partitions. You're not allowed to mount any of them as long as they're still mounted by the hibernated system. Only one OS is allowed to mount a filesystem at a time, and with Hibernation,...


1

Configure your grub file. grub-mkconfig -o /boot/grub/grub.cfg .It will find your windows boot manager and add boot menu entry for EFI configuration. Reboot the system.


0

You need to update grub.cfg , the new entries will be added automatically. From the existing OS (Ubuntu) open the terminal and type the following command: grub-mkconfig -o /boot/grub/grub.cfg


2

Boot repair is your tool unless you installed Ubuntu to the same partition and overwrote CentOS.


1

There's a tool that easily recovers/install GRUB to the MBR. http://www.supergrubdisk.org/category/download/rescatuxdownloads/rescatux-stable/ . Just burn the CD image to either a CD/DVD and boot from that disk. In the application window there's a GRUB category, click on "Restore Grub", then follow the instructions. There's also a youTube video in that ...


0

CentOS 6 doesn't include other Linux OS in the boot menu. Solution : Run an Ubuntu live-DVD (or a live Ubuntu from USB), and do : 1) sudo update-grub .... and 2) sudo grub-install /dev/sdb/ ( If you want to boot from sdb/.)


1

First if you aren't sure of what you are doing, make a backup of your important data. Then you have to follow 3 steps : Open GParted and resize your linux partition(s) in order to have at least 20Gb of free space. Boot on the Windows installation DVD/USB and select "Unallocated space" to not override your linux partition(s). Finally you have to boot on a ...


1

All the files you indicate you want to more are executables. You cannot just run these under Linux. You can try to run these under wine, but you'll have more success converting your W10 setup to a VM (VirtualBox or VMware) and run the programs under Ubuntu in such a virtual machine. On the other hand why bother with W10 stuff if you already have, or ...


4

You could: start the computer with both disks attached, boot into (your currently only choice) Debian run update-grub It should detect Windows on the first Disk, and add an entry to the boot-loader choices. And you could then optionally install grub also to the other disk boot sector by running grub-install /dev/sdb sdb is what I assume to be the ...


8

It depends on which boot-loader was installed. If its a standard Debian install it should be GRUB2. Boot the computer with all disks containing bootable installations attached and powered. you need to open Root Terminal application to open a terminal as root. then enter this commands. apt-get update apt-get install os-prober if os-prober package is ...



Top 50 recent answers are included