Tag Info

New answers tagged

0

I don't think you can install the free driver without changing the sources. I looked at https://wiki.debian.org/ath9k and https://wiki.debian.org/ath9k_htc/open_firmware as well as https://wiki.debian.org/ath9k_htc and finally at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=751339 . I looked at the versions of the packages mentioned in my jessie ...


2

The actual kernel code depends on the arch of your system. For x86 systems, they are located in arch/x86/kernel/reboot.c Halt will stop the machine, and leave it in power-on state. So it just stops the kernel, but usually does not power it off. static void native_machine_halt(void) { /* Stop other cpus and apics */ machine_shutdown(); ...


-1

Traditionally Software can control the Power Level by passing commands to a Shell or Subshell. You must be nice to users when using this approach and give them time to respond properly. Depending on your init system, you pass the init system a level. Following is a Table of Levels ...


0

Well in first place i will suggest to use any other distro that one featured by the US DoD (and probably with the intrution of the NSA), if you want security use tails[1]. Leaving this apart, the thing is fglrx is a propertary driver, so is hard to include it in a distro (and i don't have any clue about LPS base). Maybe you can just add the binary[2], ...


1

According to this kernel.org page on wireless drivers; yes you have the right driver! Whether or not a newer version (than what your distro supplies) would be better or not will depend... I have had newer versions of drivers work better but I have also had newer version work worse... So the best answer to that question IMO is another question: "Does it work ...


0

I was able to fix the issue by updating my kernel to 3.17.1-031701. Before doing it, though, you might want to check your own kernel version by using uname -a. For 32-bit systems: $ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17.1-utopic/linux-headers-3.17.1-031701_3.17.1-031701.201410150735_all.deb $ wget ...


1

According to your link the filename of the driver should be mt7601Usta.ko (.ko is the extension for kernel modules). Kernel modules are usually installed in /lib/modules/$(uname -r), so use find /lib/modules/$(uname -r) -name mt7601Usta.ko then sudo rm to delete it if you're sure it is the right module (or mv to move it out from the modules tree so it won't ...


0

You can take a look at how facter does it here. As Jan said, lsb_release is probably the best way to go, but it cannot be your only way. For example, lsb_release is not present by default on any of my RHEL servers: [damaya@damaya-sandbox script]$ lsb_release -bash: lsb_release: command not found [damaya@damaya-sandbox script]$ yum provides "*/lsb_release" ...


1

Most programs and scripts I've seen parse the usual files in /etc, AFAIK there's no other way: On Redhat, look for /etc/redhat-release On Debian, look for /etc/debian_version Mandriva has /etc/version and Slackware has /etc/slackware-version You could also use uname to get the ARCH or, probably the most sane way, use lsb_release.


1

NOTE: I'm on Fedora 20 but the issue would be the same here, only the pathing and Linux kernel version numbers are different. When I downloaded and attempted to run the install script, bash ./install.sh I noticed this error message as well. make: *** /lib/modules/3.16.3-200.fc20.x86_64/build: No such file or directory. Stop. The script isn't equipped ...


1

A lot of peripherals are removable (USB, Firewire, PCMCIA, hotpluggable PCI, etc.). Furthermore a system installation might be moved to new hardware if the old hardware failed or had to be upgraded. Linux distributions tend to provide all the drivers that you might possibly need, preferring to waste a few megabytes of disk space rather than tell you ...


0

In your case, I would suggest to do only the necessary updates as applicable to the system. According to redhat, there is no harm in installing these unnecessary updates but still it is not a good idea. Although installing an unnecessary driver update will not cause harm, the presence of a driver on a system for which it was not intended can ...


0

From the error message I would guess that means that the "diver is not new enough to support the nvidia-settings page" This is none too surprising since the GFX 5 series is over 10 years old which is like 80 in human years. The amazing bit is that nVidia maintained driver support for that antique through 2008.


2

Debian 3.2.60-1+deb7u3 x86_64 GNU/Linux 867Mbps 802.11ac Intel 7260 card, Dual band 5GHz + 2.4GHz Wireless 2x2 AC + Bluetooth4.0 Your kernel is too old. http://wireless.kernel.org/en/users/Drivers/iwlwifi says "IntelĀ® Wireless 7260 (3.10)", so you'll need at least Linux 3.10. Set up Debian backports, and install a newer kernel: aptitude -t ...


0

If you look at the output of lsmod it'll typically tell you which modules are loaded due to being a dependency of some other module. For example, in the case of bridge, it looks like stp & llc required it. $ lsmod | grep brid bridge 116006 1 ebtable_broute stp 12868 1 bridge llc 13941 2 stp,bridge ...


0

check out patch submitted to linux-mmc mailing list. http://thread.gmane.org/gmane.linux.kernel.mmc/22781/focus=22783


1

I found a fix to the compilation errors in another driver on this website: http://www.arnelborja.com/compiling-rt2870-wifi-driver-in-fedora/ below is the patch content: --- include/os/rt_linux.h 2013-09-12 13:27:14.000000000 +0800 +++ include/os/rt_linux.h.patched 2014-03-23 11:45:03.907628847 +0800 @@ -279,8 +279,8 @@ typedef struct file* RTMP_OS_FD; ...


4

According to the documentation, parameters for modules which are built into the kernel need to be specified on the kernel command line with a module name prefix. In this case add snd_hda_intel.enable=0,1 to your kernel boot line. You can check the value of the param with: cat /sys/module/snd_hda_intel/parameters/enable Some parameters can be set by ...



Top 50 recent answers are included