Tag Info

Hot answers tagged

8

That's because the /etc/hosts is simply a file on your Debian server that it utilizes for its own name resolution. It doesn't use the file to provide any DNS services. Since you don't want to set up BIND can I recommend that you look at dnsmasq instead? It's lightweight and can act as a DNS and DHCP server, simply by making use of your hosts file.


2

there is no such option built into DNS. And that is not an bind-specific thing. A usual workaround is "Global Load Balancer Service", often referred to as gslb in cloud-contexts. This method does health checks on your services and replaces the a record with a "working one" in combination with a low TTL. But it has a little switchover time. About the local ...


2

I believe what you're looking for is in /etc/nsswitch.conf From the man page: The Name Service Switch (NSS) configuration file, /etc/nsswitch.conf, is used by the GNU C Library to determine the sources from which to obtain name-service information in a range of categories, and in what order. ... Here is an example ...


1

edit /etc/resolv.conf ; add, nameserver ip.ad.dr.es lines. You are supposed to add a nameserver or two for failover. Usually you'd use nameservers that your ISP provides, but using 4.4.2.2 and similar is ok if you want to give them your browsing habits


1

During installation, DHCP is used to discover the network setup. This includes the IP address as you noticed, but also the subnet, default gateway, and optionally the domain name and nameservers. All the available information is used to set the network up and is stored in the appropriate files for future reference (/etc/network/interfaces, ...


1

By default, OpenVPN does not reconfigure the DNS on non-Windows. You could use a hook (sorry the explanations are in French) in order to do this: #!/bin/sh # Write foreign options to stdout: foreign_options() { local i while true; do local varname=foreign_option_$i local value="$(eval echo \$$varname)" if [ -z "$value" ]; then ...


1

dnsmasq is somewhat unreliably at the moment on my barrier breaker, which results in nslookup: can't resolve 'starkill': Name or service not known here as well, even if the name can normally be resolved without problems. first try a killall -HUP dnsmasq or even a restart if you like to be sure dnsmasq actually serves requests as it should. second, ...


1

I had a similar experience and concluded that the interaction and scripting with Cisco AnyConnect was adding DNS hosts dynamically. On a Debian-based distro such as yours (I am on Linux Mint 17.1 Rebecca), I found that installing network-manager-openconnect-gnome provided a helpful configuration interface for DNS parameters and the like, and provides a very ...



Only top voted, non community-wiki answers of a minimum length are eligible