Tag Info

New answers tagged


I was fighting this myself. I got close with setarch i686 dnf builddep wine --best --allowerasing but it bombs out in conflict hell. It seems to think the i686 packages are installed when only the x86_64 versions are there. For instance package cups-devel-1:2.0.3-1.fc22.i686 is already installed when rpm -q cups-devel only lists ...


I found a solution that works. To iterate my steps: 1) Download relevant RPM (or here) 2) Copy to Linux server and upack using (replace filename as necessary) rpm2cpio git- | cpio -idmv 3) Update $PATH: PATH=$PATH:<your path to git>/usr/bin 4) Now see it work git --version


I guess that if you can't install dependencies then you are out of luck. If you can't install package(and its dependencies), then your best shot would be compiling it yourself - but that too would need dependencies(there is no magic to leave them out). Also, compiling requires compiles(as name suggests), so if you can't get a compiler, then you're in a bad ...


You can download the git source and do ./configure --prefix=/home/user/myroot && make && make install to install git to your home directory provided you have the build tools. If you don't have the build-essential package installed (dpkg --list|grep build-essential), you will need to install those to your home directory as well. Copied from ...


sudo apt-get install -f followed by sudo apt-get install virtualbox


Qt 5 is built by the qtbase-opensource-src source package in Debian. Looking at the linked tracker page shows that the version in Jessie (stable) is 5.3.2+dfsg-4-deb8u1, so basically 5.3.2, which is older than 5.4... 5.4 is available in Stretch (the next version of Debian, currently in development), and 5.5 is in experimental (a sort of staging area for ...


Another solution would be to run apt-cache rdepends libplrpc-perl.


It seems that the local repository was out of date, solved after typing : sudo apt-get clean


You've got a newer libc6 than is available in the Maverick repositories. To revert to the appropriate version for Maverick, you can run sudo apt-get install libc6=2.12.1-0ubuntu10.4 libc-bin=2.12.1-0ubuntu10.4 libc6-dev=2.12.1-0ubuntu10.4 libc-dev-bin=2.12.1-0ubuntu10.4 If the newer libc6 was installed to support some other package, then you'll need to ...


I had this problem, having installed the 3.19 (Vivid) kernel on 14.04. As per the Ubuntu wiki's LTS Enable Stack page you need to: sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid You should ...


A dependency where the package name contains a colon is for multiarch. The format of this dependency is PACKAGE-NAME:ARCH (plus an optional version specification). The architecture part can be any to indicate that the dependecy can be met cross-architecture. The multiarch spec even gives python:any as an example. Most dependencies on Python require it only ...


The three dependencies for Python are: python (>= 2.7) python (<< 2.8) python:any (>= 2.7.1-0ubuntu2) The net effect is to require Python from the 2.7 series (e.g. not 2.6, not 3.x) but no older than 2.7.1-0ubuntu2. The first two taken together are a way of saying that you need to have Python 2.7 installed but it is allowed to be Python ...

Top 50 recent answers are included