Tag Info

Hot answers tagged


You have the client (and, I believe, also the server) installed. But you're not running the server on your machine (it's not started by default on Crux). Add sshd to the SERVICES setting in /etc/rc.conf. See the handbook. This will take care of starting the SSH server at boot time. For now, run /etc/rc.d/sshd start. As per the FAQ, you may want to ...


You are printing random error messages since igetuid() did not (and can not) fail. You only use perror() after a system call fails, and only once.


The problem was nothing with the setting, but was about my own design of the kernel. After revising some of the bug, the kernel can be booted successfully:


Is your sshd running? ps aux | grep sshd. Is it running on the standard port? less /etc/ssh/sshd_config

Only top voted, non community-wiki answers of a minimum length are eligible