Tag Info

Hot answers tagged

9

Assuming your governor is the intel_pstate (default for Intel Sandy Bridge and Ivy Bridge CPUs as of kernel 3.9). This issue is not specific to Arch, but all distros using the new Intel pstate driver for managing CPU frequency/power management. Arch linux CPU frequency scaling. Theodore Ts'o wrote his explanation on Google+: intel_pstate can be ...


6

You will have to check what is the governor you are using. This guy will pretty much influence your clock change depending on the demand the processor is having. Probably the governor you need is: Performance: scaling_min_freq and scaling_max_freq will be set to the max. To change your processor frequency governor: cpupower frequency-set -g performance. ...


6

I have found the solution thanks to the tip given by Nils and a nice article. Tuning the ondemand CPU DVFS governor The ondemand governor has a set of parameters to control when it is kicking the dynamic frequency scaling (or DVFS for dynamic voltage and frequency scaling). Those parameters are located under the sysfs tree: ...


4

That won't work. The number of clock cycles each instruction takes to execute ( they take quite a few, not just one ) depends heavily on the exact mix of instructions that surround it, and varies by exact cpu model. You also have interrupts coming in and the kernel and other tasks having instructions executed mixed in with yours. On top of that, the ...


4

You could use laptop-mode-tools. You can specify the governor and max/min frequency while on AC or BATTERY via config files. (Archwiki page) Another option which gives you more control (rules per battery level) is Cpufreqd (thinkwiki page). You can also tune your cpu based on acpi events (Archwiki page)


4

Here are some tests done by the folks @ IBM: cpufreq tuning results They're not specifically testing battery life but should give you an idea about ondemand - versus - conservative power consumption.


4

From the conky man page. cpu (cpuN) CPU usage in percents. For SMP machines, the CPU number can be provided as an argument. ${cpu cpu0} is the total usage, and ${cpu cpuX} (X >= 1) are individual CPUs. freq_g (n) Returns CPU #n's frequency in GHz. CPUs are counted from 1. If omitted, the parameter defaults to 1. You most likely have ...


4

This is related to a new driver introduced in Fedora 20 that does not need more than those two governors. See this thread CPU Governors - where is ONDEMAND? for details. To have the missing governors, you should boot with the kernel parameter intel_pstate=disable. To do so, in the GRUB boot screen, choose "edit boot commandline" and add this to the line ...


4

Try installing lm-sensors and fancontrol, they can take care of setting the right RPM for your fans. Alter installation run sensors-detect (as root). It should give you a name of a kernel module at the end of the putput: To load everything that is needed, add this to /etc/modules: #----cut here---- # Chip drivers it87 #----cut here---- You have to add ...


3

Your system is using intel_pstate driver. There are only two governors available when using this driver: powersave and performance. The userspace governor is only available with the older acpi-cpufreq driver (which will be automatically used if you disable intel_pstate at boot time; you then set the governor/frequency with cpupower): disable the current ...


3

It should be pretty obvious: time spent executing a task / total time. So over a given interval, 10% load means 10% of that time was spent executing tasks, and 90% was idle.


3

This is normal behavior. This behavior is part of the system attempting to conserve power by constantly adjusting the system's CPU speed. Take a look at my answer on this other U&L Q&A titled: How does CPU frequency work in conky?. ...


3

Most CPU's now include the ability to adjust their speed to help in saving on battery/power usage. It's typically called CPU frequency scaling. The realtime speed of the CPU is reported by this: $ sudo cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq The absolute (max) CPU speed is being reported by this: $ cat /proc/cpuinfo Specifically this ...


3

It is not the guest that triggers the upscale - the host must do this. So you have to lower the according trigger-level on the host.


3

This is not yet close to be a definite answer. Instead, it's a set of suggestions too long to fit in comments. I'm afraid you might slightly misinterpret the meanings of sysfs cpufreq parameters. For instance, on my Core Duo laptop, the related_cpu parameters for both cores read 0 1 - which, according to your interpretation, would mean that the cores ...


3

That shows the current CPU frequency, you've probably got CPU frequency scaling activated, so your CPU "slows down" when there's not much to do, and if you do something CPU intensive it should speed up to 2.8 and/or something in between, it's normal.


3

This can be done with the cpufreq-set command from cpufrequtils. Here is an example: cpufreq-set -f 1700


2

The cpupower.service unit provided with Archlinux reads its settings from /etc/default/cpupower. Either uncomment the governor setting, or add a new line so that governor='powersave'.


2

For 3.x kernels The interface to CPUFreq has changed in the newer kernels. This would include CentOS 6. You can read about the entire interface here in the Red Hat Enterprise Linux (RHEL) documentation titled: Chapter 3. Core Infrastructure and Mechanics. Specifically the section on CPUFreq Setup. Here are the steps required to set it up. CPUFreq drivers ...


2

org.gnome.CPUFreqSelector sounds like DBus but googling revealed it could be a PolicyKit issue. Maybe this helps, granting the applet CPUFreq changes. I think you don't need the cpufreq-selector tool, you could just use cpufreq-set directly (maybe with sudo, I'm not sure). (Or the cpupowerutils frontend, alive here) (Edit to match your updated question) ...


2

on the host, a kvm cpu looks like a process. The scaling mechanism doesn't watch processes, only the overall cpu consumption. and it is generally best practice to disable cpu scaling/throttling/etc when running VMs


2

Alright , this was said to be a bug with Thinkpad , When your battery is unplugged , and connected to AC power higher than 65W , the freq will stuck at lowest , check the /sys/devices/system/cpu/cpuX/cpufreq/bios_limit , to see if it's stuck. Source: http://www.thinkwiki.org/wiki/Problem_with_CPU_frequency_scaling I got it solved by passing kernel ...


2

You can use the ondemand cpu-freq governor, as long as you set the ignore_nice_load parameter to 1. From Documentation/cpu-freq/governors.txt, ondemand section: ignore_nice_load: this parameter takes a value of '0' or '1'. When set to '0' (its default), all processes are counted towards the 'cpu utilisation' value. When set to '1', the processes ...


2

Try cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq command


2

As far as I know, the "load Average" is the average number of process requiring cpu execution time over 1/5/15mintes. For example, say you have 1 CPU with 4 cores, any load superior to 4 means you don't have enough computing power to have all process running as fast as they wish.


2

cpufreq-info - Utility to retrieve cpufreq kernel information. It will list available frequency steps, available governors, current policy etc. cpufreq-set - A tool which allows to modify cpufreq settings (try e.g. cpufreq-set -g performance or cpufreq-set -f 2 GHz once you know what frequencies your CPU can be set to) You can also retrieve information ...


1

There are still a couple of options left, please refer to Arch wikipage. The one you are looking for, specifically, is thermald.


1

cat /proc/cpuinfo output also has the cpu MHz sample out processor : 0 vendor_id : GenuineIntel cpu family : 6 model : 42 model name : Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz stepping : 7 microcode : 0x14 cpu MHz : 3101.000 cache size : 6144 KB physical id : 0 siblings : 4 core id : 0 cpu cores : 4 apicid : 0 initial ...


1

There are various programs/files that give you this information: lscpu | grep -i MHz cat /proc/cpuinfo | grep -i mhz (though this information is apparently absent in your system) cpufreq-info, this one is the most comprehensive: $ cpufreq-info cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009 Report errors and bugs to ...


1

Looks at this SOa: http://stackoverflow.com/a/15213255/438544 It mentions these three links: http://shallowsky.com/blog/linux/kernel/sysfs-thermal-zone.html http://lwn.net/Articles/268958/ http://www.mjmwired.net/kernel/Documentation/thermal/sysfs-api.txt They mention that on newer systems you should have all thermal information under: ...



Only top voted, non community-wiki answers of a minimum length are eligible