Tag Info

New answers tagged

1

Once someone has physical access to the system, there is little you can do. Your best bet would be something like TrueCrypt on all your hard drives, and as we'll as removing the CD and floppy drives as stated in an above answer, hot glue over the SATA/IDE connectors to prevent anyone plugging a CD drive in . Set a really good password on BIOS/ UEFI and turn ...


0

How completely do you want to block console access? If it is just for when the system is up and running then you can simply disable getty from running. Look at /etc/init/console.conf and /etc/init/tty?.conf. If you want to make sure that nobody reboots into a live cd then your best bet is to epoxy the USB ports and remove the cd drive from the system.


3

I'm not sure (it has been a while) but it looks to me that is a reference to the old Linux routine (1992): ftp://ftp2.de.freebsd.org/pub/linux/tsx-11/sources/usr.bin/doshell.c: #include <stdio.h> #include <sys/file.h> #include <errno.h> extern char *sys_errlist[]; main(int argc, char *argv[]) { if (argc != 3) { fprintf(stderr, ...


1

I've filed a report and indeed it is confirmed as a bug. Found this workaround: On the computer running Wheezy: $ sudo dumpkeys -l > mykeys.txt On the computer running Jessie, I've added this to /etc/rc.local: loadkeys /path/to/mykeys.txt


0

I was eventually able to solve this by adding the following command to one of my startup scripts: klogconsole -l 3 This seems to make the system shut up. (At least, after the point where the command is executed.)


1

If Miroslav Koskar's suggestion regarding kernel loglevel did not help (you might as well use 2 or 1 there instead of 3, IMO), have a look in your /etc/syslog.conf (or rsyslog.conf) for a line containing /dev/console. This indicates the level of messages that are passed to the console by the system logger, which maybe the case if the kernel isn't doing it ...


3

Boot with: quiet loglevel=3 For info: quiet [KNL] Disable most log messages loglevel= All Kernel Messages with a loglevel smaller than the console loglevel will be printed to the console. It can also be changed with klogd or other programs. The loglevels are defined as follows: 0 (KERN_EMERG) system is ...


1

If the messages have numbers before them, these are messages produced by the Linux Kernel. (The number means the number of seconds since the system was booted up.) To stop these messages, add the quiet parameter to your kernel command line. You may do this by editing a file in the /boot partition or using a configuration tool provided by your bootloader, ...


0

On Linux you can use strace to see which system calls a program uses. The following will list all "open(2)" system calls and filter them through sed to show, hopefully, the terminfo file used by tput to translate the terminfo capability for the current terminal. TERMINFO_FILE=$(strace -e open tput cud1 2>&1 | sed -n -e ...


0

I searched a bit further in Google and found the solution: I needed to boot with the nomodeset option. After adding this to the grub.cfg file the issue was solved.


12

That's what col -b is for: $ printf 'a\bb\n' | col -b | od -tc 0000000 b \n 0000002 $ printf 'aaa\b\b\bbb\n' | col -b | od -tc 0000000 b b a \n 0000004 The sed equivalent would be something like: bs=$(printf '\b') sed "s/^[^$bs]*/&\ \ /;:1 s/\n.\{0,1\}\(.*\n\)\([^$bs]\)/\2\ \1/;s/\(.\{0,1\}\)\n\(.*\n\)$bs/\ \1\2/;t1 s/\n//g" Dating to ...


5

Try sed if used in ksh93/zsh/bash printf "Foo\b\b\bBar\n" | sed -e :a -e "s/.\{0,1\}"$'\b'"//;ta" > test.log or more portable printf "Foo\b\b\bBar\n" | sed -e :a -e "s/.\{0,1\}$(printf "\b")//;ta" > test.log or GNU sed: printf "Foo\b\b\bBar\n" | gsed -re ":a;s/.?\x08//;ta" > test.log Note: this approach treats '\b' as a backward erase ...


1

The console=ttyO2 allows you to see the kernel and system messages on the corresponding serial port. It does not affect the boot process otherwise - the system will boot even without a console. Remember to edit /etc/inittab - change ttyS2 to ttyO2 there to get a login prompt on the serial console once the system boots. Your new kernel is probably missing ...


1

You have two different keymaps. One used by your graphical environment (X) and one used by you console. The first one is configured by xmodmap and setxkbmap. The second one is configured by loadkeys. You can dump the first one with xmodmap and the second one with dumpkeys. Have a look at the man pages of those commands to find the correct options and ...



Top 50 recent answers are included