Tag Info

New answers tagged

1

Despite what file says, it turns out to be debugging symbols after all. A thread about this on the LKML led me to try: make INSTALL_MOD_STRIP=1 modules_install And low and behold, a comparison from within the /lib/modules/x.x.x directory; before: > ls -hs kernel/crypto/anubis.ko 112K kernel/crypto/anubis.ko And after: > ls -hs ...


0

After your make oldconfig, do a make vmlinuz. I think you'll find that the pre-compiled kernel is a "executable bzImage", which means it's compressed on-disk. If you watch boot messages closely, you'll see it uncompressing the kernel very early on in the process.


0

The core language system for Python requires certain development packages to be installed. Some modules that are part of the "batteries included" module system of Python require additional packages, but if you don't have those packages installed, these modules will not compile without affecting the core language (and if you are lucky fall back to a pure ...


2

I have a few ways to do this, easy ones first: Making the install prefix flexible is hard - I would just make the install prefix to your home directory, or somewhere that you can access on any of the machines, and use make install DESTDIR=/path/to/place/where/binaries/should/be/installed to install them to somewhere other than the prefix. I personally have ...


0

The actual error, and moderately annoying part, is that the library requested / not found, WAS JUST COMPILED, and then fails to link itself. The library actually exists in a different directory than is enumerated by the scripts that configured the build. They havent fixed it in 5.7.2.1 either: During compilation, the following command is run: ...


0

The files you say are missing, is because only Debian provides them, transmission sources doesn't have any init script to start. So as you noticed checkinstall can't figure this out. The best course of action is copying the debian/ directory of upstream and compiling using debuild -us -uc instead.


0

CC='' tells me, you no compiler is set. Do you have gcc installed? Try which gcc On debian you probably need to install a build environment with apt-get install build-essential or even better apt-get build-dep you-package-name .


2

From the output you've given, you are trying to compile a 32-bit build of apache on a 64 bit system. This is from the intput to configure here: --host=x86_32-unknown-linux-gnu host_alias=x86_32-unknown-linux-gnu CFLAGS=-m32 LDFLAGS=-m32 Also see the output lines confirming this: configure:3629: checking build system type configure:3643: result: ...


1

The issue is that one of the kernel headers / interfaces changed in a recent 3.x kernel. Where a UID / GID values were originally referred to as regular integers, they are now structs with a single element. Any code relying on the older definition now will fail to compile until updated to match the new kernel headers. I'm currently experimenting with ...


0

The location of libraries might differ between fedora on ubuntu. This could cause a build for fedora not to function on ubuntu and vice versa.


0

I have tested your answers, and in fact, rewriting this line fixes the issue: // cflag = tty->termios->c_cflag; cflag = tty->termios.c_cflag; The vizzini.ko driver compiles fine, and it can be loaded with insmod.


0

../include/id3/id3lib_strings.h: In static member function 'static std::char_traits<unsigned char>::char_type* std::char_traits<unsigned char>::move(std::char_traits<unsigned char>::char_type*, const char_type*, std::size_t)': ../include/id3/id3lib_strings.h:87:72: error: 'memmove' was not declared in this scope ...


1

In addition to the patches listed here you need to patch link.c from vmhgfs.tar. 184a185 > #if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 14, 99) 187a189,194 > #else > LOG(6, (KERN_DEBUG "VMware hgfs: HgfsReadlink: calling " > "readlink_copy\n")); > error = readlink_copy(buffer, buflen, fileName); > ...


1

Stuff in /usr/local usually supersedes stuff in /usr, so I'm a bit confused as to why you would install libraries there to have a "a nice custom distro", but then not want to compile against them. Those are the libraries the system will use actually use. Anyway, man pkg-config claims the base search path: is libdir/pkgconfig:datadir/pkgconfig where ...


0

wxwidgets is a simple tool kit for making quick GUIs. In OpenSuSE you can install it with the following: zypper in python-wxWidgets as root After that, you'll be able to run it with no problem. If you are still having problems, make sure the "openSUSE-*-Oss" repo is enabled. Where * is your distro number.


0

You should just install package named python-wxwidgets, which is available in openSuse.


-1

You want wxpython, which apparently isn't available for openSUSE. You can follow instructions on their website to build it from source. Roughly: $ ./configure --with-gtk $ make $ su # make install # ldconfig


2

I want to add these file into my kernel such way that when kernel start this hello.o file execute and run What you are trying to achieve shouldn't be made through kernel edition. Executing a program at boot time can be handled in much simpler ways, without need for kernel programming experience. You can: Execute it when your shell starts: Write ...


1

Or should I simply ignore it? Unused variables could be an indication of a coding mistake. If you are satisfied this is not the case and want to suppress the warning for a particular variable, you can use a (GCC specific) __attribute__ tag, e.g.: /* Unused parameter (in definition, not declaration): */ void somefunc (int x __attribute__ ((unused))) { ...


1

"Variable set but not used" warnings are informational. According to the official documentation, -Wunused-but-set-variable controls the behavior of: Warn[ing] whenever a local variable is assigned to, but otherwise unused (aside from its declaration). This warning is enabled by -Wall. The purpose is to catch situations where the programmer assigns a ...


0

I haven't looked in detail. The defconfig file was last editer 4 years ago; it's quite possible that some options have changed in the kernel source and nobody bothered to update this particular file. Try looking in the kernel logs to see if these options have disappeared. Compare with other msm*_defconfig, which have been updated more recently. The readme ...


1

In general, ./configure && make && make install without any parameters sticks everything under /usr/local, which would place foo.pc in /usr/local/lib/pkgconfig/foo.pc To make use of this, you'd need to do basically PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:${PKG_CONFIG_PATH} pkg-config --cflags foo, or, compile in this manner: ./configure ...


0

This is about confusing two different SDK1. getopt_long exists on QNX6.6. But the libc version on the Playbook doesn't have that as it has an earlier version of /proc. The error would have never happened if I had installed the Playbook OS Native SDK v2.1.0 instead of blindly following the link in the project, which will install the Native SDK v10.3 with the ...


1

PHP extensions can be compiled statically or shared. Static compilation puts the extension directly into PHP (therefore it does not need to be loaded and cannot be unloaded). When using shared compilation --enable-calendar=shared that will create file calendar.so. You can enable or disable it by editing php.ini.


2

You need to verify $PATH and $LD_LIBRARY_PATH environment variables. make sure they are point to correct version of ffmpeg and does not include older version if LD_LIBRARY_PATH is not already setup then try this : LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib ffmpeg


0

I've been searching for this but am not finding much about it either. There's the command help bdinfo which might prove helpful to you but that's about it. I might be inclined to find the source for bdinfo and take a peek at it to see if it sheds further light on what's what in the output. top level of repo source for bdinfo


4

The test is done by compiling a small dummy C program and by checking how the compiler names the output file. The following example is a simplified version of what configure is doing #!/bin/sh cat << EOT > dummy.c int main(int argc, char ** argv) { return 0; } EOT gcc -o dummy dummy.c if [ -f dummy.exe ] ; then # exe fi I would suggest ...


-1

This will give you the extension of the file: FILENAME=/tmp/testfile.exe echo "${FILENAME##*.}" result: exe


0

This sounds like your issue in this forum post about peak titled: PEAK 7.8 Drivers - Debian. You need to make sure that the Linux Kernel source is installed, so that you can compile this driver. $ sudo apt-get install linux-headers



Top 50 recent answers are included