Tag Info

Hot answers tagged

16

There are many color schemes which are usually distributed together with vim. You can select them with the :color command. You can see the available color schemes in vim's colors folder, for example in my case: $ ls /usr/share/vim/vimNN/colors/ # where vimNN is vim version, e.g. vim74 blue.vim darkblue.vim default.vim delek.vim desert.vim elflord.vim ...


6

You can do it manually with this command: :hi Comment guifg=#ABCDEF Where ABCDEF is an appropriate color hex code. To make it permanent, you will need to add these lines to your ~/.vimrc file (using green as an example): syntax on :highlight Comment ctermfg=green


5

As you are using a dark background in your terminal, you simply need to set :set background=dark instead of the default :set background=light The colors are then automatically correctly set. If you want to have this permanently, add the line set background=dark to your $HOME/.vimrc file.


4

The gs example The gs command you're running above has a trailing $1 which is typically meant for passing command line arguments into a script. So I'm not sure what you actually tried but I'm guessing that you tried to put that command into a script, script.sh: #!/bin/bash gs -sOutputFile=output.pdf \ -q -dNOPAUSE -dBATCH -dSAFER \ ...


3

The important part of that wikia link is: :set t_Co=256 Entering this in normal mode (or putting it in your ~/.vimrc) will force vim to try to use 256 colors, which should override gnome-terminal's color scheme. Apparently, while gnome-terminal is capable to 256 colors, it doesn't advertise that fact in a way that vim can detect, which is why setting ...


3

One option I found was in terminal preferences (top menu, not the window). This has profile preferences and then a color tab, e.g. Changing the Palette entry 5 from Dark blue to Light Lilac helped. I finally chose xterm as the color scheme and lightened up the comment color e.g.


1

I believe it's partially a function of your terminal type, for one. $ echo $TERM xterm-256color This post might also be worth a look, titled: Piping Ls Through Less With Colors on Mac OS X. Also this setting might prove helpful. $ export LESS="-erX" -or- $ export LESS="-eRX" You can consult the man page for less to find out more about the ...


1

You need to set the bit depth to 1. For Xorg, you want to fiddle with: Section "Screen" SubSection "Display" Depth "x" in your /etc/X11/xorg.conf. Reading the xorg.conf(5) man page you'll discover: Depth depth This entry specifies what colour depth the Display subsection is to be used for. ... The range of depth values that are ...


1

I found a script here that can do this. It requires gs which you seem to have but also pdftk. You have not mentioned your distribution but on Debian-based systems, you should be able to install it with apt-get pdftk You can find RPMs for it here. Once you have installed pdftk, save the script as graypdf.sh and run like so: ./greypdf.sh input.pdf It ...


1

I had precisely this problem a little while ago, the solution is to place the following line in your vimrc file: set t_Co=256 And then you might have to put the following at the end of your your ~/.profile: #set vim terminal to 256 colors. if [ -e /usr/share/terminfo/x/xterm-256color ]; then export TERM='xterm-256color' else export ...


1

No, if it's connecting directly to the printer, you cannot set "defaults" unless the program that is making the connection has some way to do so. (This is not OS-dependent.) You would need to do something much more complex, such as using iptables to intercept the connection and redirect it to a program which filtered the data.


1

Save a python script like this: #!/usr/bin/python from PIL import Image, ImageFont, ImageDraw import sys im = Image.new('CMYK', (1000,1000), (0, 0, 0, 255)) f = ImageFont.load_default() d = ImageDraw.Draw(im) d.text((500, 500), sys.argv[1], font = f, fill = (0, 0, 0, 0)) del d im.save(sys.argv[2]) Dependencies are python and the python imaging library. ...



Only top voted, non community-wiki answers of a minimum length are eligible