Tag Info

New answers tagged

1

If you do: stty eol = And then run the demo suggested in your EDIT, you will see foo bar in the printout of test.out. The terminal's line discipline will flush its output to its reader as it reads each special eol char in your input. A Linux canonical-mode terminal - as can be configured with stty icanon or probably just stty sane - handles the ...


1

Copy/paste between Wayland windows and XWayland windows does not work yet (it has not been implemented). I can't manage to find any official source on this, but here are a couple of links to posts saying exactly this: http://www.phoronix.com/forums/forum/software/desktop-linux/49641-gtk-3-18-plans-for-full-wayland-support-a-scenegraph?p=631866#post631866 ...


0

Copy to your clipboard with: xclip -sel clip < ~/path/to/file.txt


3

This answer is not the most-specific for the user's question Please see my 2nd answer. I am leaving this here because it addresses the more general issue. Per the comments to your original post, you need (1) a terminal emulator which supports bracketed paste and (2) corresponding support for whatever is running in the terminal, ie, vim, bash, zsh. Terminal ...


0

I found solution for me: Right click on virtual machine -> setting -> networking and change Attached to: Bridged Adapter After change the setting do command shutdown -h now in your virtual machine. hint: (ip addr help to find ip address). At now your can ssh to virtual machine (from your terminal host machine). Thanks for help.


16

Use the vim paste. What you want is to paste what is on the clipboard buffer "+p This selects the + and pastes it in place. If your using Linux * is the x buffer (the last selected text) Then vim knows its a paste What happens otherwise is vim thinks you have typed the keys being pasted (which include the indentation combined with vim doing auto ...


48

There're two reasons: Auto insert comment Auto indenting For pasting in vim while auto-indent is enabled, you must change to paste mode by typing: :set paste Then you can change to insert mode and paste your code. After pasting is done, type: :set nopaste to turn off paste mode. Since this is a common and frequent action, vim offers toggling paste ...


5

The tabs were inserted because you have autoindent turned on and you can disable that behavior by turning off autoindent (:set noai) before you paste into terminal. The commented lines are produced by auto commenting and can be disabled by turning that off. Alternative to those you should get the desired behavior using the toggles :set paste, pasting ...


1

From what I tried, it seems that I can not reproduce your issue of joining short lines. The text gets pasted or inserted always with the newlines. Pasting the clipboard with Ctrl-V works, pasting the selection with the middle mouse button works too. But your actual problem to solve may* be to paste a section of text as a citation, keeping the line ...



Top 50 recent answers are included