Tag Info

New answers tagged

0

Based on comment from Gilles I managed to fix this issue. The problem was missing pl_PL locale. I found instructions on PC LOAD LETTER blog: cd ~/sometemp wget http://sourceforge.net/projects/dsgpl/files/DSM%203.1%20Tool%20Chains/Marvell%2088F628x%20Linux%202.6.32/gcc421_glibc25_88f628x.tgz tar xvfz gcc421_glibc25_88f628x.tgz cd ...


1

"á" is 341 No, it isn't. Your character set is UTF-8, in which á is character U+00E1 which is encoded as the two-byte sequence \xc3\xa1 = \303\241. When you write \341 in the argument to tr, it's interpreted as the byte \341. it doesn't knows the extended ASCII table chars Yes, it does — except that there's no such thing as “extended ASCII table ...


0

Use strings e.g. $ printf 'XXXhelloá\nYYY' | strings -es -n1 XXXhello YYY strings has various options (man strings for details) for extracting text (including, with -es, only 7-bit characters) from an input string or file. If you want to exclude more 'special' characters you can use sed: # printf 'someárvíztűrő tükörf\túrógép\ntext' | LANG=C sed ...


-1

You can set the language environment to Russian. M-x set-language-environment If you than open your file it should be readable.


2

The output is garbled because of locale(current language) setting. Doing LANG=C disables the localization (sets it to default language). So the solutions to your problem is either disable localization and do $ LANG=C psteree or ask pstree to print ascii characaters by $ pstree -A


0

Issue #1: grepping "Flyers: Video Center"... I don't see the result : In the hexadecimal dump of the file, notice the two bytes C2A0 between the words Flyers: and Video. This is a the UTF8 encoding for Non-breaking space. grepping NBSP is known to fail For more information, read How to remove special 'M-BM-' character with sed and use sed to replace ...Hex ...



Top 50 recent answers are included