Hot answers tagged

10

It seems that support for that particular chip or firmware version is still not very stable. The message is telling you to pass an option to the b43 kernel module to activate support for your chip version. This may improve things or not. To do so, create a file /etc/modprobe.d/local-b43.conf containing the lines # Activate experimental support for some ...


9

As of version 3.19, this device is supported in the Linux kernel, but you need to manually provide the device's firmware to the kernel. Finding the Firmware: You can find the firmware in the device's Windows driver, which you can download from Lenovo (or your computer manufacturer's website). Many drivers can just be unzipped, but for this particular ...


4

I was originally running kernel 3.7.4-204.fc18.i686 with kmod-wl-3.7.4-204.fc18.i686-5.100.82.112-7.fc18.8.i686 and the wireless had issues. After 2 more updates of the kernel it just works fine. So this is what I have running and working good now: sly@localhost ~$ uname -r 3.7.6-201.fc18.i686 sly@localhost ~$ rpm -qa | grep -e '-wl' | sort akmod-wl-5.100....


4

According to https://wiki.debian.org/wl you can try disabling power management, e.g with iwconfig wlan0 power off


3

Following drs' using a shortcut, I managed to get the file and got possitive results. My bluetooth devices wasn't able to detect nearby visible devices, but now is. The shortut I used was that since my computer has no optical drive and has Windows preinstalled, it came with a partition full of drivers. I found a directory with heaps of bluetooth drivers but ...


3

EDIT Broadcom 4360 actually comes with either of two distinct chips, 14E4:4360 and 14E4:43A0. There is no driver in Linux for the first one, while wl is an appropriate driver for the second one. You can determine which one you have by means of the following command: lspci -vnn | grep -i net If instead you wish to do this from within Mac OS, hit the ...


3

According to the ArchWiki, you must blacklist b43 module because it conflicts with brcmsmac.


3

To unload modules you can use these 2 commands, lsmod and rmmod. lsmod will list what modules are loaded, while rmmod will remove a given module from the Kernel, assuming it was dynamically built so that it can/could be dynamically loaded. $ sudo lsmod | head -5 Module Size Used by bluetooth 89276 0 cpufreq_powersave ...


3

You need to put if_bwn_load="yes" in /boot/loader.conf. If you don't have a /boot/loader.conf file on your system, just create it. As with the /etc/defaults/rc.conf file, /boot/defaults/loader.conf contains default values that can be overridden in a per-system fashion. Of course, you'll need to either reboot the system to pick up the new setting, or load ...


3

It is not possible because it's not driver who uses this SRAM, it's adapter itself. This SRAM contains hardware registers of Ethernet chip that are used by driver to communicate with it and is physically arranged this way. And it is not unique for this driver, it's very typical way of interacting between different hardware components in computer system.


3

My educated best guess: No, it's not possible to completely disable the SRAM. A quick look in the Linux tg3 driver code drivers/net/ethernet/broadcom/tg3.* reveals that SRAM operations are like everywhere in there. For example, it even appears to contain the MAC address: #define NIC_SRAM_MAC_ADDR_HIGH_MBOX 0x00000c14 #define NIC_SRAM_MAC_ADDR_LOW_MBOX ...


2

Check the output of lsmod to see if they are being loaded; if not, try to modprobe $module to load it manually. If this does not help you are probably using the wrong driver for that particular card. If it works, run depmod -a to regenerate module dependencies. It should load it automatically afterwards.


2

For the benefit of people landing on this page There is a bug raised on launchpad In the comment #29 there is a solution provided that is to reload the wl module: modprobe -r wl && modprobe wl


2

for some reason the ar9721.fw file was empty… downloaded the file again – put it into /lib/firmware and now it works…


2

As mentioned, this is due to a bug in the driver. The new Broadcom source has already patched this so there's no need to manually patch it. For A X64 System try mkdir broadcom cd broadcom wget http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz tar xzf http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-...


1

Getting a Broadcom chipset to work with linux is a royal pain, especially if you have to go the "bw43-fwcutter" route to get otherwise unobtainable firmware blob. I was never able to get an older Broadcom PCMCIA card to do injection under Arch linux. The Arch linux wiki has a Broadcom Wireless page that has a section for the wl driver. That page suggests ...


1

The state that's being changed is probably in the network adapter itself. Wireless adapters especially tend to be complex programmable computers in and of themselves, and it's likely that b43 is leaving the adapter in a state where it doesn't know how to talk to wl. Beyond that, you'd need deep understanding of how these drivers work to say what exactly is ...


1

Don't ever listen to anyone who tells you that you can't do something in linux, that's exactly why I no longer use windows. :) First, enable the nonfree repos. By adding "non-free" to your /etc/apt/sources.list file. Then, run the following commands: sudo apt-get update sudo apt-get install broadcom-sta-* sudo modprobe wl echo "wl" | sudo tee -a /etc/...


1

Although searching on the internet will lead you to instructions like: reboot/reset your router, reinstall "this" or "that" driver version or make sure your ESSID is not configured to be hidden, the problem may be the channel. Having a look at the 2.4 GHz (802.11b/g/n) specification (my router can only use de 2.4 GHz band), it seems that countries apply ...


1

From my friend Google who pointed to https://bbs.archlinux.org/viewtopic.php?id=148170: /usr/lib/systemd/system/rc-local.service [Unit] Description=/etc/rc.local Compatibility After=network.target [Service] Type=oneshot ExecStart=-/etc/rc.local #ExecStart=-/pathtoyour/script1 #ExecStart=-/pathtoyour/script2 TimeoutSec=0 StandardInput=tty RemainAfterExit=...


1

I had a very similar issue and it was caused by MAC & IP binding settings on the router. My router showed a different MAC address for my Linux Mint machine than ifconfig claimed the eth0 connection should have. I released the bindings in the router settings and rebooted the router and the correct MAC address showed up. My router is a TP-Link TL-MR3420.


1

You seem to have two interfaces with IPs from the same network. Even though they have different metric I would try disabling one interface and checking with the other. So I would ifconfig eth1 down, check routes again, if they are ok try to ping first your router 192.168.0.1 if it works try to ping 8.8.8.8. If you can ping the router but not the outside IP ...


1

There is an easier way. If you can have the internet access via an ethernet cable you can just install the b43 firmware sudo apt-get install firmware-b43-installer and then load up the b43 module via sudo modprobe b43 Now you should have wireless working


1

I found a solution for my problem. I tested different drivers that were mentioned for the Broadcom Chip. The first success was a slow wifi connection. The thing is to have a look that sometimes more than one driver module can be disturbing for the driver. Driver modules can be unloaded with modprobe -r followed by the module name. They can be loaded by the ...


1

Try service NetworkManager stop. It will just interfere with any attempt to manual configure and debug the set-up. Now try iwconfig. Hopefully you see mention of an interface that isn't described with "no wireless extensions". Presuming that is wlan0 (it could be something else), try: ifconfig wlan0 up && iwlist wlan0 scanning You should see ...


1

Like the previous post, it would really help to know more information. There's a couple things I know I can point out: The link is for Arch Linux, which is quite different from Crunchbang (#!). While #! is relatively small in community, many fixes found for Debian and also Ubuntu will work for #!. Waldorf (11) is still in testing, you might have better ...


1

From what you've posted, it looks like there's a problem linking the wl_cfg80211.o file, possibly a library missing. Some of the other errors seem to imply you're missing a header/include file to define things to match the library.


1

There is an extensive howto on getting the driver and making it work at http://www.susegeek.com/networking/fix-bcm4311431243214322-wireless-in-opensuse-111-and-earlier/


1

I'm guessing this has to do with encoding. According to this answer, an SSID may (now) have an explicit UTF-8 or UNSPECIFIED encoding, but the "SSIDEncoding" field is part of a newer standard. Presumably then on networks with equipment older than this, it is effectively "unspecified". I would like to think that anything which sets an SSID from text input ...


1

You need the file called broadcom-wl-4.150.10.5.tar.bz2, which a quick internet search shows several places to download. Put that on a USB stick, go to Fedora, navigate to right directory, and run tar xvjf broadcom-wl-r.150.10.5.tar.bz2 && cd broadcom-wl-4.150.10.5 su broadcom-wl-r.150.10.5/driver su b43-fwcutter -w /lib/firmware wl_apsta_mimo.o ...



Only top voted, non community-wiki answers of a minimum length are eligible