Tag Info

Hot answers tagged

11

You can suspend or hibernate your system and then automatically wake it up with rtcwake command. For example to suspend (to ram) and resume in 60 seconds do rtcwake -s 60 -m mem To hibernate (suspend to disk) in one hour from now and resume in two hours: sleep 3600; rtcwake -s 3600 -m disk You can also wakeup the system at given time with -t option ...


9

You should be able to do this with a mains timer between the mains outlet and the power supply. Shut down the Raspberry at 4 A.M using a cron job, then set the timer to cut the mains a bit later and to restore power at 5 A.M.


6

You can get it to turn off whenever you like with halt or shutdown now or whatever you prefer; schedule that with cron or a custom sleeping background process. In addition to the real time wakeup implemented by normal PC hardware (which the pi isn't) and usable via rtcwake, there is wake-on-LAN. Unfortunately, neither of those will work on the raspberry ...


3

The image file will already contain partitions and a boot sector therefore you cannot copy it to a partition. Instead you need to copy the image to the whole SD Card: sudo dd if=Cubian-desktop-x1-a10-hdmi.img of=/dev/mmcblk0 bs=4096; sync Note the lack of p1 at the end of the output file. You could probably increase the block size too - try bs=1M ...


2

Firstly, as written, your ping will run forever unless it us unable to find the host, because it runs until it catches a signal (i. e. SIGINT) telling it to stop. Scripts in /etc/rc.local are not, as far as I recall, run in the background. As such, your script never finishes as it is an infinite loop. Depending on exactly why you are doing this, you could ...


2

You can modify in the file /etc/sysconfig/init , the field BOOTUP Like : BOOTUP=verbose It should work at the next reboot. Cheers.


2

Shutting down is easy, use the poweroff command - put it in a crontab if you want. Starting up, however, is harder as the OS doesn't run when the machine is stopped, so you can't just add a cron job and expect it to run. On some PCs the rtcwake command will indeed work but on some it won't, and you may need to tinker with the BIOS settings. For the ...


2

This is an address limit i.e. a number of bits. Thus this refers to real gigabytes (GiB) i.e. 2^37 bytes == 128 GiB == 131,072 MiB == 137438 MB.


1

Try to run systemd-analyze critical-chain. I think the output is easier to read than the log. Well, it might just confirm that wicked is the culprit. I have no experience with wicked yet, but I would try to start it under strace to see where it hangs/times out or to run tcpdump in parallel to see what it tries to do on the net. Edit: Oops, I had missed your ...


1

To schedule a server shutdown, you could schedule /sbin/shutdown -h now in your cron table. For startup, some system BIOSs allow you to automatically start the system up at a certain time of day. If your BIOS does not support that, you could look into having another host on the same network send a Wake-On-Lan packet, but that also requires BIOS support and ...


1

You can reboot the computer with a terminal command, but you can't give it a terminal command that tells it what device to reboot into. Once the machine reboots control is passed to the BIOS, which then decides what device to boot from. Some BIOSes will automatically offer to boot from a bootable CD/DVD if it detects one, but not all. So when the machine ...


1

The service servicename needs a user from Active Directory using PBIS (formerly Likewise Open). By the way, PBIS stands for PowerBroker Identity Services. So the PBIS service has to be fully up. After that the service can start with that user. If Jenkins's init script is the very last one, it worked. NOTE: So, be careful when services depend on other ...


1

Files in /etc/network/if-up.d already run automatically whenever an interface (any interface) comes up. When you specify the same script to run again in an explicit post-up command, you only cause the script to run again. So my guess is this is what should happen: It runs once when lo comes up (with environment variable IFACE=lo) due to being located in ...


1

Delete empty line before post-up-command. This should relate the post-up command to eth0 only. Additionally move your script out of if-up.d folder. Scripts in that folder are executed automatically, no matter if defined as post-up. In your case it will run additionally to your post-up-command.



Only top voted, non community-wiki answers of a minimum length are eligible