Tag Info

New answers tagged

0

Is the server configured to accept RSA keys? Look for RASAuthentication in the sshd_config file.


0

The $HOME/.ssh directory mode must be 700 and authorized_keys should be readable by the owner only, i.e. mode 600: chmod u=rwx,g=,o= /var/git/.ssh chmod u=rw,g=,o= /var/git/.ssh/authorized_keys As to the private key, it must be read-write-able by the owner only: chmod u=rw,g=,o= /var/git/.ssh/id_?sa


4

For reasons of paranoia, the .ssh directory and authorized_keys must not be group-writable. I guess the thinking is, the user must be the only one with explicit control over his/her authorization. I believe a work-around for this lies with ACL. The other work around is StrictModes=no setting in sshd's configuration file. But it would be too dangerous to do ...


1

The problem is the fact that files permissions are too open. Try setting the mode of authorized_keys to 600 and the .ssh directory to 700.


0

I found the fix for it, just do : sudo rpi-update That updated the firmware, the kernel version, and whatever else was needed to make iptables work, now my fail2ban is working fine.


1

On Solaris 11 you can use: vi /etc/ssh/sshd_config PermitEmptyPasswords yes Reload sshd Add a new user useradd -m -d /home/testuser -s /bin/bash testuser passwd -d testuser SSH using new user admin@testhost:~$ ssh testuser@localhost Last login: Tue May 19 15:02:42 2015 from localhost Oracle Corporation SunOS 5.11 11.2 December 2014 ...


0

toor was a valid password for root, so i was able to shutdown. Problem solved


1

libpam-radius-auth should work exactly as you need. I use it in this capacity with no problems. You just need to Configure it in /etc/pam.d somewhere, probably common-auth. Configure the RADIUS server in /etc/raddb/server However, they can't authenticate if they aren't local users. Yes, that's true. Users must exist in the first place. It sounds ...


0

Proxy authentication with ntlm is explained well in the below links. For Ubuntu 14.04: Configure proxy in Ubuntu 14.04 For Lubuntu: Setup proxy with authentication in Lubuntu/ubuntu But the problem with ntlm is you have to update the cntlm configuration file many times a day. Consider a situation where different users share a common machine and they have ...


2

The pam_env man page says: RETURN VALUES PAM_ABORT Not all relevant data or options could be gotten. PAM_BUF_ERR Memory buffer error. PAM_IGNORE No pam_env.conf and environment file was found. PAM_SUCCESS Environment variables were set. Additionally, if your system has been corrupted badly, pam_env.so itself ...


2

D-Bus isn't using the magic cookie file here; it's passing credentials over the UNIX domain socket (SCM_CREDENTIALS). The magic cookie file is only one of several D-Bus authentication mechanisms. D-Bus implements a SASL-compliant interface (see RFC4422) to support a wide range of authentication mechanisms. One of these mechanisms is called "EXTERNAL" ...


0

Don't let your code carry out all the logic: use PAM and its configuration first to make sure your module runs in the best conditions (ie. does not require copying pam_unix's code). First, let me suggest another pseudo code for your module: pam_sm_authenticate() { if (first_login) return PAM_CRED_INSUFFICIENT; else custom_auth(); } Here, I ...


1

First, keep in mind that it is rather unconventional to have your module's code logic change according to other modules' results: this is usually done by using control flags, such as required and requisite, which control which modules get called, in which situations (i.e. according to the current chain status, previous modules' results). With that in mind, ...



Top 50 recent answers are included