Tag Info

New answers tagged

1

You have a package installed called oracle-java7-installer, and it downloads Oracle JDK 7 as part of its installation process. When you run apt-get upgrade, it completes the installation of any package that's partially installed; you can run apt-get install to do that without upgrading any package (normally, this does nothing because all packages are fully ...


1

If you take one of the urls that gives a 404 error and put it in your browser, you will see that you get the 404 error as well. This might be temporary, or a server error so what you can do is search up the directory structure until your url is http://archive.ubuntu.com/ubuntu/dists/. There you will see subdirectories for lucid (10.04), precise (12.04), ...


0

It is also possible to force installation of a package even though it overwrites files from a different package. Of course it is usually not recommended, etc., but the tools give you the power to do it. sudo dpkg --force-overwrite -i /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb


3

Set the environment variable DEBIAN_FRONTEND=noninteractive. For example: export DEBIAN_FRONTEND=noninteractive apt-get install -y libpq-dev This will make apt-get select the default options.


3

You should be able to achieve this using debconf-set-selections. From the man page: debconf-set-selections can be used to pre-seed the debconf database with answers, or to change answers in the database. Each question will be marked as seen to prevent debconf from asking the question interactively. In order to determine the required input to ...


0

Try this version of /etc/apt/sources.list.d/official-package-repositories.list : deb http://www.mirrorservice.org/sites/packages.linuxmint.com/packages/ olivia main upstream import deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse deb http://old-releases.ubuntu.com/ubuntu/ raring-updates main restricted universe ...


3

On AskUbuntu there is this question which may of help The repositories for EOL Ubuntu releases are archived, so http://archive.ubuntu.com/ubuntu/dists/ was moved to http://old-releases.ubuntu.com/ubuntu/dists/ (raring-updates is here) - basically all you should need to do is replace archive.ubuntu.com & security.ubuntu.com in the software sources ...


3

Support for Ubuntu 13.04 officially ended on January 27, 2014. Wikpedia entry on Raring Ringtail. Presumably, you would want to update to a supported version... The current version of Linux Mint is 17.


-2

You have to change your /etc/sources.list to this (taken from here): deb http://http.debian.net/debian wheezy main deb-src http://http.debian.net/debian wheezy main deb http://http.debian.net/debian wheezy-updates main deb-src http://http.debian.net/debian wheezy-updates main deb http://security.debian.org/ wheezy/updates main deb-src ...


1

Turns out I only needed to install chromium-inspector (not to be confused with chromium-browser-inspector) and chromium. For some reason it "fixed" the other dependencies. The procedure was the following: Export bookmarks to a .html file (via Chromium's Bookmark Manager) Backup configs (cp -r ~/.config/chromium BAK) apt-get purge chromium apt-get ...


1

You want to hold that package at it's current version. Make sure you have apt-mark installed. After installing chromium version 34, use this command apt-mark hold chromium Then rerun apt-get install -f


2

Which method is easier to maintain if this is a personal repository: fake the version number of the packages to be always x+100 or similar, where x would be the major version of the original upstream software pin it using APT pinning Neither. There are a bunch of techniques you could use. First, read 5.6.12 in Control files and their fields ...


2

You have two PPAs, probably in your /etc/apt/sources.list. They are deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/ trusty/main i386 deb http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ trusty/main i386 These both look like GIMP PPAs, but since they are equal to or less than the version of the official PPA, there is no point to them. So, ...


0

I needed full version information on possible upgrades, so I used a modification of jasonwryan's answer: apt-get -V -u upgrade It's simple and IMO reasonably formatted output.


2

apt-get install nodejs=0.10.29~dfsg-1 or alternatively apt-get install nodejs/testing will probably work, unless there are additional dependencies which need to be installed from outside your preferred source, here apparently stable. If there are, you will need to specify them on the command line as well.


2

You can grep for status installed in the dpkg.log file (and in the other files dpkg.log.* files if you are using logrotate): $ grep "status installed" /var/log/dpkg.log* [...] $ zgrep "status installed" /var/log/dpkg.log*gz [...] But you will not only get manually installed packages, but also security updates and all package installed because of ...


2

If you want check what Debian packages are in your system you can use dpkg command. dpkg -l dpkg --list It gives the full list of the packages in your system. In first and second column you can see respectively: Desired=Unknown/Install/Remove/Purge/Hold Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend In the first ...


-2

The configuration through a .yaourtrc is even better : no additional option to put down on the command line, and a finer control on what you want to do. Check for example : http://kissmyarch.blogspot.fr/2012/05/two-simple-yaourt-tips.html


1

result of ulimit -f is 15000 This is the limit, in kB, on the size of files that can be written by the current shell or any descendent process. It should normally be unlimited. The install process will likely require writing files bigger than 15 MB. E: Sub-process bzip2 received signal 25. Processes receive signals from other process or the OS ...


1

In my opinion, there is nothing here that can be reasonably fixed. After a discussion with the poster on chat, it became clear that is he is basically doing unsupported things. He first installed Knoppix, and then added Debian repositories and then tried to install/upgrade to Debian packages. This is not supported by Knoppix or Debian or anyone else as far ...


2

0 upgraded, 6 newly installed, 0 to remove and 488 not upgraded. The problem here is that you are in-between several upgrade paths for every package. You are not using stable, nor testing, and that brings about problems. You should upgrade as many packages as possible to stable first: sudo apt-get -t stable dist-upgrade Then decide if you want to ...


5

The repository given on the official download page doesn't contain any package for ARM, just amd64 and i386. So apt can't find a package there that would work on the Raspberry PI.


0

to install the latest version you have to do the following: sudo apt-get update sudo apt-get install owncloud-client And the latest available in all your repositories will be installed.


1

If any of the dependencies has some other previously installed packages that recommend/suggest them then apt would not remove them. There should be another package that you already have installed that either suggests or recommends that package. If you check with apt-cache rdepends pulseaudio the packages that recommend/suggest pulseaudio then there's the ...


2

If that's really the whole of your /etc/apt/sources.list file, that explains your current situation. And I've got no explanation for why you have a Hardy repo installed. I suspect you've followed an old tutorial and it has broken things. Your first step is getting your repos back on track. I would suggest using a tool like RepoGen to get the basics in but ...


0

The message "Dependency is not satisfiable: python-central(>=0.6.11)" means that you also need to install the python-central package, at version 0.6.11 as a minimum. However, since you are working on an offline computer, is very likely that you will run into another missing dependencies problem. You can check several methods to download and install ...


1

This is telling you that a dependancy (another package that is required to run the one you want to install) is either not installed on the system, or that the version installed is too old. The easiest way to make that work is to connect the machine to the internet and install with the package manager. This will automatically get and install any dependancies ...


3

You assume correctly :-) Your package manager is complaining that the package you're trying to install is requesting that python-central with a version greater than or equal to 0.6.11 is installed, but it can't install it. You have two problems here - the first is that you're not connected to the internet and the second is the fact that python-central is ...


1

It means python central is not installed, or too old. You need to connect to the internet, or go chase the dependencies manually. There'll probably be more after this one.


0

You need to install mysql-server and mysql-shared Packages



Top 50 recent answers are included