New answers tagged

1

You also need to add the SSL flag to APACHE_SERVER_FLAGS in /etc/sysconfig/apache2. # Notably, to enable ssl support, 'SSL' needs to be added here. # To enable the server-status, 'STATUS' needs to be added here. # # It does not matter if you write flag1, -D flag1 or -Dflag1. # Multiple flags can be given as "-D flag1 -D flag2" or simply "flag1 flag2". # # ...


0

You need to make sure you comment out the boiler plate SSL lines above in the config file. #SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem #SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt I ran into this same problem a moment ago and found your question before I ...


1

change the document root in /etc/httpd/conf/httpd.conf


1

If you have a hostname (e.g. anothersite.com) point to the apache webserver but you haven't explicitely configured a <VirtualHost> section that matches that hostname, then apache will deliver a "best match" (the first ). so if you only have a single <VirtualHost> in your apache config, and multiple hostnames (mysite.com and anothersite.com) ...


1

Usually this fix for me, add these lines into your wp-config.php: define('WP_HOME','https://example.com'); define('WP_SITEURL','https://example.com'); where both entries contain your new site address. Restart webserver


0

Provides: tags have nothing to do with the ea-apache24-2.4.18-1.1.x86_64 conflicts webserver problem. The package ea-apache24 has a Conflicts: webserver tag which causes this. Which I think is not really clever, as by default nearly all webservers can be installed in parallel. And not sure why you installed apache from some external repo when you can have ...


0

Your connection does not arrive on interface 10.173.144.43:443 so it's not handled by your VirtualHost. It hits the main server configuration which does not have SSL enabled. If you don't care what local interface is used, use a * in VirtualHost. Perhaps your firewall change made is so that some inbound request now used the named interface/IP, but it will ...


0

I figured out how to add shared module and here is explanation: Go to /etc/httpd/conf.modules.d Create file with .conf extension in which you'll put you settings for shared module: touch proxy_module.conf Add this to proxy_module.conf : LoadModule proxy_module modules/mod_proxy_balancer.so Restart apache: systemctl restart httpd After ...


0

In your situation, I'd build nginx from source. This has the advantage that you can enable only the features you'll need to run as a proxy. There are disadvantages. Keeping up with security issues becomes your responsibility, so you'll have to keep track of nginx errata. Also, you'll have to hand-roll init/systemd start scripts (although you can rip ...


0

It is absolutely not possible to override that. As a note, never attempt --skip-broken. The problem is both ea-apache24 and nginx both "provide" the same thing. Because of this, nginx refuses to install. There is no way around this without doing an rpm --force. But there is a good chance that will also fail. Doing this will create an rpmdb hell. I would ...


0

With /etc/httpd/conf.modules.d or /etc/httpd/conf.d, the principles are the same: to disable a module or a configuration file, rename its file extension to something different from .conf.


0

On CentOS 7, the right way to do it is to go through /etc/httpd/conf.modules.d and find the appropriate conf files with the modules you want to disable. You can also check /etc/httpd/conf/httpd.conf, but you'll have better luck in the conf.modules.d folder. Simply comment them out, reload apache, and you're good to go.


0

I think you're reading too much into the symlink. httpd will not look if you have files that are symlinks to files that are called index.html in either case. It looks for a file named index.html in your DocumentRoot. The FollowSymLinks is needed when such a file exists and is a symlink. (Imagine if, by accident or malice, a symlink to say, /etc/passwd or ...


1

Simply: yum downgrade httpd-<version-number> The version must be available already in the repository, which you can verify with: yum list --showduplicates httpd You might then encounter dependency problems: an older version of httpd depends on an older package that has been obsoleted. In that case, you must remove the depending packages. If the ...


1

Why do you want that exact version, and not the CentOS version based on 2.2.15 (presumably with backports for bugfixes up to 2.2.(last) and then some)? CentOS is basically recompiled RHEL sources, and as an enterprisey distribution they stay with the base version from the original release of the distribution (itself carefully selected), backporting relevant ...


0

I feel confident saying I found a few answers. In my situation I have a type 1 hypervisor, so I didn't want to use PhPVirtualBox (runs with VirtualBox a type 2 hypervisor) but that would work fine... Another options is >> NoVNC + x11VNC + ApacheProxyPass + linux distro This would allow not just a browser, but a whole desktop, which is fine for me, ...


0

from arch wiki in /etc/httpd/conf/httpd.conf, comment the line: LoadModule mpm_event_module modules/mod_mpm_event.so and uncomment the line: LoadModule mpm_prefork_module modules/mod_mpm_prefork.so Note: The above is required, because libphp7.so included with php-apache does not work with mod_mpm_event, but will only work mod_mpm_prefork instead. ...


0

from the config above it looks like you are configuring a HTTPS virtual host so please ensure that in the browser you specify https://sxweb.foo.com in the same time what they are telling you is that you can not run the skylable server on the same machine where you run your apache server as the skylable it needs port 443 and 8443 for it's normal ...


1

Did you recently upgrade from a previous version of Debian? You may need to change the DocumentRoot to be /var/www/ instead of /var/www/html sudo vim /etc/apache2/sites-available/000-default.conf Change the DocumentRoot, then sudo service apache2 restart Seems that in the new version of Debian the default location has changed Edit: Here is a bug report ...


1

First check to make sure that your server is listening on the port you want, not just local host netstat -plnt Should give you an output similar to this: Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 127.0.1.1:53 0.0.0.0:* LISTEN - tcp 0 0 10.0.3.1:53 0.0.0.0:* ...


0

Check this out from the httpd_selinux man page, available in the selinux-policy-doc package: If you want to allow httpd to read home directories, you must turn on the httpd_enable_homedirs boolean. Disabled by default. setsebool -P httpd_enable_homedirs 1 Your problems with /tmp might depend on what exactly you're trying to do. ...


1

Problem is solved. My apache config as posted above is correct. The problem was a false firewall configuration. Since I didn't change the firewall settings myself I cannot post the actual solution but as said the above apache config works.


0

Do chgrp apache on your home directory (and any files and subdirectories that you want Apache to be able to write to), and do chmod g+w on them.  This will set directories to 775 mode, and files to 664.


0

Are you trying to access you server via telnet? If so, that won't work correctly for secured pages (i.e. https). You need to use tools designed to do so; e.g. the OpenSSL suite of tools. Try the following set of commands instead: openssl s_client -connect <server>:<port> GET / HTTP/1.1


5

You can test this using ab, a software that resides inside apache2-utils package. Example: ab -r -n 100 -c 10 -k -H "Accept-Encoding: gzip, deflate" http://mysite.mydomain.com/ -r: Avoid exiting on socket errors. -n: Number of requests to perform. -c: Number of multiple requests running in concurrency. -k: Enable HTTP KeepAlive. Means it will perform ...


0

The gzip file format has an 8-byte footer containing a CRC-32 checksum and uncompressed length of the data. The DEFLATE file format is block-oriented. The gzip program in the pipeline is almost certainly buffering up input to use in the next output block. The 8-byte footer won't be written until after the long-running shell script exits, and gzip's stdin ...


0

ok , the problem in iptables i have to allow 80 port for accept connection by excuting this command iptables -I INPUT 5 -i eth1 -p tcp --dport 80 -m state --state NEW,ESTABLISHED -j ACCEPT save the rules by service iptables save restart iptables services service iptables restart



Top 50 recent answers are included