Tag Info

Hot answers tagged

5

This is not how certificates work. You can't generate a private key for an existing SSL certificate. First you generate the key pair (private + public), then you generate a CSR (containing your public key) that you forward to the CA (Comodo in this case) which will provide you with the certificate to install on your server. Perhaps the private key is ...


4

I can think of many solutions for this specific problem : (A) Configure sudo access such that your username does not require password for tail command (or for all commands, if you so require) Refer sudo and sudoers Documentation for this. (B) Configure sudo access with negative timeout. Default timeout is 5 minutes , after that you will have to reenter the ...


4

chmod u+r doesn't do what you apparently think it does; what it actually does is make the file readable by its owner. Which, I'm going to guess, it already was. chmod o+r (make file readable by "others", i.e., not owner/group) would probably work, but security argues against this. Pick one: ls -l /var/log/apache2/error.log ... on my (Debian) system, its ...


4

A wildcard matches a single left-most label. That is *.example.com matches www.example.com but not example.com or sub.foo.example.com. This means you either need to get a certificate which includes *.example.com and example.com as subject alternative names or if you just need www and the naked domain name then you can can get a cheaper certificate which ...


3

According to the Debian package page for wordpress, it appears that lighttpd should satisfy the dependency. However, it also requires libapache2-mod-php5 or php5, which is why I think it still pulls in Apache: while you have installed lighttpd, you may have forgotten to install the matching PHP package. Make sure lighttpd and php5 are both installed before ...


2

Run sudo visudo and add this line: Defaults timestamp_timeout=-1 -1 = never timeout the password Also see man 5 sudoers Though the above solution attracts security concerns. Please follow this link to set up sudo to run without password for specific commands.


2

More information on certificates with and without the www domain can be found here. This post has the same subject as your question and basically states that there is no work-around, other than buying a new certificate


2

Per https://help.ubuntu.com/lts/serverguide/httpd.html all configuration options have all been moved to subdirectories. httpd.conf: historically the main Apache2 configuration file, named after the httpd daemon. Now the file does not exist. In older versions of Ubuntu the file might be present, but empty, as all configuration options have been moved to ...


1

Enable and configure mod_remoteip. You proxy would set the original remote IP address in the header like X-Forwarded-For in HTTP requests. Pass it to RemoteIpHeader directive placed outside <Directory>. If mod_remoteip works correctly, original remote addresses passed by the proxy can be seen with %a in LogFormat. You should first check this. On ...


1

In your ispconfig.vhost file, see this block: <FilesMatch "\.ph(p3?|tml)$"> SetHandler None </FilesMatch> It tells to not associate any handler for php files. A little after, you have another block: <IfModule mod_fcgid.c> ... <FilesMatch "\.php$"> SetHandler fcgid-script </FilesMatch> ... </IfModule> This ...


1

You can try this in .htaccess or apache config. AddType text/plain .log


1

As you specifically mentioned htpasswd, here is a simple perl script that you can use to replace it (from here): #!/usr/bin/perl use strict; my $passWord=$ARGV[0]; print crypt($passWord,$passWord)."\n"; Just place the above code in a new script, say htpasswd.pl, make it executable (chmod 755 htpasswd.pl) and run it as follows: ./htpasswd.pl password ...


1

Yes this is possible, thanks to open source code. :) The easiest way is to edit the Apache2 source file for the mod_autoindex module that creates the html that is sent to the client. Here is the file you would need to edit 1: http://svn.apache.org/repos/asf/httpd/httpd/branches/2.2.x/modules/generators/mod_autoindex.c There are 7 places in that file where ...



Only top voted, non community-wiki answers of a minimum length are eligible