Yellowdog Updater Modified (yum) is an interactive, rpm based, package manager.

learn more… | top users | synonyms

0
votes
0answers
8 views

How to uninstall JDK1.6? [duplicate]

I am on Scientific Linux- I have JDK 1.6 and 1.7, 1.7 being used but I think the 1.6 is causing me problems. How can I remove the 1.6 version from Linux? I had to install it using yum.
3
votes
1answer
36 views

How to merge config files interactively after “yum update”

After system packages are updated with "yum update", config files which could not be overwritten are not replaced, but we can find *.rpmnew files near by. By design system administrator must merge ...
1
vote
0answers
85 views

Yum or Reposync: How can I slowly remove a repository without unintended dependency issues?

I have used reposync to create and maintain local copies of two repositories, remi and remi-test. These are repositories maintained by Remi Collet. On several systems in an internal LAN, I added both ...
0
votes
1answer
28 views

make RPM recognize dependency built from source

I am trying to emulate an enviroment that has centos5 and tomcat6 (for some reason), which is a problem because there are no RPMs for tomcat6 which are compatible with centos5 available to me. I do ...
0
votes
1answer
36 views

How to remove a (group) of softwares that depend on one another? [duplicate]

I would like for example to remove php and all it's components and extensions as seen in this picture, but instead of removing every software one by one, is there anyway safe I can remove them all ...
0
votes
0answers
119 views

yum install kernel-devel: “Nothing to do” [SOLVED]

I need the kernel-devel package to compile a program(How to check if USB WiFi-Adapter is not working or router is out of range?), but when I try to install it via yum, this is the only output: yum ...
1
vote
0answers
74 views

So, what do I do with the output of yum check?

When I run yum check (or try to use yum to update my system generally), I get the following: # yum check Loaded plugins: langpacks, presto, priorities, refresh-packagekit ...
0
votes
0answers
69 views

Upgrading from Fedora 17 to Fedora 20 (or higher)

I'm trying to upgrade my fedora 17 install to a more recent version. I have tried the following methods, which don't work: First, using fedup: # yum install ./fedup-0.8.1-1.fc20.noarch.rpm Loaded ...
0
votes
1answer
25 views

Why is there an apt-get script set in my cron.daily, I'm on Fedora 20?

I found this file tonight: /etc/cron.daily/apt.cron #!/bin/sh [ ! -f /var/lock/subsys/apt ] && exit 0 [ -f /etc/sysconfig/apt ] && . /etc/sysconfig/apt [ $CHECK_ONLY == "yes" ] ...
0
votes
0answers
32 views

“Suggest” to RPM install the UID of a user that is going to be created?

In an RPM it's possible to create a system account; is it possible to suggest the UID to use? For example; during the normal install say that the UID in use was going to be 100; but I want it to use ...
2
votes
2answers
86 views

Where does demo code usually go when installed with package manager.

In this particular example I am trying to get the CGAL Library demo code wich is availble from the Fedora package manager yum: CGAL-demos-source.x86_64 : Examples and demos of CGAL algorithms ...
2
votes
3answers
193 views

Yum regular expression or wildcard search?

Fedora documentation says: 5.2. Advanced Searches If you do not know the name of the package, use the search or provides options. Alternatively, use wild cards or regular expressions with ...
1
vote
1answer
29 views

Disabling gpgcheck with tmprepo plugin

I want to install an rpm from a repo just once and not have to add it to my yum.repos.d/ directory using the tmprepo plugin. However, I’m blocked on how to install an rpm with no gpg signature. The ...
1
vote
1answer
41 views

Install yum packages on a mounted volume

I have a Raspberry Pi with Pidora installed. I need to install a LAMP server. This is the scheme of the filesystem, with a mounted USB flash drive. Filesystem Size Used Avail Use% Mounted on ...
2
votes
1answer
446 views

yum: RPM dependency tree

I'm going to install an RPM package and I can see that some of dependencies requires X server libraries to be installed as well. I'm absolutely sure that the package I need is a server software and ...
2
votes
1answer
366 views

Does yum's --enablerepo option only enable a repo for the current command?

Does yum's --enablerepo option only enable a repository for the duration of the current command? For example if the enabled setting in /etc/yum.repos.d/remi.repo file is set to 0 (disabled) and I ...
0
votes
1answer
328 views

Can't install “libdvdcss” with yum anymore after update on “Fedora 20 Heisenburg”

I couldn't update my system today, because of dependency problems with libdvdcss, I removed libdvdcss and it's dependency libdvdcss2. Update was successfull after that but now I can't install ...
1
vote
3answers
122 views

Other than via configuration in /etc/yum.repos.d, where else can a repository be configured?

Helping out someone who inherited his environment. He wants to disable some repositories. This is an anonymized output of his yum repolist: luke@server1 $ sudo yum repolist Loaded plugins: rhnplugin, ...
0
votes
0answers
131 views

bash script to verify rhel patching

we have several redhat servers which we patch from redhat satellite. To avoid confusion, I'll use the term "host" to denote the server which is being patched. We have a script, say, patch.sh, which ...
0
votes
1answer
55 views

Bash STDERR still appearing after redirection [closed]

I am trying to parse the output of yum check-update in Bash 4 (Red Hat) and want to skip the first line that states: 'This system is not registered to Red Hat Subscription Management. You can use ...
10
votes
2answers
6k views

How can I instruct yum to install a specifc version of package X?

If there are 2 versions of a given RPM available in a YUM repository, how can I instruct yum to install the version I want? Looking through the Koji build service I notice that there are several ...
2
votes
1answer
464 views

Installing PHP 5.3.3-24 on CentOS 6.5 (Final)

I require a slightly older version of PHP for my server because I need to be able to exploit a CVE (CVE-2006-7243) that was patched in the newer versions. NOTE: This is a legitimate use case where ...
0
votes
2answers
543 views

Yum file conflicts due to my mistake. How do I fix?

I did something stupid. I simply scped my rpmforge repo files from another (working) machine on to my dev box, and ran yum update. This yielded: root@dev07 /etc/yum.repos.d # yum update Loaded ...
2
votes
1answer
140 views

“Couldn't resolve host” when downloading Fedora 16 packages

I'm using yum to install make, I am getting the following error. I tried all solutions from similar questions but the issue remains. ...
0
votes
1answer
294 views

Getting conflict errors when runnin yum update

I'm truing to run yum update, and keep getting errors about conflicts. I must have accidentally interrupted an update at some point, but I don't know when and how. I've tried —skip-broken, but it ...
0
votes
2answers
102 views

update ss utility on centos

My centos version is: 2.6.32-131.17.1.el6.x86_64 #1 SMP Thu Oct 6 19:24:09 BST 2011 x86_64 x86_64 x86_64 GNU/Linux And my ss version: ss --version ss utility, iproute2-ss091226 I need to ...
1
vote
2answers
119 views

Using YUM for CentALT packages

Since CentALT isn't available anymore I can't upgrade some of my packages. Sure I can use a mirror for CentALT to get it working, but it only lists 'older' packages since it's not updated anymore. I ...
4
votes
2answers
5k views

Unable to Pull EPEL repository Metadata

Installing Nginx on Scientific Linux according this documentation fails: [vagrant@localhost ~]$ sudo su -c 'rpm -Uvh http://dl.fedoraproject.org/pub/epe l/6/x86_64/epel-release-6-8.noarch.rpm' ...
0
votes
0answers
72 views

problem regarding YUM

I have a problem with my Centos 6. Actually, I am trying to run any command like yum update or yum upgrade or yum install mysqlmysql-server. Everytime, I got an error below: Loaded plugins: ...
2
votes
0answers
35 views

Unable to install Mysql

When I install mysql on my Centos, I get the following error: Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile Could not retrieve mirrorlist ...
6
votes
1answer
121 views

How can I put some comment in yum installation list?

Lets say I made a List of installed packages by: rpm -qa > list I want to use this list to re-install those Packages on another System, For Example By: yum -y install $(cat list) But I need ...
0
votes
1answer
110 views

Unable to install yum and mysql,ssh

When I go to install mysql on CentOS 6,I get the following error: yum install mysql mysql-server Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile ...
3
votes
3answers
426 views

Centos rpm -qa vs yum list installed

I want to have server b to have exactly the same setup as server a. My plan is to have a list of all installed things on server a and install it by using the list on server b something like : yum ...
2
votes
2answers
555 views

Downgrade gcc to 4.6.3 on fedora?

How can I downgrade gcc to 4.6.3 on fedora. I am working on a project that I do not have permission to update to be comparable with 4.8 and need to be able to install gcc 4.6.3. How can I do this?
0
votes
2answers
346 views

Yum on CentOS 7 repositories may be broken

Just got CentOS 7 on a new server and I went yum install httpd and it went fine. Afterwards I went yum install mysql-server and I got No package mysql-server available. I haven't messed up with the ...
0
votes
0answers
54 views

yumdownloader can't find packages with extended local version

Background: I asked this question a long time ago, trying to figure out the RedHat convention of package-1.2.3.el6_1.x86_64.rpm. I was told that the el6_1 portion is the "local version" -- it's ...
1
vote
2answers
78 views

Can I `yum search` for an architecture other than my own?

I'm trying to grab some packages from a yum server with yumdownloader. I can pass the --archlist= argument to grab packages for a different architecture -- I need to in this case, as the target ...
2
votes
3answers
63 views

listing package dependents

I stupidly did "yum remove python" which also ended up removing all the packages that required python as well. Luckily, I have access to another Linux machine that is a near clone of this machine, ...
0
votes
1answer
212 views

Can't remove ImageMagick using yum remove

I want to remove the ImageMagick,But I got this error [root@localhost ~]# cat /etc/redhat-release CentOS release 6.4 (Final) [root@localhost ~]# rpm -qa "ImageMagick*" ...
0
votes
1answer
77 views

Fedora Core yum update keeps hanging

When I run yum update it hangs at the end with no error message. If I run sudo yum install httpd it hangs with no error. I read that using strace should give more info, but when I try that it says ...
3
votes
1answer
955 views

YUM won't update KERNEL

... ... ... --> Running transaction check ---> Package db4-devel.x86_64 0:4.7.25-18.el6_4 will be installed --> Processing Dependency: db4-cxx = 4.7.25-18.el6_4 for package: ...
3
votes
3answers
4k views

Cannot retrieve metalink for repository: fedora/20/i386

I installed Fedora 20 using the liveOS. While taking the updates I am getting the following result: [root@localhost bioinfo]# yum update Loaded plugins: langpacks, refresh-packagekit Error: Cannot ...
2
votes
1answer
120 views

Rebuilt kmod package not updating via `YUM` but is via `rpm`

I have built a package with the following version: kmod-dahdi-linux 10:2.9.1.1-75_shmz65.1.11.2.6.32_431.el6.i686 Which should be an upgrade of the one installed on the system: kmod-dahdi-linux ...
1
vote
0answers
58 views

Zend installation on Fedora 19

I am trying to install Zend Server on Fedora 19. Once I run yum install zend-server-ce-php-5.3 I get following error: Transaction check error: file /usr/local/zend/var/log conflicts between ...
2
votes
1answer
607 views

How to install Node.js in CentOS 5.10 with Python 2.4?

I want to use Grunt on websites we have hosted on our WHM dedicated server. It is running CENTOS 5.10 x86_64 standard with WHM 11.42.1 (build 21). It is critical that things do not break, as we have ...
4
votes
5answers
282 views

Correlating filename with package

Say, I'm given a filename like libasound.so.2. Is there a way to query the package manager to correlate the filename with its corresponding package? I'm interested to get answers for any package ...
2
votes
1answer
30 views

Query all paths in all packages/repos without installing?

Let's say I want to create a new package that installs a command, i.e. adds a new file to /bin or /usr/bin. But I have yet to name the command. So if I'm to run into conflicts, I want to find out ...
0
votes
2answers
181 views

Can't find lib which provides libneon.so.25

I'm running yum whatprovides libneon.so.25, but can't find any library that provides this. Am I missing something?
1
vote
1answer
429 views

Getting SVN 1.6/1.7 on Fedora 20

I have a remote repository which is running 1.6 that I have no admin rights to, thus I'm trying to install a version of SVN that is compatible with 1.6. Doing a yum --showduplicates list subversion ...
0
votes
2answers
205 views

How to install most recent version of Eclipse via the Terminal

I'm new to Linux and have just been given a VM of Oracle Linux to work with. I need to install Eclipse on it and, after a bit of research, discovered that this could most easily be done with the ...