Yellowdog Updater Modified (yum) is an interactive, rpm based, package manager.

learn more… | top users | synonyms

0
votes
1answer
383 views

Cannot use EPEL repo, get NSS error -5990 (PR_IO_TIMEOUT_ERROR)

I'm using vagrant to start up a centOS 7.0 VM. My provisioner is trying to set up EPEL 7 via yum install epel-release -y and then trying to install ansible via yum install ansible -y It installs ...
0
votes
1answer
309 views

Yum Corrupted on RHEL 6

I really need help. I am encountering the issue with my yum command. It seems to be exactly the same as the issue described on this site, Yum corrupted on CentOS 6.2, Problem importing one the python ...
0
votes
1answer
20 views

Reposync - is it safe to abort?

I accidentally executed reposync on our Linux machine and it started performing hundreds of .rpm file downloads... Being a Windows guy with limited Linux knowledge, I found this: synchronize yum ...
0
votes
0answers
126 views

Cannot retrieve repository metadata (repomd.xml) Centos 6.6

I'm trying to upgrade centos 6.6 with yum update I keep getting this error message Cannot retrieve repository metadata (repomd.xml) for repository: centos6 x86_64. Please verify its path and try ...
0
votes
2answers
1k views

Install mplayer on Centos 7

I've been trying for several days to install mplayer on Centos 7 without success, I've install many repos but nothing works, I've always the following error: -> Resolve Dependencies completed ...
0
votes
0answers
57 views

multilib confilict trying to install netcdf-devel

I'm trying to install netcdf-devel using fedora. I was getting multilib conflicts with hdf5 libraries, so I uninstalled all hdf5 and netcdf packages to try and start from scratch. I then tried sudo ...
0
votes
0answers
145 views

Where can I find a yum repo with couchdb for CentOS 6.5?

I've been beating my head against the wall for a couple of days now. Most CouchDB installation directions say to use yum and install from the epel.repo. Unfortunately, for me I can't seem to find ...
0
votes
1answer
23 views

Allow only specific package from given repo yum

We have two repo A and B Both repo provides package C I dont want to use A for anything else , except for package C Rest all packages i want to install from B How to tell yum to block A for all ...
0
votes
1answer
3k views

yum command not found, cannot install stress [closed]

When I try to install the stress package on SUSE11 and Centos 7, yum tells me that it isn't found or that stress as a command does not exist. Anywhere I have looked online tells me that it is as easy ...
0
votes
2answers
63 views

How can I let people install my package by apt-get?

I have a set of binary packages that I want the user to be able to install from command line via apt-get or yum without having to host it myself on a server. I have heard of reprepro and pushing it to ...
0
votes
0answers
88 views

broken yum/python

Yum seems to be broken and below is the error. 'import site' failed; use -v for traceback There was a problem importing one of the Python modules required to run yum. The error leading to this ...
0
votes
3answers
2k views

Removing KDE from Fedora21, groupremove not working

I am trying to remove KDE from my Fedora 21 installation in favor of XFCE. I have tried a few different commands and neither of them work. #yum groupremove "KDE Plasma Workspaces" and also #yum ...
0
votes
1answer
127 views

How to install oddjob-mkhomedir repository on AMI box using command line

I'm trying to install oddjob-mkhomedir and it comes back with no package available nothing to do. I used sudo yum install oddjob-mkhomedir so I'm assuming the repository is not available. My ...
0
votes
1answer
597 views

Big trouble : rpm empty db, install V3 RSA/SHA1 Signature, key BAD, YumRepo Error

I'm little tired because I have spent hours solving problems, and can't find a solution on Centos 6.6. I have many troubles: rpm db is empty: try googling, find restore process, but always empty ...
0
votes
0answers
14 views

Conflicting Gpodder versions

I'm running Fedora 20. I installed Gpodder 2.20.3 from source using make. I realised it was not the version I wanted (2.20.1), and make uninstall didn't do anything (no target), so I manually ...
0
votes
3answers
41 views

Why does same program requires yum update on one machine but not another?

I have cpio-2.11-25.fc20.x86_64 installed on two machines: This program does not require an update on the first machine, but I was presented with a higher version 2.11-28.fc20 on the second machine. ...
0
votes
0answers
127 views

linux + cant installed the package GNOME Desktop Environment on linux red-hat

I have been installed the package GNOME Desktop Environment on my red-hat machine version 6.4 in the end of the installation I get the error about missing RPM- GPG-KEY-oracle directory !!! ...
0
votes
0answers
185 views

Updating my version of php to the latest 5.5 version

I'm trying to update the version of php 5.5 to the latest version (5.5.20 at the time of writing). I'm doing this on a CentOS v6 machine. I've tried following the steps here: ...
0
votes
0answers
110 views

Yum can't download, but curl is fine?

I'm creating a local copy of rpmforge on a RHEL5 host. # reposync --repoid=rpmforge --download_path=/var/www/html/yum # cd /var/www/html/yum/rpmforge; createrepo --database . I have a repository ...
0
votes
1answer
20 views

How do i get installer user-id?

I have a project whereby i have to extract configurations from one linux pc and emulate it on another. I am focusing on extracting the packages installed during the installation of the fedora. This ...
0
votes
1answer
371 views

`yumdownloader --source` can't find srpm on rhel 6.5

yumdownloader --source prints either No Match for argument or No source RPM found. Switching "Enabled" "1" or "0" has no effect. [vboxuser@okdemohost ~]$ yumdownloader --source gcc Loaded plugins: ...
0
votes
0answers
3k views

completely clean re-install of mysql on CentOS 7

I have encountered problems with a mysql installation on CentOS 7. All the data is backed up, so I just want to completely erase every remnant of mysql on the machine and then do a clean install. My ...
0
votes
0answers
122 views

Yum check error: I/O error

when i tried to update yum it showed up some db cursor error with I/O errors then after doing yum clean and update still they remained so. After that tried with yum check and ended up as follows: ...
0
votes
1answer
119 views

Yum won't update package

I am trying to update the package minetest from 0.4.9 to 0.4.10, but when I update the whole system, it states that there are no updates available. If I try to update the package alone, I get the same ...
0
votes
1answer
96 views

Bash 4.3 yum repository for Amazon Linux

I'm trying to get bash 4.2 (or a more recent version) on Amazon Linux in ec2. The default repository only has Bash 4.1. I'm looking for a yum repository with a recent version. $ sudo yum install ...
0
votes
0answers
75 views

Mapping between RPM file names and metadata names generated by maven

We have a Sonatype Nexus repo, where we publish RPMs with the Maven RPM plugin. Snapshots and release versions are available. The issue here is around the mapping between versions. First, I obtain a ...
0
votes
0answers
640 views

Need php-pecl-rrd for PHP 5.6 on Linux

Previously I have been running with PHP 5.5 on a 32 bit architecture but due to a new server I have now installed PHP 5.6 on CentOS7. This is possible through Webtatic.com. The only problem I have ...
0
votes
0answers
59 views

SELinux error when yum updated pcre package

When doing a yum update, I got the following errors: Updating : pcre-8.33-7.fc20.i686 82/164 libsepol.module_package_read_offsets: module package header ...
0
votes
1answer
219 views

yum groupremove 'Development Tools': keep packages required by other packages

I did: yum groupinstall 'Development Tools' Now I want to remove it: yum groupremove 'Development Tools' But it marks for deletion many other packages that require binutils. How to keep binutils? ...
0
votes
1answer
36 views

Is there a Yum Option that Creates an Error if a Package is Missing?

I am using a set of local yum repositories and trying to install a set of packages from those repos. I noticed that when one of the packages on the command line does not exist, Yum just prints out ...
0
votes
1answer
263 views

Yum not working at all

I ran the command yum clean metadata and then ran the command yum update. When I ran the yum update I now get the following errors Loaded plugins: product-id, security, subscription-manager This ...
0
votes
0answers
137 views

yum/rpm: exclude a file (by path) from being installed

Is there any way to make yum/rpm never install a particular file path, but to otherwise install any packages which contain that file path, and for verification to act as if that file exists? For ...
0
votes
0answers
26 views

How to stop meta-rpm transaction if a precondition fails?

I currently have a meta-package rpm which contains a list of dependencies on other rpm packages. I want to stop the update/install transaction of the meta-package (and all subsequent packages) if the ...
0
votes
0answers
822 views

Rebuilding the Linux yum repository metadata

On a RH 6.5, running yum update I get : "This system is receiving updates from RHN Classic or RHN Satellite. Setting up Upgrade Process Error: Cannot retrieve repository metadata (repomd.xml) ...
0
votes
0answers
229 views

Show Plymouth Boot Screen failed

I am not getting proper information about how to solve this thing. I am using Centos 7 i've installed one open source called OpenERP. all services are running now. I have one issue i.e. ...
0
votes
0answers
113 views

Fedora 20 won't startup after shutdown during kernel update

I had a few bugs in my System(System Settings not opening and Firefox not starting) and I thought a kernel update(via yum) could do it some good. During that update, I suddenly got logged out as if ...
0
votes
0answers
9 views

How to uninstall JDK1.6? [duplicate]

I am on Scientific Linux- I have JDK 1.6 and 1.7, 1.7 being used but I think the 1.6 is causing me problems. How can I remove the 1.6 version from Linux? I had to install it using yum.
0
votes
1answer
83 views

make RPM recognize dependency built from source

I am trying to emulate an enviroment that has centos5 and tomcat6 (for some reason), which is a problem because there are no RPMs for tomcat6 which are compatible with centos5 available to me. I do ...
0
votes
1answer
38 views

How to remove a (group) of softwares that depend on one another? [duplicate]

I would like for example to remove php and all it's components and extensions as seen in this picture, but instead of removing every software one by one, is there anyway safe I can remove them all ...
0
votes
0answers
477 views

yum install kernel-devel: “Nothing to do” [SOLVED]

I need the kernel-devel package to compile a program(How to check if USB WiFi-Adapter is not working or router is out of range?), but when I try to install it via yum, this is the only output: yum ...
0
votes
0answers
276 views

Upgrading from Fedora 17 to Fedora 20 (or higher)

I'm trying to upgrade my fedora 17 install to a more recent version. I have tried the following methods, which don't work: First, using fedup: # yum install ./fedup-0.8.1-1.fc20.noarch.rpm Loaded ...
0
votes
0answers
63 views

“Suggest” to RPM install the UID of a user that is going to be created?

In an RPM it's possible to create a system account; is it possible to suggest the UID to use? For example; during the normal install say that the UID in use was going to be 100; but I want it to use ...
0
votes
0answers
387 views

bash script to verify rhel patching

we have several redhat servers which we patch from redhat satellite. To avoid confusion, I'll use the term "host" to denote the server which is being patched. We have a script, say, patch.sh, which ...
0
votes
1answer
532 views

Getting conflict errors when runnin yum update

I'm truing to run yum update, and keep getting errors about conflicts. I must have accidentally interrupted an update at some point, but I don't know when and how. I've tried —skip-broken, but it ...
0
votes
2answers
490 views

update ss utility on centos

My centos version is: 2.6.32-131.17.1.el6.x86_64 #1 SMP Thu Oct 6 19:24:09 BST 2011 x86_64 x86_64 x86_64 GNU/Linux And my ss version: ss --version ss utility, iproute2-ss091226 I need to ...
0
votes
0answers
140 views

problem regarding YUM

I have a problem with my Centos 6. Actually, I am trying to run any command like yum update or yum upgrade or yum install mysqlmysql-server. Everytime, I got an error below: Loaded plugins: ...
0
votes
1answer
474 views

Can't remove ImageMagick using yum remove

I want to remove the ImageMagick,But I got this error [root@localhost ~]# cat /etc/redhat-release CentOS release 6.4 (Final) [root@localhost ~]# rpm -qa "ImageMagick*" ...
0
votes
1answer
96 views

Fedora Core yum update keeps hanging

When I run yum update it hangs at the end with no error message. If I run sudo yum install httpd it hangs with no error. I read that using strace should give more info, but when I try that it says ...
0
votes
2answers
656 views

Cant install gnutls.i686 on a x64 CentOS install

I need to install gnutls.i686 on CentOS 7 but I get this error in yum: Transaction check error: file /usr/share/man/man5/pkcs11.conf.5.gz from install of p11-kit-0.18.7-4.el7.i686 conflicts with ...
0
votes
0answers
411 views

Creating yum .repo file from a remote repo using rpm

This command (from the install page for Varnish 3.x): rpm --nosignature -i http://repo.varnish-cache.org/redhat/varnish-3.0/el6/noarch/varnish-release/varnish-release-3.0-1.el6.noarch.rpm appears ...