2
votes
1answer
993 views

why can't I install packages with rpm? I get “transaction lock”

I'm having problems with yum and I am trying to re-install it. I've download yum.3.2.0-40-el6.centos.noarch.rpm. When I try: $ rpm -ivh yum.3.2.0-40-el6.centos.noarch.rpm I get: error: can't ...
26
votes
7answers
5k views

Non-Root Package Managers

From my research, I seem to notice that all package managers insist on being used as a privileged user and must be installed into /. Typically, what I like to do is create a throwaway account, ...