A pacman wrapper that adds seamless access to the Arch User Repository (AUR).

learn more… | top users | synonyms

14
votes
2answers
19k views

How do I unset a variable in bash

I have tried the following command to set Proxy on yaourt: export ALL_PROXY=http://proxy.example.com:8080 The question is how to unset the proxy on yaourt? In general how can I unset the value of a ...
7
votes
2answers
1k views

How to recognize harmful AUR packages

How do I recognize if a package which is installed via yaourt on arch linux could be harmful to my pc? I read in the wiki that I should check every installation I make with yourt. But what exactly do ...
6
votes
2answers
6k views

Check for updates of packages installed through yaourt

Is there anyway to update package installed with yaourt ? yaourt -Syu seems to do the same as pacman -Syu, which only care about package in official repository.
6
votes
2answers
5k views

Error updating all ArchLinux packages with -Syu

I am on Arch Linux with Kde. I haven't updated the packages in a while and I'm having a problem while trying to do so: The first thing I tried was: sudo pacman -Syu as the documentation says, and I ...
5
votes
2answers
3k views

How can I responsibly run updates automatically on Arch Linux?

I'm a bit of a newcomer to Arch Linux and still getting used to some of its paradigms. I come with a lot of habits from another distro that was quite a bit more structured and in some ways ...
3
votes
1answer
1k views

yaourt curl error: SSL connect error

I'm trying to install some packages form yaourt. For example : yaourt compiz But it gets me following error: [hamed@localhost ~]$ yaourt compiz curl error: SSL connect error Please tell me ...
3
votes
0answers
597 views

Arch Linux - make: error while loading shared libraries: libunistring

I keep getting this same error when trying to install various packages: make: error while loading shared libraries: libunistring.so.0: cannot open shared object file: No such file or directory It's ...
3
votes
0answers
595 views

Make yaourt does not reinstall when already installed

Is there a way to make yaourt does not reinstall when the package (from AUR) already installed $ yaourt -Q jruby local/jruby 1.7.3-1 but somehow $ yaourt --needed --noconfirm -S jruby keep ...
2
votes
3answers
468 views

How to recreate a package file from installed package?

I used yaourt to successfully build and install an AUR package, unfortunately missing the fact that in its default configuration the built package is removed after installation. Since the build took ...
2
votes
3answers
4k views

yaourt curl error: Couldn't connect to server

I'm trying to install some packages with yaourt. For example, when I try to install Google Chrome, I get the following error: $ yaourt google-chrome curl error: Couldn't connect to server I can ...
1
vote
2answers
1k views

Getting the error invalid option '--asroot' on packages

When trying to install the package kodi-standalone-service however after I get prompted for editing the PKGBUILD then I get this error. makepkg: invalid option '--asroot' Unable to read PKGBUILD I ...
1
vote
1answer
428 views

yaourt -Syu is not working in arch linux

I tried yaourt -Syu and got this error: error: failed to prepare transaction (could not satisfy dependencies) :: Starting full system upgrade... :: nvidia: requires linux<3.11 how could I solve ...
1
vote
1answer
1k views

How to use yaourt on arch linux under proxy?

How do I install applications using yaourt under proxy network. For pacman I can simply use: export http_proxy=http://usernm:passwd@link:port sudo -E pacman -S application But how do I do this for ...
1
vote
1answer
221 views

preserving colors when piping yaourt through sort

Can sort preserve piped in colors? I'm trying to modify yaourt -Qu | sort so I get color output. Tried googling this but I couldn't find a general way nor a special way to do this for sort.
1
vote
2answers
307 views

First KDE Session

I was curious, so I installed kde alongside gnome (which I use primarily, for the matter). I am running arch linux, and I installed kde using yaourt, by the following command: yaourt -Syua # ...
1
vote
0answers
101 views

cannot install anything using yaourt on Arch Linux

If I try to install using yaourt I get same error for every package, and it asks me to build package again and again. ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (cannot ...
0
votes
1answer
235 views

Always answer Yes to replace package Arch Linux [duplicate]

I am trying to build the latest KDE Frameworks git packages. However, I currently have installed the stable non-git packages. In order to install all of the git packages I need to answer 'y' to all of ...
0
votes
0answers
97 views

Arch Linux: yaourt budgie-desktop xml error

When trying to install the AUR (Arch User Repository) package "budgie-desktop" by running the command "yaourt -S budgie-desktop", I'm getting an odd error about an xml file: Command ...
-3
votes
0answers
23 views

“Oh no! Something has gone wrong” shows up - archlinux

I was installing some softwares like kivy and pip and everything seemed to work fine but I remember that some libs in cython or python had conflicts with other libs or something like that so I agreed ...