2
votes
1answer
51 views

How to select block of text in xterm

In some terminal emulators like gnome-terminal or terminator, I am able to select a block of text by pressing Ctrl and then clicking the mouse and dragging. This is useful, let's say, to select an ...
2
votes
2answers
186 views

vim colors not automatically loaded (probable Vundle conflict)

I've been trying to port my Windows .vimrc to Linux, to use on the command line (on gnome-terminal). Everything works fine, except for the colorscheme. It looks like it's loaded (:colorscheme returns ...
1
vote
1answer
84 views

Change terminal type for screen over a serial connection

I am connecting to an embedded Linux board using screen over a serial link and trying to change the terminal type, as the default vt100 is pretty restrictive in terms of colours and scrolling etc. ...
14
votes
3answers
2k views

Which terminal type am I using?

I have tested this with both Ubuntu 12.04 and Debian 7. When I do echo $TERM I get xterm But if I use the dropdown menu "help" > "about" then it says gnome terminal 3.4.1.1. Does this mean I am ...
0
votes
1answer
305 views

How to change keyboard speed in the Linux console? [duplicate]

When I press Ctrl + Alt + F1 the desktop environment disappears and a terminal window appears. Pressing Ctrl + Alt + F7 brings me back to DE. This terminal is useful when the DE hangs for some reason ...
2
votes
1answer
825 views

How to fix the shifted function keys in vim in xterm in gnome-terminal?

When I hit the <s-f2> key to execute my nnoremap <s-f2> :set number! mapping Vim opens its "Insert" mode above (O) and types the 1;2Q string. In order to see the entire terminal key code – ...
3
votes
0answers
341 views

8-bit input in gnome-terminal

I'm trying to switch from xterm to gnome-terminal but having trouble with alt keys. I have already disabled menu access keys, but I still need 8-bit inputs. In xterm I can set 8-bit inputs in ...
0
votes
2answers
991 views

It's possible to make XTERM and Gnome-keyring work together?

When I'am connecting to ssh with gnome-terminal application opens gnome-keyring dialog, so I am entering password only once per session and I can reconnect to same ssh more than once without asking ...