The tag has no wiki summary.

learn more… | top users | synonyms

1
vote
2answers
81 views

Whiptail/dialog input bug when executed from rc.local

I need to start a Bash script containing calls to dialog at Debian boot time. This is how I've been able to do it: Unset default root password Set --autologin option to tty1 in initrd ...
0
votes
1answer
69 views

Resizing Whiptail to full terminal screen

How to make whiptail full terminal screen? "as big as the terminal", like fluid CSS, something like 100%
1
vote
0answers
191 views

Questions about whiptail and bash functions

I'm a bash newbie. Say I have this script #!/bin/bash function cpp-lang { yum install "Development Tools" } function updatesys { yum -y update yum -y upgrade } whiptail ...
1
vote
2answers
152 views

Bash script loop to grow parameters

I want to use whiptail to generate a checkbox list based on the output from another program. Only the first word on each line of the output from the first program is necessary, so I extract it using ...
0
votes
1answer
33 views

Confusion about basic bashscript loop - until/done [duplicate]

I have a bash script I'm working on to help with an installer. why doesn't this work? function fn_myFunc(){ local MYVAR=0 until ["$MYVAR" -ne 0]; do whiptail --yesno ...
3
votes
1answer
289 views

Change script to use whiptail instead of zenity

I'm having difficulty converting some zenity based script to use whiptail instead. The working script looks something like this: #!/bin/bash xfreerdp /v:farm.company.com \ /d:company.com \ ...
1
vote
1answer
240 views

Displaying messages to tty using whiptail through monit

I would like to display a whiptail message on the login screen that is triggered by monit, but I am without luck. I understand it might be something to do with interactive/non-interactive shell. Here ...
8
votes
3answers
5k views

whiptail or dialog

I am going to create script which will use user input, so I decided to use whiptail, but little bit confuse that which one is portable and will work in ubuntu 10.x and higher and CentOs5.x and higher. ...