2
votes
1answer
1k views

Why I got error: `error while loading shared libraries: libmpich.so.3`?

I installed mpich-3.0.4 not in a default location. I installed it based on the mpich installer's guidance. However when I try to run: mpiexec -n 4 -f machinefile ./mpich-3.0.4/examples/cpi It ...
3
votes
3answers
262 views

What is the preferred way to install new versions of software?

I have installed Ubuntu Server 10.10 and now I want to install some software like PostgreSQL, Nginx and PHP. But what is the preferred way to get the latest stable version of the software? E.g I ...