To upgrade is to replace a piece of hardware or software with a better, and usually newer, version or component.

learn more… | top users | synonyms (1)

1
vote
0answers
9 views

Downgrading Linux Mint kernels from 3.18.2-031802-generic to the previous one?

I have Linux Mint 17.1 Cinnamon version on my notebook HP Compaq 15-h050nl and about 1 month ago I upgraded the Linux Kernels to the current version (3.18.2-031802-generic). After done that, I had 2 ...
1
vote
1answer
444 views

Interdependent conflicting packages in CentOS 6.5

I've been using CentOS 6.5 as my OS for quite a while. Usually I don't have many problems with Linux installations, but as they new CentOS 6.6 was released I found myself in a bit of a problem. There ...
0
votes
0answers
12 views

Backbox Update jacks up Ruby / Gems [on hold]

If you are like me, you updated your backbox ISO as soon as you installed... and then were met with errors. If you haven't updated... do this first. sudo apt-get update sudo apt-get install ruby2.1 ...
3
votes
2answers
889 views

Install vlc 2.1.X on Linux Mint

I am trying to install new version of vlc on Linux Mint 16. I have tried tutorials on how to do it and no success. When I am trying to install it with apt-get install vlc I get the same version 2.0.8. ...
19
votes
4answers
25k views

How can I update to a newer version of Git using apt-get?

I've just set up a new machine with Ubuntu Oneiric 11.10 and then run apt-get update apt-get upgrade apt-get install git Now if I run git --version it tells me I have git version 1.7.5.4 but on my ...
2
votes
1answer
16 views

SSH demon not installed in linux embedded device

I have an embedded device which runs linux(arm). I am trying to update the executable through ethernet using scp command. But I got to know that sshd is not running in the device . I need to install ...
1
vote
0answers
16 views

The command “dmidecode -t 17 | grep Size” showing in CentOS release 6.5 (Final).

Recently I upgraded the system(Dell 720) RAM 8 to 16 GB(4*2[new ram]), but it is still showing old amount of RAM(ie 8GB). Please help me, If I need to install driver(module). Kindly Let me know all ...
0
votes
0answers
22 views

Pacman can't resolve dependencies: Archbang

i tried installing the latest firefox (and other browsers like palemoon) and was suggested to first use pacman -S --needed base-devel but got 'target not found:base-devel'Then was informed by another ...
0
votes
1answer
511 views

How to update CodeBlocks in Kali Linux?

I installed CodeBlocks on Kali Linux but I got 10.05 version and I want to update it to 13.12, preferably via terminal. Also I would like to know how to update any application this way.
0
votes
0answers
10 views

No sound with audio jack

I am using a Debian wheezy on Netbook eeepc 1001px After last kernel update When I plug the audio jack, I can here the electric charge but no sound when I remove it the internal speaker works ...
0
votes
1answer
332 views

Update from elementary OS Freya beta to stable

Freya stable released toady and I have installed Freya beta 2. I want to update to stable so tried using sudo apt-get dist-upgradebut it shows nothing. Do I have to make a clean install or is a update ...
0
votes
0answers
20 views

Error: version `GLIBC_2.14' not found

How do I run a program that was compiled against glibc 2.14 on an old system? I'm unable to update anything. Can I download newest glibc and somehow have the program use it instead of the installed ...
2
votes
1answer
26 views

When should I restart my computer after an update?

When I use a GUI updater, sometimes it says that my computer needs to be restarted. But when I use apt-get upgrade for example, I can't find messages like this. I saw this answer, so do I need to ...
4
votes
1answer
4k views

How to update glibc to 2.14 in CentOS 6.5

I want to install Android NDK on my CentOS 6.5 machine. But when I ran the program, it says it needs glibc 2.14 to be able to run. My CentOS 6.5 only has Glibc 2.12 installed. So I tried to update ...
0
votes
1answer
19 views

Gentoo CPU_FLAGS_X86 doesn't work

I havn't updated my system for few months and found i have to add new option to my make.conf. Ok, so now i have CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ...
10
votes
1answer
2k views

What do the characters y/d/N mean?

Dumb question, I know, but when I am updating my system, the machine tells me the size of the packages to download and asks me: is this ok: [y/d/N]? I know the meaning of y (yes) and N (no), but ...
3
votes
2answers
5k views

Arch Linux not booting after system update

After running a system update pacman -Syu with the testing repo not commented, my computer no longer boots. It shows the udev loading, then shows a black screen with a cursor blinking in upper left. I ...
1
vote
0answers
97 views

Is there any way to upgrade from KDE 4 to 5 on Linux Mint 17?

Earlier you could install KDE5 via repository using Project Neon, like these: http://www.webupd8.org/2014/07/how-to-install-plasma-5-in-kubuntu-1410.html, but unfortunately PPA maintainer deleted it, ...
4
votes
2answers
2k views

fedora 17 with fedup 0.7

I get the bug described here when trying to upgrade to Fedora 20 from Fedora 17. The symptom is that the first stage of upgrade (before rebooting) works successfully, but when you reboot to ...
0
votes
1answer
454 views

Getting conflict errors when runnin yum update

I'm truing to run yum update, and keep getting errors about conflicts. I must have accidentally interrupted an update at some point, but I don't know when and how. I've tried —skip-broken, but it ...
0
votes
1answer
741 views

How to disable automatic updates in CentOS 7?

CentOS Linux release 7.0.1406 (Core) / Linux 3.10.0-123.13.2.el7.x86_64 Last week, I noticed that when I tried to restart, there was an option to Install Updates & Restart. I do not recall ...
0
votes
1answer
502 views

How to upgrade Kali Linux 1.0.6 to 1.0.8 (Debian) using an offline ISO image?

I want to upgrade Kali Linux to 1.0.6 to Kali 1.0.8. I realized that I can do this using the command: apt-get update && apt-get dist-upgrade But I have a slow network and it would take ...
2
votes
1answer
596 views

How to get the latest GNOME shell in Fedora?

I want to try gnome-shell 3.5 but I dont see it in the repos, I'm using Fedora 17, is there any way adding gnome-shell 3.5 to my repos? Regards Update: Please note the question was asked on Aug ...
0
votes
1answer
237 views

What is the command-line equivalent to 'mintupdate' for Linux Mint?

Linux Mint has a nice GUI-based Update Manager with selectable update tiers. The defaults are for levels 1 through 3 our of a possible 5 levels. However, I often handle administrative tasks for a ...
4
votes
2answers
1k views

How can I responsibly run updates automatically on Arch Linux?

I'm a bit of a newcomer to Arch Linux and still getting used to some of its paradigms. I come with a lot of habits from another distro that was quite a bit more structured and in some ways ...
1
vote
0answers
28 views

Error during ubuntu upgrade (errors were encountered while processing)

I am trying to upgrade my ubuntu from 11.10 to 14.10 but I got this error message when I ran sudo apt-get -f install errors were encountered while processing: ...
6
votes
1answer
133 views

Preventing Nix from upgrading git to git-full

I'm using Nix on Ubuntu to have more modern versions of some packages, one of them being git. When I'm run nix-env -u, this is what happens: % nix-env -u --dry-run '*' (dry run; not doing anything) ...
1
vote
2answers
28 views

Download updates from peer computer over LAN

As you may have heard, Microsoft announced that Windows 10 will allow you to download updates not just from their servers, but from multiple sources using peer-to-peer over LAN and the Internet. My ...
3
votes
2answers
743 views

Will Debian Wheezy (stable) automatically upgrade to Jessie once Jessie becomes the stable release?

I am on Debian Wheezy (stable) and routinely update my system via the basic: sudo apt-get update sudo apt-get dist-upgrade In the future, once Jessie becomes the stable release, I wonder whether ...
0
votes
0answers
68 views

Ubuntu 14.04.2 LTS keeps telling that a new release is available

I have upgraded my Ubuntu VM from 13.10 to 14.04.2 LTS. When I log in, it keeps telling me that a new release "14.04.2 LTS" is available: Welcome to Ubuntu 14.04.2 LTS (GNU/Linux 3.11.0-18-generic ...
3
votes
0answers
203 views

Screen flickering (only on desktop) with Fedora 20, but why?

I'm using Fedora 20 and since I returned from the weekend, my screen flickers very fast. This occurs only on the desktop (excluding the menubar, with the fedora-menu and the clock, etc.) and the ...
0
votes
1answer
37 views

Fedora upgrade stuck between version 16 and 20

I was given remote ssh access to a server running Fedora 16. I tried upgrading it to Fedora 20 and rebooted. But it looks like the system wasn't fully updated. # uname -a Linux garden ...
4
votes
3answers
496 views

Linux Mint Not Updating

I literally installed it last night. This morning I saw an update icon but when I click Update Manager it says ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR E:Encountered a section with ...
1
vote
3answers
4k views

Upgrading curl in Centos 5.6

There is any easy way to upgrade the default curl 7.15 to the 7.20 or 7.21 version? Any repository to install into YUM. Edit: I found this repository with the last version ...
1
vote
1answer
108 views

Desktop gone after upgrade to Centos 6.6

I upgraded a local Centos VM from 6.5 to 6.6. After the update, no restart is needed and the desktop works. When I restart, I see the blue startup bar and CentOS 6.6 on the right side of it. When the ...
1
vote
1answer
83 views

Debian offline dist-upgrade in one step

Is there a way to perform a distribution upgrade on an offline Debian system by making only one return trip to an online machine? I've managed to perform the equivalent of apt-get update && ...
1
vote
0answers
20 views

How can I upgrade an application from new source?

I am runnign debian wheezy. I have PHP 5.4 installed from default repos. And now I have added these to sources list to upgrade to PHP 5.6 deb http://packages.dotdeb.org wheezy all deb-src ...
4
votes
3answers
5k views

On Debian Testing: How to get a recent Iceweasel Release (non-ESR) version without updating to Unstable?

I'm on Debian Jessie / testing. It currently has Iceweasel 17, but I would rather like to use a more recent release (Mozilla "Release" or "Firefox" 'channel' - currently Iceweasel 25). ...
1
vote
1answer
47 views

Keeping OpenBSD up-to-date with openup

I installed OpenBSD 5.6 -RELEASE on a machine, and then kept it up to date with M:tier's openup. Is my machine now considered up-to-date, the same way as it would be if I where following the -STABLE ...
0
votes
2answers
53 views

Ubuntu 14 won't update

I'm running ubuntu 14 and when the auto Software Updater launches it errors and offers only a partial upgrade, then errors completely. When I run sudo apt-get update it's fine. But when I run sudo ...
3
votes
0answers
134 views

update kernel without restart

Recently Linux got a new feature called Live Kernel Patching, which you means you dont have to restart your system to update kernel. Is there any other kernel which has this feature already or Linux ...
1
vote
4answers
7k views

The command to upgrade to a new kernel from Ubuntu repositories

In the distro I'm most familiar with -- ALTLinux, a command like apt-get install kernel-image-std-def#3.0.... would install another kernel, and update the initramfs and the bootloader config ...
1
vote
3answers
424 views

Failed at step EXEC spawning /bin/plymouth (Debian testing)

After I performed a dist-upgrade on a Debian testing (Jessie) instance, I can no longer boot. I'm marooned at the command prompt: Welcome to emergency mode! After logging in, type "journalctl -xb" to ...
1
vote
0answers
57 views

Problem dual booting windows 8 and ubuntu 14.04

I had windows 8 for like 12 months Yesterday I choose to install ubuntu 14.04. On windows 8 I had 2 partitions C(where windows was installed) and D(other ntfs partition). I shrunk D with 50 GB then I ...
0
votes
1answer
113 views

archlinux cannot execute java after update

I 've updated raspberry pi b+ arch linux via pacman -Syyu and now I cannot run java anymore because of following error: [xxxx@pi ~]# java -bash: /usr/bin/java: cannot execute binary file: Exec format ...
-1
votes
1answer
1k views

ifconfig shows only lo

I'm a beginner using Debian. I've just installed Debian 7.5.0 amd netinst. Actually I am trying to install the firmware through aptitude install firmware-linux-nonfree When I executed ifconfig and ...
0
votes
1answer
106 views

apt-get failed to find any updates for Debian squeeze

# ls -F /etc/apt/ apt.conf.d/ preferences.old sources.list trustdb.gpg trusted.gpg~ preferences.d/ secring.gpg sources.list.d/ trusted.gpg trusted.gpg.d/ # cat ...
1
vote
1answer
453 views

GHOST: glibc gethostbyname buffer overflow

https://rhn.redhat.com/errata/RHSA-2015-0092.html I can see md5sums of the packages, but cannot download them and my package manager says I'm up-to-date. [root@notebook log]# grep glibc-2 yum.log | ...
14
votes
2answers
6k views

What does “The following packages have been kept back” mean?

When doing an apt-get upgrade I sometimes get a message saying "The following packages have been kept back". For example: $ sudo apt-get upgrade ...
1
vote
0answers
21 views

shutdown, reboot, printer setup etc. unavailable to normal user after upgrading debian

I did an upgrade to my Debian Jessie box and after that shutdown, hibernate and suspend options are disabled in the gui. I can not even connect any new wifi connections via Network Manager. Also ...