0
votes
0answers
22 views

Obtaining error message using apt-get: “Unable to fetch some archives…” [on hold]

when i use sudo apt-get upgrade, I'm getting this message: E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
2
votes
2answers
234 views

many many dpkg errors while upgrading

I am using Ubuntu 14.04, newly upgraded from 12.04. I was trying to upgrade my software, but it is showing many, many dpkg errors regarding texlive-*. When I type following command: sudo apt-get ...
1
vote
1answer
116 views

'E:The package linux-headers-3.5.0-54 needs to be reinstalled, but I can't find an archive for it. ' when upgrading the system

I am using Ubuntu 12.04, and I try to upgrade to 14.04.1 using the terminal using: do-release-upgrade but I keep getting the following error: SystemError: E:The package linux-headers-3.5.0-54 ...
1
vote
1answer
72 views

Unattended upgrades and modified configuration files

We have the unattended-upgrades package upgrading our servers with security upgrades every Monday and it works great. Today though, it upgraded all of our servers with a new version of PHP5. Because ...
0
votes
2answers
123 views

Can't install mintupdate 4.5.6-1 (Linux Mint 16)

I can't install mintupdate 4.5.6-1 under Linux Mint 16. When mintupdate tries to upgrade version 4.5.6 to version 4.5.6-1 the following error pops up: E: Could not open lock file ...
4
votes
2answers
3k views

Failure to startx on Ubuntu 14.04 after security update - missing libXfont.so.1

I had Ubuntu 14.04 running perfectly on my system and then it underwent a recommended security update. I let it update while I was at work and when I returned I found a black screen stating, "No init ...
5
votes
1answer
95 views

How can I see when package has been upgraded?

Is there a way to see the upgrade history with date with some program e.g. apt? I want to know when exactly I upgraded security relevant packages the last time and the time before that... Thanks a ...
4
votes
4answers
3k views

How can I upgrade MySQL in Debian using apt-get?

I'm using the Turnkey Linux virtual machine. The version of Debian in there is apparently on the "Wheezy" upgrade path (if that's what you call it). I'm not completely comfortable with Linux, as you ...
4
votes
1answer
451 views

apt-get doesn't upgrade openssl on debian 7

I'm facing the following problem. If I run the command sudo apt-get upgrade, I get: Reading package lists... Done Building dependency tree Reading state information... Done The following ...
1
vote
2answers
107 views

How do I resolve an apparent hanging update process

I am trying to update an instance on AWS. I have little familiarity with linux in general. However, I did run the command on my Ras. Pi first and had no problems. However this is the second time ...
0
votes
1answer
90 views

Update Linux 10 Mint Julia to 13 Maya

Everytime I try to apt-get update it comes up with the following: Err http://archive.ubuntu.com Precise/main amd64 Packages 404 Not Found [IP: 91.189.91.14 80] Err http://archive.ubuntu.com ...
0
votes
0answers
52 views

How to fix boot failure after update

I did a apt-get update on Debian. After reboot the system lost its mount point and failed to boot. How could be accomplished to fix the boot failure?
0
votes
1answer
181 views

How to upgrade TurnKey Linux 12.1 to 13.0

I have a Turnkey Linux 12.1 installation that I would like to upgrade to Turnkey Linux 13.0. The upgrade should transition from Squeeze 6.0.8 to Wheezy 7.x. I want to upgrade the Wheezy to utilize a ...
0
votes
2answers
574 views

Debian 7 apt is upgrading my custom backported package with the “official” identical version!

and happy new year to you all.. Recently I've built nginx deb package v1.4.4 from debian backport source that of course I've added to the apt sources.list and things went great. I have run apt-get ...
3
votes
1answer
355 views

Machine readable number of updates? Alternative to /usr/lib/update-notifier/apt-check?

/usr/lib/update-notifier/apt-check (from update-notifier-common package) was a fine tool. But it's going to be removed from Debian. /usr/lib/update-notifier/apt-check --human-readable 28 packages can ...
3
votes
4answers
1k views

Is it necessary to reboot after a kernel upgrade (via APT)?

I have been wondering this for quite a while. Let's say that you have a Debian server that you keep updated via APT. Usually (every 1-2 months) there are some kernel updates, which will update the ...
3
votes
1answer
474 views

Can I upgrade to a newer Ubuntu version on a Ubuntu-based distribution?

I'm currently running elementary OS Luna, which is based on Ubuntu 12.04. Can I upgrade my installation to have a Ubuntu 13.04 base, but still use elementary OS's desktop environment and applications? ...
2
votes
1answer
153 views

apt upgrade: start a new shell to examine the situation. Where?

When I do a dist upgrade, I often get prompts about config files like this: Configuration file `/etc/php5/apache2/php.ini' ==> Modified (by you or by a script) since installation. ==> Package ...
2
votes
6answers
5k views

Why can't I upgrade Linux Mint 15 from Cinnamon 1.8.8 to Cinnamon 2.0, and how do I fix it?

So Cinnamon 2.0 is out, and I've followed the steps people have given for upgrading. sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable sudo apt-get update sudo apt-get dist-upgrade ...
0
votes
1answer
4k views

E: Some index files failed to download. They have been ignored…” when tunning “sudo aptitude update”?

This is what the end of output after I run sudo apt-get update on Ubuntu 12.04: Ign http://apt.typesafe.com unicorn/main Translation-en 35% [Working]W: Failed to fetch ...
0
votes
1answer
46 views

How to upgrade Magic Box?

I'm running Magic Box on Virtualbox. Magic Box is a portuguese Linux System, based off of SuSE. At least, that's what it said on the Linux Family Tree. The version I have is V.12. There's the most ...
1
vote
2answers
4k views

Failing on apt-get update

Very recently when I have been attempting to check for updates on my laptop (Ubuntu 12.04), the check fails. sudo apt-get update: W: GPG error: http://us.archive.ubuntu.com precise Release: The ...
4
votes
2answers
4k views

Can I rollback an apt-get upgrade if something goes wrong?

Is there a way, before starting an aptitude upgrade or apt-get upgrade, to set up something so that you can "easily" rollback your system to the "apt" state it was before the actual upgrade, if ...
0
votes
1answer
366 views

apt-get dist-upgrade wants to remove too much packages

I'm upgrading from Mint 13 to Mint 15 using apt-get dist-upgrade. It want to remove 277 packages, which I find quite a lot. Among those packages are acroread, xmlcopyeditor, wine1.4, skype and others. ...
1
vote
1answer
440 views

Apt-get dist-upgrade fails

I'm trying to upgrade from Mint 13 to Mint 15, but receive the following error: Calculating upgrade... Failed The following packages have unmet dependencies: mate-media : Depends: ...
0
votes
2answers
82 views

Where can I check what was updated on the last update?

Once in a while, when updating my system after reboot I got a black screen. The problem seems to bee ATI drivers, but it's weird because even TTYs do not work. For fix it I reboot on recovery mode, ...
2
votes
2answers
784 views

Upgrade a single package from a target release

In Debian Squeeze I have installed a packageX from debian-backports. Q1: When I apt-get dist-upgrade or aptitude full-upgrade, what release is checked for updates for packageX? debian-backports or ...
2
votes
2answers
790 views

debian apt-get dist-upgrade from squeeze to wheezy failing on vlc

I can't continue until I solve this bug, I've tried removing the dpkg so it redownloads it but it still has this error when trying to dist-upgrade, or now, apt-get -f install. root@hayek:~# apt-get ...
6
votes
1answer
1k views

disable apt-listchanges (and other interactive stuff) during upgrades (reliably)

I have to admit, I really really hate apt-listchanges. If I'm going to do a huge dist-upgrade, I want to just leave the computer there for a few hours. The asker of this serverfault question had a ...
1
vote
3answers
6k views

The command to upgrade to a new kernel from Ubuntu repositories

In the distro I'm most familiar with -- ALTLinux, a command like apt-get install kernel-image-std-def#3.0.... would install another kernel, and update the initramfs and the bootloader config ...
10
votes
2answers
5k views

What does “The following packages have been kept back” mean?

When doing an apt-get upgrade I sometimes get a message saying "The following packages have been kept back". For example: $ sudo apt-get upgrade ...
3
votes
3answers
186 views

Using the apt package manager refuse an update for a specific package

I am attempting to upgrade a few packages using the apt package manager. However there is a specific package in the list that I don't want to upgrade. In fact I don't want anyone to ever upgrade it. ...
9
votes
2answers
15k views

How can I update to a newer version of Git using apt-get?

I've just set up a new machine with Ubuntu Oneiric 11.10 and then run apt-get update apt-get upgrade apt-get install git Now if I run git --version it tells me I have git version 1.7.5.4 but on my ...
2
votes
0answers
83 views

Can sources.list only be updated by hand?

I'm currently running Linux Mint. I remember that under Ubuntu, whenever a new release comes out, it prompts you with a choice of whether to upgrade or not. It seems like this is not happening in ...
5
votes
6answers
6k views

Can I use `apt-get` to upgrade to the latest version of Nagios?

At the time of this writing the latest version of Nagios is 3.3.1. I am running Ubuntu 10.04 and have used apt-get update; apt-get install nagios3 to end up with version 3.2.0. I know there are a lot ...
10
votes
5answers
5k views

“tar: unrecognized option --warning” during 'apt-get install'

I just ran apt-get upgrade on my debian 5 vps and I got this error: tar: unrecognized option `--warning=no-timestamp' Now when I try to install other packages e.g: imagemagick I get the same ...
2
votes
1answer
451 views

Upgrading ffmpeg

How can I upgrade ffmpeg to version 0.6 on debian-based operating system? I'm using apt-get for installation and deb packages.
4
votes
1answer
2k views

Problems with apt-get upgrade on Debian (404 Not Found)

I can't update my Debian Sid system. on running the apt-get upgrade I am getting: maciej@wladyslawa:/etc/apt$ sudo apt-get upgrade Reading package lists... Done Building dependency tree ...