To upgrade is to replace a piece of hardware or software with a better, and usually newer, version or component.

learn more… | top users | synonyms (1)

1
vote
1answer
15 views

How to update kali without internet connection manually?

I have installed kali linux in virtual box with a windows host, and when I try to update kali it completes 5-10 packages and aborts saying connection failed. I have a slow connection and want to get a ...
0
votes
0answers
40 views

archlinux cannot execute java after update

I 've updated raspberry pi b+ arch linux via pacman -Syyu and now I cannot run java anymore because of following error: [xxxx@pi ~]# java -bash: /usr/bin/java: cannot execute binary file: Exec format ...
1
vote
1answer
231 views

centos dropbox newest version not starting

I have some issues getting dropbox to run on Centos 6.3. These issues started after I recently got a security warning to upgrade Dropbox. Before this, the older version (not sure which one exactly) ...
-1
votes
1answer
21 views

Yum update error and returns system error

Error Type: Error Value: File contains no section headers. I don’t understand I did not edit or did anything to that repos.d file :( [root@planetery ~]# yum update Loaded plugins: fastestmirror, ...
1
vote
1answer
21 views

How do I fix a transaction error?

I have Transaction check error between nodejs-0.10.33-1nodesource.fc20.x86_64 and nodejs-semver-2.1.0-1.fc20.noarch. Full error at gist:8998690a05100b1f6085 When I run yum list nodejs I get: ...
0
votes
1answer
16 views

Yum won't update package

I am trying to update the package minetest from 0.4.9 to 0.4.10, but when I update the whole system, it states that there are no updates available. If I try to update the package alone, I get the same ...
0
votes
1answer
53 views

“Shell connection” item disappeared from Midnight Commander menu

I have performed an upgrade of my distro (openSUSE 13.1 -> 13.2) and now no long see menu item in Midnight Commander that allows me to perform operations with remote files via SSH. Coressponding menu ...
1
vote
1answer
79 views

Failed at step EXEC spawning /bin/plymouth (Debian testing)

After I performed a dist-upgrade on a Debian testing (Jessie) instance, I can no longer boot. I'm marooned at the command prompt: Welcome to emergency mode! After logging in, type "journalctl -xb" to ...
4
votes
1answer
37 views

Why is there no “mark for upgrade” in Synaptic Package Manager for upgradeable packages?

The help docs mention marking for upgrade. The context menu and menu bar do not have this option listed at all, and the only non-greyed-out options are marking for removal or complete removal. There ...
1
vote
1answer
235 views

insmod: ERROR: could not insert module 8188eu.ko: Invalid module format

I'm trying to use the TL-WN725N as an USB WiFi-Adapter with Fedora 20. I followed these insructions and the adapter worked fine and even survived two updates during the last few weeks. Then I did a ...
0
votes
2answers
66 views

Debian Jessie updates

I've installed Jessie about 2 months ago (from a fresh download from Testing), and I never see package updates notifications. And I am never asked to download anything. Is there something I have to ...
2
votes
0answers
23 views

Why libpam-systemd run interactively on apt upgrade, even when specified force-confdef/force-confold

I upgrade my packages using aptitude, specifying the apt options --force-confdef and --force-confold. This generally works, but the package libpam-systemd (204-5ubuntu20.8, on Ubuntu 14.04) still ...
1
vote
0answers
49 views

un-official OS upgrade

I want to install a package called plasma-nm on Elementary OS Luna. But the problem is that software requires network-manager 0.9.8 or greater. while I have 0.9.7, can I upgrade network-manager? I ...
0
votes
1answer
41 views

Install latest GTK without building myself

I'm using GTK3.4 and I need to update to > GTK3.10 for a theme editor I would like to use. I've never built something like that from source and the task looks a bit daunting. I've looked at what's ...
1
vote
1answer
62 views

How can I upgrade a complete list of packages from stable to backports

I have installed Qt 4.8.2 from Debian Wheezy on my system. Now, some application requires Qt 4.8.3 on my machine, so I looked at the versions and found that Qt 4.8.6 is avaliable in Wheezy-Backports: ...
1
vote
1answer
50 views

Writing ISO (Specifically Debian Jessie) to an SD Card

When updating Debian Wheezy (the stable release) to Jessie, it crashed, so it is currently unusable. The only solution to this, as far as I can tell, is to overwrite Jessie on top of what is currently ...
5
votes
2answers
139 views

Packages to rebuild after upgrading gcc on gentoo systems

Which packages should be rebuilt after upgrading gcc on a gentoo system? Is it sufficient to run # emerge -a --oneshot `equery depends gcc |awk '{print " ="$1}'` as suggested similar for perl in ...
1
vote
1answer
216 views

Interdependent conflicting packages in CentOS 6.5

I've been using CentOS 6.5 as my OS for quite a while. Usually I don't have many problems with Linux installations, but as they new CentOS 6.6 was released I found myself in a bit of a problem. There ...
3
votes
1answer
161 views

Delaying kernel upgrades on Arch Linux

On Arch Linux, whenever a kernel upgrade is applied (via pacman -Su), problems occur. For example, iptables can no longer be used: # iptables -L iptables v1.4.21: can't initialize iptables table ...
0
votes
0answers
16 views

Unable to start skype in Xubuntu [duplicate]

After xubuntu updating the skype I am unable to launch the last. sudo apt-get autoremove --purge skype Erase /.Skype by graphic client sudo add-apt-repository "deb http://archive.canonical.com/ ...
0
votes
0answers
30 views

How do I set kernel-ml default in CentOS?

I have installed kernel-ml package from http://elrepo.org/tiki/kernel-ml Now I have both the original CentOS kernel and kernel-ml. How do I set kernel-ml as default on boot? Thank you!
0
votes
1answer
171 views

How to update CodeBlocks in Kali Linux?

I installed CodeBlocks on Kali Linux but I got 10.05 version and I want to update it to 13.12, preferably via terminal. Also I would like to know how to update any application this way.
0
votes
0answers
67 views

What is the command-line equivalent to 'mintupdate' for Linux Mint?

Linux Mint has a nice GUI-based Update Manager with selectable update tiers. The defaults are for levels 1 through 3 our of a possible 5 levels. However, I often handle administrative tasks for a ...
1
vote
1answer
275 views

Trouble with opkg package manager in Angstrom embedded linux on Colibri module ARM v7 processor

I am working on a Colibri module having Angstrom linux installed in it! The processor is ARM v7. I am having trouble updating the softwares installed in the system. Whenever I tried the command opkg ...
2
votes
2answers
43 views

Why does RHEL offer updates for hardware I don't have?

RHEL 7 offers me to install 150+ updates, and it seems most part of these updates are not applicable to my server. For example it offers to install some "WiFi" Firmware, but my server doesn't have any ...
0
votes
0answers
212 views

How to upgrade Kali Linux 1.0.6 to 1.0.8 (Debian) using an offline ISO image?

I want to upgrade Kali Linux to 1.0.6 to Kali 1.0.8. I realized that I can do this using the command: apt-get update && apt-get dist-upgrade But I have a slow network and it would take ...
0
votes
0answers
101 views

BASH-3 update: how to revert / undo the changes?

I am using Mint 17, 64-bit with Cinnamon. I recently updated Bash and following the update mint drivers are missing and mint is not working. So I want revert the changes. How can I do it? For ...
0
votes
0answers
70 views

How to update apache 2.2.12 to 2.2.15 on SUSE enterprise linux server 11?

I have a requirement where I need to upgrade my Apache on SUSE enterprise Linux server 11 from 2.2.12 to 2.2.15. I tried searching on web but couldn't get any definitive answers.
-1
votes
1answer
122 views

How can I update BASH [duplicate]

How can I update BASH? I noticed that there are version 4.2.45 env x='() { :;}; echo vulnerable' bash -c "echo this is a test" this is a test cat /etc/redhat-release CentOS release 5.11 (Final) rpm ...
0
votes
1answer
91 views

Can't change update settings on elementary?

I can't update elementary os, when I try to change the settings 'Install updates from', none of the check boxes will check, it stays like the following image. What should I do?
0
votes
0answers
67 views

Fedora 20 won't startup after shutdown during kernel update

I had a few bugs in my System(System Settings not opening and Firefox not starting) and I thought a kernel update(via yum) could do it some good. During that update, I suddenly got logged out as if ...
1
vote
1answer
30 views

Need to automate the updating of the crontab file

We have an automated process where a server is built, and after applications/middleware are installed using another automated process, and the crontab needs to be updated for those ...
0
votes
1answer
211 views

Upgrading Ubuntu 13.09 to 13.10 for LTS?

I am trying to upgrade my ubuntu installation so I can begin working with mod_mono for apache. I tried to the usual upgrade command but I am getting some odd results. Any help would be much ...
0
votes
0answers
286 views

Upgrade apache 2.2 on CentOS 5.1

I need to UPGRADE Apache on a CentOS 5.1 server. Its currently at 2.2.14 and I want to bring it up to the latest 2.2.29. Upgrading the OS is not an option, and I don't want to install Apache 2.4 and ...
6
votes
3answers
2k views

Do I have to reboot after updating bash to avoid shellshock?

I've updated my systems to the latest versions of bash (Fedora: bash-4.2.48-2.fc19.x86_64 and CentOS: bash-4.1.2-15.el6_5.2.x86_64) Is merely updating enough to avoid the exploit or do I need to then ...
0
votes
0answers
120 views

Upgrading from Fedora 17 to Fedora 20 (or higher)

I'm trying to upgrade my fedora 17 install to a more recent version. I have tried the following methods, which don't work: First, using fedup: # yum install ./fedup-0.8.1-1.fc20.noarch.rpm Loaded ...
0
votes
0answers
43 views

Intel Centrino Wirelsess-N 1030 not getting connected on generic mode in ubuntu 14.04

I upgraded Ubuntu from 12.04 to 14.04. After upgrading neither WLAN and ethernet work and also does not work in recovery mode (enable networking) or root shell. When booting the previous version ...
1
vote
2answers
51 views

ntpd installed to local directory, now have two versions

I got the latest version of ntpd because the binary releases have vulnerabilities. Unfortunately, after I built it and ran make install, it was installed to /usr/local/sbin, but the system is running ...
0
votes
1answer
290 views

How can I install all packages when apt-get dist-upgrade does nothing?

On my Debian system (Raspian Raspberry Pi), some packages were kept back. I tried sudo apt-get dist-upgrade, but this did not result in an upgrade. $ sudo apt-get upgrade -y Reading package lists... ...
1
vote
1answer
323 views

Install vlc 2.1.X on Linux Mint

I am trying to install new version of vlc on Linux Mint 16. I have tried tutorials on how to do it and no success. When I am trying to install it with apt-get install vlc I get the same version 2.0.8. ...
7
votes
2answers
29 views

How does linux driver update work?

As far as I know no update on a linux machine requires a restart. Windows however needs to restart several times for a update to complete which is understandable because the hardware might be in use ...
2
votes
2answers
722 views

many many dpkg errors while upgrading

I am using Ubuntu 14.04, newly upgraded from 12.04. I was trying to upgrade my software, but it is showing many, many dpkg errors regarding texlive-*. When I type following command: sudo apt-get ...
1
vote
2answers
295 views

'E:The package linux-headers-3.5.0-54 needs to be reinstalled, but I can't find an archive for it. ' when upgrading the system

I am using Ubuntu 12.04, and I try to upgrade to 14.04.1 using the terminal using: do-release-upgrade but I keep getting the following error: SystemError: E:The package linux-headers-3.5.0-54 ...
0
votes
2answers
433 views

All Domains Missing After Plesk Parallels Upgrade From 11 To 12

I've just used the Parallels upgrade service (autoinstaller in terminal). I upgraded from Parallels 11 to 12. I logged into the panel, it asked me all the personal info and I started to get nervous. ...
0
votes
1answer
332 views

Getting conflict errors when runnin yum update

I'm truing to run yum update, and keep getting errors about conflicts. I must have accidentally interrupted an update at some point, but I don't know when and how. I've tried —skip-broken, but it ...
1
vote
1answer
91 views

stable, stable/updates and stable-updates in the sources.list

Very often now I have seen sources.list files (including my own) that contain lines like these: deb http://security.debian.org/ testing/updates main contrib non-free deb ...
2
votes
3answers
62 views

Alsa driver update in client machine without make

I have a Debian 6 system and updated alsa from 1.0.23 to 1.0.25, It works as expected. Steps which I performed to compile: ./configure make make install Now , I have 100's of client machines in ...
4
votes
2answers
2k views

Should I let pacman replace glamor-egl with xorg-server?

This is the output of pacman. I installed nothing; just wanted to update... :: Synchronizing package databases... core is up to date extra 1761.1 KiB 2.58M/s 00:01 ...
0
votes
1answer
86 views

Upgrading Linux (Fedora) with LUKS encrypted volume

I have FC18 on a LUKS/dm-crypt encrypted hard disk. I'd like to upgrade the system via a FC20 dvd. I looked around a bit and it seems that upgrading the system via the installation procedure from the ...
2
votes
1answer
46 views

pacman does not sync core

I run as root pacman -Syu However it just skips right over [core], without prompts, etc. Just like it was normal to proceed when 0% done. It just proceeds with extra and community. How can I force ...