The tag has no usage guidance.

learn more… | top users | synonyms

1
vote
2answers
862 views

Can I mount a microsoft mirrored dynamic disk?

I'm testing out sw raid in windows 7, but I almost always use linux and I would like to know if it's possible to mount such a mirrored dynamic disk. I can already mount each members separatly but ...
2
votes
1answer
24 views

Is there a way to rebuild only part of a disk in an mdraid5 setup?

Last night I accidentally used dd to overwrite the first ~20GB of a drive in a RAID5 array. When I noticed, I repaired the array with $ mdadm --fail /dev/md127 /dev/sdb $ mdadm --remove /dev/md127 ...
1
vote
1answer
49 views

How do I handle Linux RAID0 and Windows striped dynamic volumes on the same set of hard disks?

I recently got a 1TB disk to supplement my two 500GB disks, and I decided to use some form of RAID on the latter. I divided the 500GB disks into two partitions each. Then, I created a RAID0 using the ...
1
vote
1answer
92 views

How to implement RAID 6 over different nodes on the network

I am trying to create a RAID 6 over independent nodes which are on the network. I have to further implement LVM over this RAID 6. I read about it at ...
1
vote
1answer
61 views

mdadm RAID10 - change broken disk

Tonight my server stopped answering to ssh, ping, so I drove to the server room. Server did not respond to keyboard (even Ctrl-Alt-Del), there was no data on screen (it was black, no symbols on it), ...
1
vote
1answer
265 views

Removing failed disk from raid 1

my server (Debian Wheezy) has a failed disk. I have sda and sdb and according to the support of my hoster, sdb needs a replacement. I send them this information with the mdstat: ...
0
votes
1answer
60 views

How to make Drives visible to OS using MegaCLI / MegaRAID not puting them in to RAID at all?

So I have 12 [12:0-12] drives that are "Unconfigured Good" as WebBIOS would say. They are not in any virtual drive span or drive group. I want to use software ZFS RAID instead of hardware one. How to ...
0
votes
1answer
87 views

Recovering a (not yet created) RAID5 with URE (Unrecoverable read errors)

I wan't to create a RAID5 array at home, the OS is Linux (Kernel 3.15.7) and the array will be created with mdadm. I wan't to create the array with eigth or ten 1TB discs. Let's assume a single drive ...
2
votes
0answers
11 views

Btrfs: available space not used after migrating from RAID1 to RAID6

I had 8 2TB disks running in a RAID1 setup but it started to get full so I converted it to a RAID6. However, it seems I can't use the space I've gained by switching to RAID6. My filesystem is pretty ...
2
votes
0answers
30 views

mdadm - Creating RAID1 on LiveUSB does not persist when re-booting

I have three drives sda, sdb, and sdc: $ lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 2.7T 0 disk ├─sda1 8:1 0 1M 0 part ├─sda2 8:2 0 500M 0 part ├─sda3 ...
2
votes
0answers
66 views

How to replace faulty device on RAID5

I wanted to replace a corrupted raid5-device on my linux system (opensuse 13.2) but missed the step of set-faulty/removing the device (/dev/sdc1). So i accidently just switch the device with a cloned ...
2
votes
0answers
80 views

MD soft-raid to replace fake raid: How to get rid of old metadata?

I had a system running with fake RAID (Intel controller, imsm), which had some problems. Now I'm switching to the regular MD soft-RAID - I created a RAID 1 on /dev/sda1 and /dev/sdb1. Seems to work ...
2
votes
0answers
202 views

What changed between kernels 3.7 and 3.9 that affects LVM/RAID root file systems?

I'm trying to fix a (very messy) system that the user hosed by running a kernel upgrade from 3.7.10 to 3.9.6. the root file system is on an LVM volume on top of a software RAID array. The boot manager ...
2
votes
0answers
653 views

Disable RAID auto detect at runtime

In Linux, I'm partitioning two disks for RAID1 with fdisk. The first disk partitioning succedes, but the second fail because the raid starts automatically and occupy also the second disk (why? it ...
1
vote
0answers
25 views

lsblk shows non-existent md partitions after reboot

I'm getting weird behaviour while setting up an mdadm RAID1 array on debian 8.2. After I set-up the array, lsblk shows: simon@debian-server:~$ lsblk NAME MAJ:MIN RM SIZE ...
1
vote
0answers
56 views

How to recover an Intel RAID 0 on a Rocks cluster distribution

We had a Rocks 5.5 distribution on our cluster and wanted to upgrade to 6.2. The "/export" partition was mounted on a Intel software RAID 0 array of 2 identical hard drives (HD) (/dev/sdb and ...
1
vote
0answers
14 views

EFI boot and RAID6

I am a Linux beginner and I am trying to install SLES on a server with 8 HDDs, 3 TB each, but I am testing the configuration first on a VM (virtualbox). I tried following configurations and both got ...
1
vote
0answers
56 views

How has this arrangement of RAID disks occurred and is it recoverable?

I some months ago set up two RAID arrays for a system under CentOS 7. I was somewhat confused that the device list included two entries for each array, i.e. one had /dev/md126 and /dev/md126p1. The ...
1
vote
0answers
26 views

Is it reliable to assemble md from two machines at the same time

Say we have the same disks accessible from two machines. I want to do assembling md from two machines. Is it possible/reliable ? The disks are connected through SAS. All I need to have is reliable ...
1
vote
0answers
756 views

Help with lost software RAID5 on CentOS 6.5

I've been searching for hours and giving up / too scared to delete all my data. I have a file server running CentOS 6.5 which has 4 WD RED 2TB drives (all > 1 year old) in software raid 5 with mdadm, ...
1
vote
0answers
709 views

After ubuntu install + software raid 0 config, we see: rejecting I/O to offline device

I'm trying to pin down what this error rejecting I/O to offline device is, as seen towards the end of this syslog. Ideas: Problem with RAID-0 configuration (we have 2 4TB disks in RAID-0 and I do ...
1
vote
0answers
682 views

Installing 12.04LTS Server on a Fake RAID10

Scenario Install Ubuntu 12.04LTS Server on a RAID10 with boot on a RAID1. 4 - 2Tb SATA Hard Drives 3 Partitions (/boot, /, and swap) boot (256Mb from each disk) setup in RAID1 /dev/md0 partition ...
0
votes
0answers
19 views

raid5 array reassembles as raid0

I found simmilar problem here: Missing mdadm raid5 array reassembles as raid0 after powerout, but mine is a bit different. Here too my raid5 reassembles as raid0, but i don't see any of my devices ...
0
votes
0answers
42 views

raid10 “recovery aborted due to read error” drives being marked spare

I'm trying to recover my RAID10 array. All devices are plugged into a PCI controller that I've been using for a number of years now. I just replaced all of the drives in the system, as they all seemed ...
0
votes
0answers
51 views

Debian 8 sytemd “found device” multiple times

I currently run a Debian 8 system (upgraded from Debian 7) with a software raid 1. Once in a while systemd reloads 3 times in a relatively short period and logs it into syslog. If it reloaded only ...
0
votes
0answers
55 views

Software raid problem

We have a software raid on our server and we have a problem with disk performances. From time to time disk i/o freezes. During those periods iostat shows that one disk is faster than another. Both ...
0
votes
0answers
66 views

How to recover a partition recreated with gparted

Yesterday I've had the bad idea to try to follow this tutorial : http://fds-team.de/cms/articles/2013-12/use-a-real-windows-7-partition-in-virtualbox-kvm-vmware-player-u.html these are the commands ...