0
votes
0answers
23 views

Moved Raid from NAS box to PC running Ubuntu hdparm shows drives frozen

So I had a RAID5 setup in a Partriot S4 Javelin (a NAS box). I'm now migrating it to a proper server running Ubuntu 14.04. NOTE: There are 4 drives. All the drives show up in Ubuntu. Two show ...
0
votes
0answers
23 views

Ubuntu raid dirty degraded

I have Linux version 3.5.0-17-generic (buildd@allspice) (gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1) ) #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 (per /proc/version). There are two raid arrays ...
2
votes
1answer
428 views

mdadm - RAID5 array size vs. actual disk size mismatch

I have 4x 3TB WD RED disks that are in mdadm RAID5, which should total an array size of 9TB usable space, however I only have 6TB. I have confirmed all disks are in the array, the only strange thing ...
1
vote
1answer
229 views

Ubuntu Server - OS on single HDD, file server on software RAID 1

I run a Windows Server 2008 machine. It is used as a file server (File Services feature), in addition to local shares I use CrushFTP for SFTP and HTTP access to my files. I would like to convert to ...
1
vote
2answers
140 views

Raid5 Device Has Less Space Than Expected

I have 3 3TB drives, and have raid5ed them together. I would expect to get a resulting device around 6TB. The command I used: mdadm --create md0 --level=5 --raid-devices=3 /dev/sda1 /dev/sdb1 ...
1
vote
0answers
375 views

After ubuntu install + software raid 0 config, we see: rejecting I/O to offline device

I'm trying to pin down what this error rejecting I/O to offline device is, as seen towards the end of this syslog. Ideas: Problem with RAID-0 configuration (we have 2 4TB disks in RAID-0 and I do ...
0
votes
2answers
297 views

Migrate an entire volume group LVM2 to RAID5

I have a Virtual Host server build with Ubuntu and Xen SO Ubuntu 12.04.1 LTS 64Bits xen-hypervisor-4.1 Disk Hitachi SAS 15K 147GB (x2) in a Volume group sda1 1GB /boot sda2 146GB lvm sdb1 ...
0
votes
1answer
199 views

Can I configure software RAID on an existing server without losing the existing partition?

I've got an existing server with 1 disk and Ubuntu 12.10 installed and running. I want to add a 2nd disk and configure RAID 0 across the two disks using Ubuntu's software RAID. Can I do this ...
1
vote
0answers
485 views

Installing 12.04LTS Server on a Fake RAID10

Scenario Install Ubuntu 12.04LTS Server on a RAID10 with boot on a RAID1. 4 - 2Tb SATA Hard Drives 3 Partitions (/boot, /, and swap) boot (256Mb from each disk) setup in RAID1 /dev/md0 partition ...
6
votes
3answers
16k views

How to mount/recover data on a disk that was part of a mdadm raid 1 on another machine?

Some background The disk itself was "worked on" by a friend and is said to be still intact, undamaged and still mountable/recoverable The disk was part of a software raid 1 on Ubuntu 12.04 The other ...
5
votes
1answer
1k views

degraded software raid boot

I've installed Ubuntu 12.04.1 in a new server and set up the 4 hard drives with 3 RAID 1 devices, the configuration is such that the first two drives have md0 (swap space) and md1 (/) with the third ...
2
votes
1answer
366 views

“error: no such device” at boot in Ubuntu Server 11.10 with Raid1

I have a configuration of 4 HDD's as Raid1 2 pairs of 2 HDD's. First Raid1 pair is for system, so I just made an 40GB space for swap, and the rest of it for the root, the second pair of Raid1 is for ...
1
vote
1answer
686 views

How do I attach my LVM RAID's to a new Ubuntu install?

I have an Ubuntu 9 Desktop system that I mainly use as a media server. I have a 2TB RAID5 and a 500GB RAID1, both using LVM. The OS drive is a 4GB CompactFlash card which has finally run out of space. ...
1
vote
2answers
267 views

Copying linux install from non-RAID/x86 to RAID/x86-64

I'm copying an Ubuntu Server install from an x86 machine with a single hard disk to a new machine with x64 and two identical disks. Two partitions will span the new disks: One small-ish RAID1 for ...