Installing software on a running system, either as binaries or from source

learn more… | top users | synonyms

0
votes
1answer
5k views

How to make mk809III run linux like picuntu?

I bought a mini pc Android stick called "mk809 III" which is quad core and has 2 gig's of ram. I want to make it as my web server with Apache and MySql, to do this I got to install some linux distro ...
4
votes
1answer
379 views

How to change the repository settings for yum installer?

I am pretty much new to Linux. I am trying to install tint2 on CentOS. When I try to install using the command yum install tint2, it gave following error checking for X11... configure: error: Package ...
1
vote
0answers
24 views

Setting XDG_DATA_HOME and XDG_CONFIG_HOME on compile/per program

The goal is to have a -dev version and a stable repository-based version installed at the same time, but with different data and config directories so that the dev version is not operating on(and ...
1
vote
2answers
77 views

Installing R 3.1.1 (programming language) on debian wheezy

I want to learn and use R, and so I need to install it. Unfortunately, Wheezy got only 2.15 version, while I need 3.1.1. I followed these instructions: http://cran.r-project.org/bin/linux/debian/ and ...
0
votes
1answer
50 views

Unable to install ATI Catalyst drivers under CentOS 7

I'm getting an error running ./amd-driver-installer-14.20-x86.x86_64.run # ./amd-driver-installer-14.20-x86.x86_64.run Created directory fglrx-install.xjgOcJ Verifying archive integrity... All good. ...
3
votes
1answer
26 views

Replace FreeBSD base clang with ports clang

FreeBSD 10 was the first release that officially released with Clang as the default, base compiler. Most ports, unless specially marked, now compile using the base ("pre-installed") clang. ...
0
votes
1answer
22 views

Uninstall nspr in linux

I installed nspr by first downloading its tar.gz file, unzipped the file and finally by writing sudo ./configure I want to un-install it now. How can I do it ?
0
votes
0answers
97 views

Configuring VMware 7 Workstation on Fedora 20 x86_64 KDE

When I first time around installed VMware, it Installed successfully and when I ran the program it got me to where you have a dialog box to select the kernel module, now when I install it the program ...
1
vote
4answers
3k views

Handbrake for wheezy?

Has anyone figured out how to install/backport a Debian Handbrake package on Debian wheezy? The only version of Handbrake currently in Debian is in experimental, and the dependencies are not available ...
1
vote
2answers
116 views

Cannot succesfully run apt-get -f install

I am working on a Ubuntu Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-43-generic x86_64) machine. There are some packages that I need to install, and in order to be able to that, first I have to run apt-get ...
0
votes
1answer
1k views

Oracle 11g R2 on Redhat 6

I have a Solaris background, and I am new in RHEL, and I want to install Oracle 11g on it. I downloaded Oracle documentation, that illustrate how to install it for RHEL 6. The following or later ...
18
votes
4answers
1k views

What is the difference between building from source and using an install package?

It was wondering: when installing something, there's an easy way of double clicking an install executable file, and on the other hand, there is a way of building it from source. The latter one, ...
10
votes
7answers
32k views

How to install .tar.bz and .tar.bz2 packages?

I would like to know how to install .tar.bz and .tar.bz2 packages on Debian, please give me a complete explanation.
1
vote
2answers
38 views

“ImportError: libssl.so.1.0.0: cannot open shared object file: No such file or directory” during Bitmask installation

I am trying to install Bitmask on my system(Fedora 20) to get the riseup VPN running. Running ./bitmask after unpacking the tarball gives the following output: Bitmask-linux64-0.6.1-4]# ./bitmask No ...
0
votes
1answer
38 views

“tar (child): Cannot connect to https: resolve failed” when installing Bitmask

I am trying to install Bitmask on my system to get the riseup VPN running(https://help.riseup.net/en/vpn/how-to/linux), but as you can see, there are no packages for Fedora. I tried the compressed ...
0
votes
1answer
2k views

install latest gcc on rhel 6 x86_64

I have an RHEL 6 server with gcc version 4.4.7. I wanted to update the gcc version (I think the current one is 4.8). Yum update doesn't work. Also, SO answers for a similar question on CentOS does not ...
0
votes
1answer
50 views

Unmet dependencies using apt-get on Ubuntu

I am working on a Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-43-generic x86_64) machine. It is a server running in production environment with other projects so I have to be quite careful. I have to install ...
3
votes
1answer
525 views

Emerge on Gentoo fails with “Multiple package instances within a single package slot have been pulled … in”. How can I resolve this?

I'm trying to install Google Chrome on my recent Gentoo box. But emerge is throwing some errors that are way over my head. I genuinely don't know what the problem even is. !!! Multiple package ...
1
vote
1answer
504 views

PECL memcached installation gets error

I installed Zend Server 6 (debian). Also installed several packages: apt-get install gcc apt-get install g++ apt-get install libncurses5-dev apt-get install zlib1g apt-get install zlib1g-dev ...
0
votes
2answers
47 views

How to download & install “heidisql” on linux?

First time I am starting working on "heidisql". I want to download & install "heidisql" on Linux Mint. May anybody please provide me the link to download "heidisql" for Linux version & how to ...
0
votes
1answer
27 views

Install of pycrypto [Errno 28] No space left on device

I am installing this tool to Debian GNU/Linux 7.5 x64 (wheezy) and when I run install_mnemosyne.sh I get this error when the pycrypto installation is running: Downloading/unpacking pycrypto (from ...
0
votes
0answers
112 views

cuda - gzip: stdin: invalid compressed data--format violated

I downloaded cuda toolkit from here! I'm running on 32-bit Linux(Mint 17). I had to download .run file(the downloaded file name is ...
2
votes
1answer
459 views

Network bandwidth measurement on Solaris

I want to install pathtest or a program like it in a Sparc server running solaris 10. The purpose is to make a speedtest server to my remote sites. It is mentioned in pathtest FAQ that it only ...
2
votes
2answers
262 views

Missing dependency during rpm install

When I install CodeAnalsyt, i get a failed dependency on libbfd-2.20.51 on Centos 6.3. Binutils is installed on my system and the failed dependency does exists at ...
4
votes
3answers
9k views

Apache installation configuration can't find PCRE? ( pcre-config for libpcre not found )

These are the requirements and instructions on how to install Apache on Linux. http://httpd.apache.org/docs/current/install.html So I've installed everything (c++ compiler, apr and apr-util) to be ...
0
votes
1answer
68 views

Can't install “libdvdcss” with yum anymore after update on “Fedora 20 Heisenburg”

I couldn't update my system today, because of dependency problems with libdvdcss, I removed libdvdcss and it's dependency libdvdcss2. Update was successfull after that but now I can't install ...
0
votes
0answers
20 views

Install vlc 2.1.X on Linux Mint

I am trying to install new version of vlc on Linux Mint 16. I have tried tutorials on how to do it and no success. When I am trying to install it with apt-get install vlc I get the same version 2.0.8. ...
4
votes
1answer
123 views

Installing software the first time a system boots after CentOS installation

I have a custom text based CentOS 6.4 installation that installs the OS, then after the first boot I have a custom rc.local file that installs custom applications and prepares the system for our ...
0
votes
0answers
12 views

facing issue while installing oracle Database 11g on rhel5 And SOA

While installing required rpms for both SOA and Oracle the below rpms are conflicting with each other glibc-devel-2.5-49.x86_64.rpm and glibc-devel-2.5-24.i386.rpm How can I fix it? one package gets ...
-1
votes
0answers
29 views

How to import numpy

I am trying to find density of states with dftb+ in a Linux system. I have a Linux system with Python-2.7.5 and Numpy-1.8.1. I am using the command as written below: gagan@gagan-desktop:~/tests$ ...
1
vote
2answers
839 views

How to install multiple glibc on fedora

I have Fedora 4 installed on my computer and it has glibc version 2.5.3, but I want to install a software that needs a glibc 2.7+. On the other hand, I have some programs that need this 2.5.3 version. ...
9
votes
2answers
981 views

Too much installing and uninstalling? [closed]

Is this a problem on Linux like it is one Windows? Installing and uninstalling things that end up leaving behind little bits and pieces that accumulate and have a negative effect? If so, what can I ...
1
vote
1answer
114 views

Problems installing mysql on debian

I have a : user@Node:~$ uname -a Linux Node 2.6.32-042stab092.1 #1 SMP Tue Jun 24 09:10:28 MSK 2014 x86_64 GNU/Linux With a : user@Node:~$ cat /etc/debian_version 7.6 and I am having problems ...
3
votes
1answer
99 views

How to specify a higher ruby version for installing a gem?

I install a ruby package. $ sudo gem install pdfbeads ERROR: Error installing pdfbeads: nokogiri requires Ruby version >= 1.9.2. says that it needs ruby version greater than 1.9.1. My ...
0
votes
2answers
618 views

puppet certificate catching error

After installing puppet master and client, when I request for catalog, I am getting the following error: [root@INFINI-ONE puppet]# puppet agent -t warning: peer certificate won't be verified in this ...
0
votes
0answers
105 views

Adding ppa's on Elementary OS freya doesn't work

I wanted to install FinalTerm on my elementaryos freya installation, so I added the ppa with sudo add-apt-repository ppa:finalterm/daily. However, when I tried running sudo apt-get install finalterm ...
1
vote
1answer
504 views

Can't install python because of zypper conflict

I have a virtual machine I just set up. I'm running a completely fresh install of OpenSUSE (with online updates from yast). At the terminal I tried to run python: $ python bash: python: command not ...
0
votes
2answers
872 views

Installing Tor on Backtrack 5R3

I've been trying to install Tor on my Backtrack 5 R3 laptop, and I believe it should be installed, however, when Vidalia starts it says it's unable to start Tor and asks me to check the location and ...
3
votes
2answers
34 views

Should I install npm in Kubuntu?

I am using Kubuntu. I am looking into installing a plugin to help in javascript. This seems to be good jshint but it mention npm install What is this? My understanding is that in Kubuntu I should only ...
5
votes
2answers
8k views

Packages still not found even after apt-get update

I am working on a Linux Mint 16 computer and since recently, every time I want to install something via apt-get install, the log message says that the packages couldn't be authenticated. I go ahead ...
1
vote
2answers
20 views

Compile source with later libraries on one server and use the binary on an older server

I may have a noob question regarding the compiling software from source. I need the latest libpcre3-dev library to compile a software from source, however, the current distribution of the OS (Ubuntu) ...
0
votes
1answer
400 views

linux + how to install glibc.i686

I try the following, but I get No package glibc.i686 available. What do I need to do in order to install the glibc.i686? Or maybe there is another way to solve this problem? yum install glibc.i686 ...
1
vote
1answer
163 views

How can I install Adobe Reader in Fedora 20?

I'm not able to find an appropriate RPM to install adobe reader. Does anybody have a good way for installing it? The system is 64-bit.
1
vote
1answer
39 views

installing libsocket-perl, apt-get searches for wrong filename extension, gets 404

I've been having trouble installing a package for a number of days now and can't find the solution anywhere, though I have been able to figure out more exactly what's going wrong. It appears that ...
2
votes
1answer
43 views

Installing PHP 5.3.3-24 on CentOS 6.5 (Final)

I require a slightly older version of PHP for my server because I need to be able to exploit a CVE (CVE-2006-7243) that was patched in the newer versions. NOTE: This is a legitimate use case where ...
2
votes
2answers
2k views

Install mono and Monodevelop on a new Redhat 6.5 Workstation

Does anyone know how to install Mono and MonoDevelop on a Redhat 6.5 Workstation. I've tried a number of different things but nothing has worked. I tried using git and building with make from the mono ...
0
votes
1answer
414 views

Debian install fails on USB-HDD

After my internal HDD broke in my laptop, I've tried to install Debian 6.0.6 on my external HDD. Please note that everything runs great when installing Ubuntu, but for some reason while the Grub stage ...
1
vote
1answer
422 views

Installing SCO OpenServer 5.0.7 Maintenance Pack

I have had so many issues on how to download, extract and install this software on SCO. And I'm sure there are loads of people having or had the same issue as I am having. So the question is, how do ...
10
votes
3answers
11k views

Installing a .deb package in home directory

Is it possible to install a .deb package completely under my home directory at debian?
0
votes
2answers
32 views

Where to install mininet [duplicate]

I read some posts and parts of FHS to understand which directory I should install packages in. As far as I could understand /opt is for independent packages and /usr/local is for packages that are not ...