Installing software on a running system, either as binaries or from source

learn more… | top users | synonyms

1
vote
2answers
144 views

Install rcp on RHEL

I have a Linux Red Hat machine version 6.4 (64-bit). I notice that the rcp command does not exist on my machine (no rcp binary). I also searched in Google in order to find an rcp binary that will fit ...
0
votes
0answers
44 views

Install application on barebone linux board without internet

I'm kind of new to using linux for hardware development. I made a C program which uses ExifTool, and it works fine on the desktop. The ExifTool have to be installed and runs on Perl. I can cross ...
2
votes
1answer
37 views

Compilation error on Ubuntu

I'm trying to install the driver of the probe IPEH-00202242179, I downloaded an installation file with the following commands: $ cd peak-linux-driver-7.9 $ make clean $ make $ su -c "make install" ...
-3
votes
4answers
136 views

How to install a downloaded deb file [closed]

I am new to Ubuntu and I am trying to install Compiz-Config-Manager, but it will not let me. This computer is not connected to the Internet, so I downloaded the .deb file onto a USB and transferred it ...
1
vote
1answer
26 views

Changing the default installation directory?

Is there a way to change the directory where applications are installed? I mean instead of /usr/bin can I change the settings to install them at /usr/local/bin or something like that, as long as they ...
2
votes
2answers
187 views

Installing python gives dpkg error

Installing python gives a dpkg error. I have done these commands, output below $ sudo apt-get install python3.4 $ sudo dpkg -C $ sudo apt-get check $ apt-cache policy libglib2.0-dev $ sudo ...
4
votes
1answer
103 views

Is building Perl an inside joke or is it supposed to require this many `make` invocations?

So I am building Perl version 5.18.2 from source on an ARMv7 processor right now, a Krait on the Snapdragon S4, and I am not too sure how much support there is for such an architecture. By the way, I ...
1
vote
1answer
140 views

Trouble installing lxml with custom install location for libxml2/libxslt

I am attempting to install a python module called lxml to my account on a supercomputer running RHEL. I do NOT have root access or super user status. lxml requires the dev/devel versions of libxml2 ...
3
votes
2answers
69 views

How To Convert .run Installer to .deb Installer?

I'm running Ubuntu 14.04. I have many 3rd party system libraries which I use for projects, but managing library installation is difficult. Some libraries are .deb files, some are built from source ...
-1
votes
1answer
123 views

How to install Touchégg on Fedora 20 [closed]

How do I install Touchégg on Fedora 20? https://code.google.com/p/touchegg/wiki/CompileSourceCode seems to be written for Ubuntu (Debian) systems, which makes me confused; 1 - Download and unzip ...
2
votes
1answer
52 views

Replacement of using terminal

Is there a way I can use Putty and connect it to my machine in replacement of terminal on my laptop? I am currently using ubuntu but I like some of the features that putty has over using the terminal. ...
0
votes
0answers
54 views

Why Inotify is unable to add watch

I have been trying to install teamviewer on RHEL 6 machine. The installation went fine. When I try to run teamviewer, it terminates immediately after showing the GUI. I went to ...
0
votes
0answers
40 views

Installing ZeroMQ for PHP on Hostmonster

I'm working on the shared hosted solution from Hostmonster. I'm trying to get ZeroMQ installed so that it will work with Ratchet. I have configured and build ZeroMQ 4.0.4 locally, as well as libzmq. ...
3
votes
3answers
61 views

How to manage installed from source programs?

I have servers (with Debian or Centos) and I would like to install programs from sources, because I can always have up to date software. If I want to install some program from source I usually do next ...
0
votes
1answer
68 views

Can I install libXcomposite.so without the root permission?

I got this error when I execute dropbox on CentOS. ImportError: libXcomposite.so.1: cannot open shared object file: No such file or directory I don't have a root account. Output of uname -a: ...
1
vote
0answers
66 views

php5-curl installation aborts due to ucf failing on /etc/php5/mods-available/curl.ini

I've screwed my raspbian (debian) installation. To fix this I'm going through reinstalling every single packacke. This is tiresome (or rather: slow) but works in general. Where I'm absolutely stuck ...
1
vote
1answer
114 views

'sh: 0: Can't open HoNClient-3.4.3.sh' when I try to run the HoNClient

I've been trying to install HoN on my laptop. It's running 32-bit Linux Mint 15. The problem I've run into is this: When I try to run the client in the terminal, using the command: sudo sh ...
1
vote
1answer
57 views

Switch Maven version after installing from jpackage?

I've installed maven3 on CentOS from the JPackage repository. Problem is my installs also seem to have pulled in maven2 which is the default. Is there any way to switch /usr/bin/mvn to be maven3? ...
1
vote
1answer
66 views

Installing courier-mta causes sendmail to be installed instead

My Debian workstation will not install courier-mta. The command aptitude install courier-mta appears to complete without error, but actually installs sendmail instead. What I did I'll start without ...
1
vote
0answers
465 views

How to install ap-hotspot

I can't seem to install ap-hotspot on ubuntu 12.04. I read somewhere that I should run the following commands: $ sudo su - # add-apt-repository ppa:nilarimogard/webupd8 # aptitude update # aptitude ...
1
vote
2answers
26 views

Installing CVS on Scientific Linux

I'm interested in installing CVS on Scientific Linux. I'm new to Linux and I need to input the command: "cvs co X" My terminal states that what I have typed is an "invalid command," so I'm assuming ...
0
votes
1answer
32 views

Can I install LAMP over existing Apache installation?

I'm setting up my first VPS, and I installed and configured Apache before I realized that there was the LAMP package to do that for me. Can I run sudo apt-get install lamp-server^ or do I have to ...
1
vote
1answer
39 views

tightvnc configuration - software version check

I have a raspberry pi and just managed to setup TightVNC running fine, but it looks like I can't use file transfer on the client. The viewer is 2.7 but I don't know what is my tightvncserver's version ...
1
vote
2answers
270 views

Cannot install libevent on CentOS 6.5

I'm on CentOS 6.5. Specifically, I'm running this AMI: Adobe Media Server 5 Extended. I followed these steps: $ sudo yum groupinstall "Development Tools" $ sudo yum install glib2-devel fuse-devel ...
0
votes
1answer
26 views

Proper location to install services

I originally posted this question over on AskUbuntu but it didn't get any traction so I'll ask here. In ubuntu or linux in general is there a "correct" location to install services that you download ...
1
vote
1answer
51 views

Could not allocate requested partitions while instaling Scientific Linux

I am installing Scientific Linux, and I must choose a drive to install it. I have a deleted partition with the size of 150 GB. When I select the deleted partition and try to create a partition ...
3
votes
1answer
145 views

How do I maintain a separate (newer) glibc / gcc / … stack as non-root on Linux

Our computation cluster runs a very old version of CentOS, with an old Kernel (2.6.18) and, of course, old libs and binaries. Because updating the whole thing requires a lot of work on all the nodes, ...
0
votes
0answers
25 views

Error installing protocol buffer on Solaris 8

Tried to run make for protobuf 2.5.0 on Solaris 8 which I download from this source. First, there were issues regarding a missing stdint.h which has been solved here. But it still fails to run the ...
0
votes
0answers
23 views

“error while loading shared libraries: libopenal.so.1” while installing Drox Operative [duplicate]

I'm trying to install Drox Operative on a laptop I just converted to running Ubuntu, and I'm getting this error whenever I try to run the game: sudo ./DroxOperative./DroxOperative: error while ...
0
votes
2answers
661 views

How to install with yum all python packages except broken?

I want to install all python packages on my Fedora 20 system, and there are broken dependencies. How can I install all except the broken or with errors? ]$ sudo yum install *python* ..... --> ...
0
votes
0answers
70 views

Kali tool installation?

I have installed the newest kali linux on a virtual box. But I can not find the preinstalled tools such as the exploitation tools. Should I be downloading them after the installation? Or is it ...
1
vote
1answer
56 views

cannot make protobuf on Solaris 8

I just downloaded protocol buffer (protobuf) 2.5.0 from here. Then I tried to install it on Solaris 8 (SunOS ms-sparc8 5.8). When I try to run make, I got this error. In file included from ...
0
votes
0answers
54 views

Is it possible to install Unity dock on something like Elementary OS?

I was trying out some different distros to choose from, and I ended up setting up Elementary OS. But I was hoping it was possible to install Unity to get the awesome dock, without reinstalling the ...
1
vote
4answers
86 views

What code should I use to download and install my script into a user-writable directory in the user's PATH (without requiring sudo)?

Edit: places where I said $HOME/.bin I should have written $HOME/bin or any equivalent is fine. I.E, any user-writable directory that is in the user's PATH. So I have a bash script which I am ...
1
vote
2answers
84 views

What is the correct way to upgrade 7zip on Solaris 10?

I currently have an old old version of 7zip installed (4.55 beta) on Solaris 10. It is located in /usr/bin/7z. Found using which 7z I have downloaded a new version 9.20.1. The README says to edit the ...
0
votes
1answer
65 views

Installing dependencies as a non root user [duplicate]

Can anyone please tell what are the steps to installing libxml2 on a server without root privileges? In a manner so it can be seen by other packages? I have installed it but do not know what is the ...
1
vote
1answer
2k views

How to fix xclock command not found error on Oracle Linxu 6.4?

I want to do GUI based installation but xclock command is not found. I have checked, I don't have xclock at all by finding it. # xclock -bash: xclock: command not found If I search x11 I found ...
0
votes
0answers
23 views

Installing SASM Integrated Development Invironment for assemby, dependency problems

How do I resolve these dependency issues? I want to install a IDE for assembly in my Fedora 20, but it's not working. Here is the package I'm trying to install: package site Here is the output from ...
1
vote
1answer
64 views

Installing systemtap 2.3 on ubuntu precise

If I install systemtap using apt-get on ubuntu precise, I get systemtap 1.6. Building it from source is proving to be complicated as it requires kernel headers. Is there an easy way to install ...
3
votes
3answers
58 views

How is yum atomicity ensured?

The installers do change a lot of system files. System may become unbootable if something fails during the software updates. Yet, it is almost impossible to ensure atomicity of even simple single file ...
0
votes
1answer
90 views

Icecat install fails with `GLIBC_2.14' and `GLIBC_2.17' not found

I am using gNewSense, but a lot of stuff should be working the same as in Debian. I followed the instructions: http://zachwick.com/posts/how_to_install_gnu_icecat_on_debian_wheezy.html The first ...
0
votes
1answer
99 views

Install a different version of Maven from the one provided by Ubuntu

I would like to install a package on Ubuntu 10.04.4 but would like to not use the one available in the one repository that I get when I do: apt-cache policy ${package} I would actually like to ...
1
vote
2answers
1k views

How to Install Oracle Java7 in Ubuntu13.04

I am trying to install Java 7 in Ubuntu 13.04 using this tutorial. Preparing your system First you need to remove openjdk for this run the following command from your terminal sudo apt-get ...
0
votes
0answers
75 views

Installing iPython3 Fedora 20

It was very easy to install ipython and upgrade it to the newest version (2.0) using pip. However, I want to set up ipython3, which uses Python 3, and found it more difficult. I finally installed it ...
1
vote
2answers
380 views

How to install libltdl.so.3

I have Fedora 20, and am trying to install scanner software, 32-bit, for my Epson DX5000 printer. I get the messages: [root@localhost:/home/Harry]$ rpm -Uvh iscan-2.29.3-1.usb0.1.ltdl3.i386.rpm ...
1
vote
1answer
1k views

minimal X.org xserver installation on Debian Wheezy

I installed Debian Wheezy with no desktop environment as I would like to use lightweight dwm window manager instead. However, as a first step, I need to install xserver. I would like to install ...
0
votes
2answers
62 views

installing own Git Server, push code after granted permission

I'm trying to install a Git Server in a RedHat 6.5 box I'm folowing this tutorials : 1,2,3, and to be honest the more I read the more things get obscure. If I'm to create a git user wich will be ...
0
votes
2answers
57 views

Installing Giggle 0.7 no makefile found and installation instructions are to 'make'

I've been trying to follow the instructions for installing giggle-0.7. From the INSTALL file: The simplest way to compile this package is: cd' to the directory containing the package's ...
0
votes
1answer
135 views

How to force `dpkg` to install dependencies [closed]

I would like to install .deb file via dpkg in Arch Linux. This .deb file needs many dependencies. I don't want to install dependencies by hand. How do I force dpkg to install dependencies?
0
votes
1answer
1k views

yum install PHP Error Summary

so I'm following this tutorial to install php5 in a red hat 6.5 box and I have only type one command and is this one below, I just wantend to install the php-gd module.(testing..) when I try this: ...