Installing software on a running system, either as binaries or from source. This is usually done using your system's package manager.

learn more… | top users | synonyms

6
votes
1answer
182 views

How to add a Thunderbird addon globally?

I have downloaded a Thunderbird extension as a.xpi file. I know, I can install it in Thunderbird by going to Tools -> Addons -> Install Add-on from file However, I am using several ...
6
votes
1answer
2k views

Linux Mint won't run virtualbox

I installed Linux Mint 11 Katya with Virtualbox 4.1 once and all was running fine. Then I reinstalled system, and I have a lot of software installed too (including Wine). But when I went through the ...
4
votes
2answers
2k views

What does /usr/bin/install do besides copying?

Does make install with a Makefile most of the time call /usr/bin/install? What necessary work does /usr/bin/install do besides copying the just compiled files to /usr/bin/local? The man page says ...
3
votes
1answer
4k views

Install Drivers Offline Arch Linux

I have been attempting to install Arch Linux on my Macbook Pro but the wireless and ethernet drivers don't work. Because of this, I cannot access the internet on it. So whilst searching for a solution ...
3
votes
1answer
9k views

Installing vpnc on CentOS

I'm currently attempting to establish a vpn connection, but I am unable to install a vpn client. I assumed installation would be as simple as sudo yum install vpnc, but CentOS is unable to find the ...
3
votes
1answer
12k views

Installing GCC 4.5 on Fedora 16

The default GCC package available in the Fedora 16 repositories is gcc-4.6. I need to install gcc-4.5 on my system. I downloaded the packages from the kijo repository, but when I try to install them ...
3
votes
2answers
295 views

Where should I copy-paste-install software to?

I'm installing IntelliJ, and the readme tells me to choose an installation folder. Where is a good, standard place to put installed programs?
1
vote
1answer
1k views

httpd-devel requires outdated version of glibc-common on CentOS 6.3

httpd-devel requires an outdated version of glibc-common on CentOS 6.3 x86_64 and Apache/2.2.15. It wants 2.12-1.80.el6 and I have 2.12-1.80.el6_3.3.x86_64 installed (via CentOS @update repo) Here is ...
1
vote
1answer
10k views

switching from user to root and revers (FreeBSD)

I want to make some modification with root and then with my user, in fact I want to install sudo and he give me the error in the first step: cd /usr/ports/security/sudo make install clean ...
0
votes
1answer
106 views

How to add new keyboard layouts in Manjaro Fluxbox?

I want to try Manjaro Fluxbox, and I would say it's my favorite Manjaro to date, except for some quirks like the one that I don't know --- not only how to get a keyboard layout indicator / switcher, ...
9
votes
4answers
10k views

How to truely install a tar.gz file on Linux - how to manage manually-installed (or standalone) applications?

I see all these links explaining packages and .debs... I know that... and there are many kludges to get tar.gz files working (eg: update-alternatives for Java or manually dropping the file in ...
8
votes
1answer
7k views

Install g++ when having gcc (C only) — RH6

I have a RHEL 6 machine, which came with gcc but without g++. The gcc version is 4.4.4 20100726 (this is what I got from gcc --version). How can I get g++ working? Currently, the shell just returns ...
7
votes
1answer
6k views

Local installation of .rpms using YUM

I'm asking this question cautiously because I don't want to get this wrong. I have a program_name.rpm file saved locally on my server (CentOS 6.5). I have installed it previously just by navigating ...
4
votes
2answers
2k views

Installing OpenVPN to replace Cisco VPN because Cisco will not work with the kernel I am on or downgrade instead?

I had difficulties installing Cisco5.0 VPN on my Ubuntu 10.04 LTS. I asked for assistance in this question: link to previous question. The answer is that this Cisco program will run on only older ...
3
votes
3answers
234 views

Install using synaptic ignoring dependencies

I was trying to install texmaker a latex editor in my debian system from synaptic. It shows in the dependency list texlive-base, texlive-common. etc as dependencies. But I have already installed ...
3
votes
1answer
9k views

Invalid configuration `x86_64': machine `x86_64' not recognized

Compiling this: http://linux.softpedia.com/progDownload/Indexed-PDF-Creator-Download-1071.html anisha@linux-dopx:~/tarBalls/ipdf-1.0.0> ./configure --build=x86_64 checking for a BSD-compatible ...
3
votes
1answer
138 views

Link a dependency in Synaptic to the one already installed from source

I want to install SVN version of Quantum GIS and already I have a SVN version of GRASS GIS. As instructed in QGIS Wiki here, I added the qgis repository to my sources.list file. Now I am able to see ...
2
votes
2answers
728 views

Unable to install dahdi - /usr/bin/install: cannot stat ‘’: No such file or directory

I am trying to install dahdi in my centos 7 system using this link but having some errors [root@localhost ~]# cd /usr/src/dahdi-linux-complete* [root@localhost dahdi-linux-complete-2.11.0+2.11.0]# ...
2
votes
2answers
116 views

Remount Arch Linux installation CD to download some additional packages

According to this post I can: Start the livedisk again, remount your drives archroot into your root partition and then install the packages you need and everything should work. However, I ...
2
votes
1answer
51 views

how can I run old programs from a MIPS?

I have an old PC with a program called atomTV, for viewing, and producing movies from molecular trajectory files. I only have a binary, and the platform it ran on was 64-bit MIPS architecture, where I ...
2
votes
2answers
219 views

Use alternatives or adding to PATH?

I'm a bit confused about the proper way to make a script globally available from the terminal, like a command. There are two ways, using the alternatives utility, basically making a symlink to ...
2
votes
2answers
140 views

Tools to manage a custom installation prefix for software compiled from source?

What package managers exist which can handle compiling and installation development version (git head) into a configurable installation prefix? I.e. by typing a command, I want to be able to: ...
2
votes
1answer
8k views

/lib/modules/2.6.37.6/build missing in linux puppy? what should I do?

I am new to linux as of yesterday. I'm using linux puppy to try to get the most out of a 10 year old, slow laptop. I installed it fine, no problems there, but as soon as I try to use my usb dongle's ...
2
votes
2answers
2k views

Updates/applications/packages for Ubuntu 10.10 with no internet connection

I recently installed Ubuntu Desktop 10.10 (i.e 2h ago :D) from ISO CD. All went smoothly but now I have an issue. I don't have a network connection. I do not mean that there is a configuration ...
1
vote
1answer
185 views

how do I manage dependencies for this manually installed rpm file?

How do I manage the dependencies while manually downloading and installing these rpm files? Googling the names of the rpm files results in differently-named rpm files. I cannot use yum install ...
1
vote
1answer
1k views

Installing R-base in Linux Mint 17.1 Cinnamon

I'm trying to install the package r-base using the Linux Mint community software view. By clicking on the "install" button one asks me for the "install of additional software?". By clicking on ...
1
vote
1answer
203 views

cannot make protobuf on Solaris 8

I just downloaded protocol buffer (protobuf) 2.5.0 from here. Then I tried to install it on Solaris 8 (SunOS ms-sparc8 5.8). When I try to run make, I got this error. In file included from ...
1
vote
1answer
82 views

What are possible issues with installing a package from the developer instead of the distro-repositories

It might sound like a trivial question to some but even though I have been using Linux for quite a few years I haven't really figured out this question. Little background info; I recently upgraded my ...
1
vote
2answers
1k views

Kernel module for Cisco VPN client doesn't compile under ubuntu 10.04 LTS?

I am trying to install a Cisco VPN client under Ubuntu 10.04 LTS. In the extracted folder I type: alex@alex-laptop:~/Downloads/cisco4.8/vpnclient$ sudo ./vpn_install and there is output of activity ...
1
vote
3answers
2k views

How to install kernel on debian with no internet connection

I'm trying to install a newer kernel version on my Debian (squeeze) machine as I need it to get my wireless card working. I have Debian on one partition of my hard drive, Fedora on the other. I'm ...
1
vote
1answer
184 views

How can I install hulahop

I cloned hulahop via git and I'd like to use it and try to run this example. I have a problem to find out how to build and install it. I also tried to install it with apt-get but I don't have this ...
0
votes
1answer
45 views

Remove the old installed version of an application when installing a new version from source?

I am installing a newer version of Wine by compiling from source, and then will use checkinstall to create a deb package, and then install it from the deb file by dpkg. At the same time I would like ...
0
votes
1answer
898 views

How to install Binwalk on Debian without installing the graphs libraries?

What is the proper way to install the Binwalk tool on Debian 7.0 without the added graphing capabilities (and it dependencies)? I've read that I can skip the make deps command, but this deps.sh script ...
0
votes
1answer
969 views

Installing yum on CentOS 5

I have a CentOS vm that I'm currently working on. I tried to update yum and it broke, so I removed it. So I need to re-install it on my vm, can anybody tell me how to install yum on CentOS5?