Installing software on a running system, either as binaries or from source. This is usually done using your system's package manager.

learn more… | top users | synonyms

0
votes
1answer
171 views

How do I get started with linux? [closed]

I am a programmer but have only used Windows as the development environment till now. I work on Java. I wanted to start developing on Linux and would like to know where to start. More specifically: ...
1
vote
1answer
95 views

Back up particular package and its dependencies

My question is: can we take a backup of a particular package and its dependencies? For example, if we install VLC it requires dependencies like kde filesystem,libcaca.so.0 etc.. can we take a backup ...
3
votes
1answer
775 views

libstdc++.so.3 => not found on CloudLinux, no SuperUser permissions, seemingly in chroot.

I am trying to install the Linux x64 BOINC command-line interface client on a CloudLinux machine with x86_64 Architecture. When I try to run the executable I get an error: ./boinc: error while ...
3
votes
2answers
1k views

Installation on debian 5 32-bit without being a root

I am new to Linux and I am trying to install Skype and Google Chrome on my desktop. It runs Debian 5 32-bit. I downloaded the packages from the web but I have no idea how to install them. I have ...
1
vote
1answer
560 views

Upgrade swig 2.0 or newer

I'm using Fedora 13 and I have swig 1.3 installed: $ swig -version SWIG Version 1.3.40 I need to upgrade it to swig 2.0. How is this done?.
1
vote
2answers
598 views

How to recover a utility. (Accidentally Deleted /usr/bin/php file)

New Linux user. I accidentally overwrote my /usr/bin/php file. The php command no longer works. What's the best way to recover that file? Using bash and Linux Mint distro.
5
votes
5answers
2k views

Why is it recommended to create a group and user for some applications?

Most of the time, when installing a program from source it is recommended to create a new user and a new group and give /usr/local/<myapp> the recently created user and group ownership. Why is ...
2
votes
2answers
610 views

How to install aMSN on Scientific Linux?

I can't find aMSN in the Scientific Linux 6 repositories.. How can I install it?
2
votes
5answers
512 views

Bash script that can test for a particular lib

I'm writing a bash script that needs to test if certain libs are installed on a VPS, and if they're not, the script will install them. My problem is being able to have the script determine if they ...
2
votes
1answer
2k views

How to verify if tmux is properly installed on Mac OSX

I've just tried installing tmux from source (via installing libevent first). The installation seemed fine, without throwing any obvious error. But when I typed tmux in iTerm2, it returned "command not ...
0
votes
1answer
312 views

Clang/LLVM Install Within Slackware?

I would like to install the Clang/LLVM compiler suite within Slackware since I use it as my default C conpiler for my C programming assignments. I am currently building it within a build directory ...
1
vote
1answer
996 views

Problem in installing Google voice and video plugin for Gmail

I just downloaded Google talk plugin for voice and video (for audio/video chat in gmail). I am using RHEL6. I downloaded the plugin (64 bit, rpm format). While installing it an error comes which ...
2
votes
2answers
861 views

how to apply this patch

There is a patch fix for perl module net::ssh2 it fixes a seg fault error that happens on some machines. It's located here: https://rt.cpan.org/Public/Bug/Display.html?id=36614 I downloaded the ...
3
votes
1answer
113 views

Access PgSQL executables from anywhere

I've installed PgSQL 9.1.2 from PostgreSQL repositories and all it's fine except that I can't execute command from every path in my OS. For example suppose that I want to run the command pg_dump: for ...
1
vote
1answer
2k views

How to install Empathy on CentOS 6.0?

I'm a very new CentOS user. I came from Ubuntu. I need to install Empathy on my CentOS PC. Can anybody explain how to do that?
1
vote
1answer
353 views

How to install caffeine on fedora16?

https://launchpad.net/caffeine I'm trying to install caffeine on Fedora but I am stuck on some problem, that is I can't run: ./bin/caffeine
6
votes
2answers
244 views

Where should I place a downloaded tarball?

I have downloaded the ChromePlus tarball and extracted it to my home directory. The extracted folder contains an executable that I can double-click to launch ChromePlus. So I assume I do not need to ...
4
votes
2answers
1k views

Installing OpenVPN to replace Cisco VPN because Cisco will not work with the kernel I am on or downgrade instead?

I had difficulties installing Cisco5.0 VPN on my Ubuntu 10.04 LTS. I asked for assistance in this question: link to previous question. The answer is that this Cisco program will run on only older ...
1
vote
2answers
804 views

Kernel module for Cisco VPN client doesn't compile under ubuntu 10.04 LTS?

I am trying to install a Cisco VPN client under Ubuntu 10.04 LTS. In the extracted folder I type: alex@alex-laptop:~/Downloads/cisco4.8/vpnclient$ sudo ./vpn_install and there is output of activity ...
1
vote
3answers
1k views

How to install kernel on debian with no internet connection

I'm trying to install a newer kernel version on my Debian (squeeze) machine as I need it to get my wireless card working. I have Debian on one partition of my hard drive, Fedora on the other. I'm ...
2
votes
1answer
372 views

I bought a game from Ubuntu Software Centre, How do I download it for Linux Mint?

I bought the game TRAUMA from the ubuntu software centre, using my login user/password and paid with my debit card, I can download and play the purchased game in ubuntu fine. But I recently switched ...
1
vote
1answer
2k views

How do I install the nagios NRPE plugin on CentOS 5 using yum?

How do I install the nagios NRPE plugin on CentOS 5 using yum? I've tried yum install nagios-plugins but it's only downloading a fraction of a megabyte. Then if I do a search for one of the commands ...
2
votes
2answers
2k views

How to fix this error? make: *** [obj/local/armeabi/libgstaudioflinger.so] Error 1

I am trying to install this following framework from my Linux Fedora box to Android using there SDK/NDK. But after following all instruction its getting still failed to get build. Any idea how to fix ...
0
votes
1answer
172 views

Missing IPsec package in Solaris 10

I'm running Solaris 10 v5/08. Running svcs -a | grep ipsec returns nothing, so I have reason to believe IPsec isn't installed (or isn't showing up for some other reason). How can I make sure it is ...
3
votes
3answers
379 views

Install pdflatex via SSH on Amazon EC2 instance

I need to install pdflatex on my Linux powered machine (Amazon EC2 instance, didn't decided yet which distribution would be the best so also feel free to give a hint) because I want to connect ...
1
vote
2answers
2k views

How to install software in solaris?

How do I install NetBackUp software in solaris? I'm learning the software and I need to install and practice using it.
6
votes
6answers
20k views

Where is Netbeans installed on Ubuntu?

I installed Netbeans on my Ubuntu 11.10 machine. I used the combined method, so Netbeans and JDK are installed from a single file. However, now that it's installed I can't figure out how to start ...
7
votes
2answers
1k views

How to install exactly the same packages on another computer in openSUSE?

Another computer can be as well virtual machine. I cannot make disk clone because of hardware differences and settings. I have computer A, installed and running, I also have computer B. I will ...
0
votes
1answer
306 views

How to install non-outdated nvidia drivers using apt-get?

I tried using apt-get install nvidia-current after installation I got 280.13 version, which is not the latest version(290.10). so how can i force apt-get to download the latest driver? Edit: I'm ...
1
vote
2answers
1k views

apt-get : no installation candidate for libxul-dev

When I'm installing libxul-dev I end with this error message: $ sudo apt-get install libxul-dev Reading package lists... Done Building dependency tree Reading state information... Done Package ...
1
vote
1answer
169 views

How can I install hulahop

I cloned hulahop via git and I'd like to use it and try to run this example. I have a problem to find out how to build and install it. I also tried to install it with apt-get but I don't have this ...
3
votes
1answer
5k views

How do I upgrade to the newest Firefox via YaST in OpenSuSE 11.x? [closed]

I'm running OpenSuSE 11.2 and I would like to upgrade to the newest version of Firefox (v 8 I believe at the time of this question). I'm not interested in extracting a tarball, I would like to do it ...
1
vote
1answer
3k views

“Linux kernel source code directory” requested in Cisco VPN client install

I'm trying to install Cisco's vpn client, and it requests that I provide the directory containing linux kernel source code. Specifically, it reads: In order to build the VPN kernel module, you ...
2
votes
1answer
769 views

What is the fastest way to install GCC on Wind River 3.02?

I am fairly new to installing things on a bare-bones Linux system and really do not want to just blindly install rpm after rpm of dependencies I think I might need... I know that this version of ...
2
votes
1answer
344 views

Forcing 'yes' to new update license agreements?

Sometimes when a new version of a big piece of software is released (java, flash, etc), the developers will require that a license agreement be combed through and then ask you to type (yes/no) at the ...
7
votes
3answers
5k views

Why do some packages use 'make install' while other use 'sudo make install'

I recently installed LAME encoder on my server to convert wav to mp3 and that worked with './configure, make, make install; I then tried to install OGG encoder and that requires './configure, make, ...
3
votes
1answer
1k views

installing column unix utility on windows

I would like to be able to use the BSD unix utilities: column, join and paste in my Cygwin installation. It seems that they are not available, or I cannot find them. Is there a way to install them so ...
1
vote
1answer
421 views

What ghc package does cabal-install need?

I've just installed cabal to try and get http://dmwit.com/yeganesh/, but on running cabal-install it throws the error: cabal: ghc version >=6.4 is required but it could not be found. Apt-cache ...
4
votes
2answers
141 views

Where is a good place to put applications that come pre-compiled?

Certain applications like Blender and Eclipse come precompiled in a tarball. Usually I put the directories in my home folder and access them from the command line. Is there a better place to put them ...
8
votes
2answers
3k views

How to make apt-get accept new config files in an unattended install of debian from Repo

I am writing a script for a unattended install of a package that is in our repo, it is a software package with one of Debian's marked config files. Is there any option that I can pass to ...
0
votes
1answer
750 views

Installing yum on CentOS 5

I have a CentOS vm that I'm currently working on. I tried to update yum and it broke, so I removed it. So I need to re-install it on my vm, can anybody tell me how to install yum on CentOS5?
0
votes
1answer
137 views

Installing a unix application?

I am trying to install depot_tools here are the instructions. I downloaded the file from this: svn co http://src.chromium.org/svn/trunk/tools/depot_tools I wanted to install it in /usr/local so I ...
2
votes
0answers
174 views

How do I install dvd-slideshow on Centos 5?

How do I install dvd-slideshow on Centos 5? http://dvd-slideshow.sourceforge.net/wiki/Main_Page I tried but only found a gui to install on Ubuntu. I'm using Centos 5, command line.
2
votes
2answers
2k views

How to set the default gcc version for only one user

I share a server (Ubuntu 11.04) with other people and I am the only one who has to use gcc 4-4 for my code, the rest is using 4.5. I already installed gcc 4.4 but how do I make it the default for me, ...
6
votes
1answer
3k views

Fritz WLAN USB stick - Xlib/Xfree86 dev packages for installing Wine

I have installed Ubuntu 10.4 and want to install the driver for my Fritz WLAN USB stick according to http://wiki.ubuntuusers.de/fritz!wlan_usb_stick (German site... sorry). Now I am trying to install ...
3
votes
1answer
841 views

Warnings about read-only filesystems while installing a solaris package

I have a solaris machine that I am trying to install Perl 5.12 as well as gcc and make to get CPAN working. I downloaded the packages from sun freeware, and was able to install gcc. When I tried to ...
2
votes
1answer
535 views

How can I install Texas Instrument's dvsdk?

How can I install a file that doesn't even have a file extention? I followed the instructions, but I failed... Also apt doesn't do anything. Here is the link to the file and the installation process: ...
5
votes
1answer
2k views

Linux Mint won't run virtualbox

I installed Linux Mint 11 Katya with Virtualbox 4.1 once and all was running fine. Then I reinstalled system, and I have a lot of software installed too (including Wine). But when I went through the ...
1
vote
1answer
769 views

Slackware, installing Flash and Chrome

I'm having trouble installing flash and chrome. When I download the sources, there are no installers for the packages. All I get is a few folders and .so files. Is there anything out there which shows ...
1
vote
3answers
1k views

Install ffmpeg 0.7.1-5 from debian package

I downloaded this package for ffmpeg. When I try to install it with command sudo dpkg -i ffmpeg_0.7.1-5_i386.deb it writes this error message: Unpacking ffmpeg (from ffmpeg_0.7.1-5_i386.deb) ... ...