RPM is a package management system intended primarily for Linux distributions.

learn more… | top users | synonyms

2
votes
1answer
630 views

Can rpm handle an install of another OS into another Logical Volume?

I am trying to install fedora as a domU under a CentOS dom0 using the method outlined in The Book of Xen. I have asked another question regarding a consistent error message of cpio: Bad magic when I ...
2
votes
1answer
4k views

Getting “cpio: Bad magic” when trying to rpm install into a mounted Logical Volume

I need some help with this. I am trying to follow the Xen guide to provision a domU using package installation of the Fedora 15 release (the dom0 is CentOS 5.6). Ive run the rpm install command with ...
1
vote
1answer
868 views

Why did yum-builddep not provide the dependencies to install my rpm?

I am trying to rum my rpm package but getting this dependencies error. [root@localhost ~]# rpm -ivh /root/x86_64/asterisk-1.8.12.2-1.fc15.x86_64.rpm error: Failed dependencies: ...
93
votes
12answers
31k views

What are the pros/cons of deb vs. rpm?

For whatever reasons, I've always used RPM based distros (Fedora, Centos and currently openSUSE). I have often heard it stated that deb is better than rpm, but when asked why, have never been able to ...
12
votes
4answers
5k views

Is there is a PPA-service equivalent in the Fedora world?

For Ubuntu there is this convenient PPA service available where you can get your own package repository. You can put there source packages which are under an open source license, e.g. development ...
5
votes
2answers
3k views

Is it stable to use epel and rpmforge in the same time?

So after a fresh Scientific Linux 6.3 Desktop install, I: yum install rpmforge-release && yum update and yum install epel-release.noarch then: yum install wine gparted cups-pdf ...
2
votes
1answer
1k views

Unpacking kernel-source rpm off-system (OpenSuse)?

I'm using OpenSuse 11.2 from a LiveUSB USB flash/stick, which arguably has not much place on it. I need to get the Linux sources for this version of OpenSuse, as they are needed to build a driver for ...
1
vote
1answer
704 views

httpd-devel requires outdated version of glibc-common on CentOS 6.3

httpd-devel requires an outdated version of glibc-common on CentOS 6.3 x86_64 and Apache/2.2.15. It wants 2.12-1.80.el6 and I have 2.12-1.80.el6_3.3.x86_64 installed (via CentOS @update repo) Here is ...
0
votes
1answer
387 views

Upgrading Python 2.6. libpython2.6.so.1.0 missing

I am upgrading python on an offline 64bit RHEL 6.4 box and am having to do it via RPM's rather than yum. I am trying to upgrade python from 2.4.3 to 2.6 so I can build nodejs from source. I am ...
6
votes
1answer
433 views

Why does `man -k cron` say `vixie-cron (rpm)` for some results, and how do I read those pages?

I'm trying to find out some details regarding cron and /etc/cron.d/ on a RedHat system. Ironically, my answer is viewable within the vixie-cron-*.src.rpm for this package, but the the man pages for ...
4
votes
2answers
3k views

yum install in user home for non-admins

I am a non-admin user on a large computer system. I need some up to date packages that are not installed on the system. I want to use yum to install them. As a user without sudo, admin, or root ...
3
votes
1answer
856 views

CentOS 4.8 and glibc 2.5

How would I go about installing glibc 2.5 on CentOS 4.8? I know CentOS 4.8 has been EOL'd, which is all good and well. However, the environment that I am working in is using this version, and will ...
3
votes
1answer
142 views

unresolved dependencies of bz* files for rpm make from source

I am trying to do a build of rpm from source. I got through the ./configure and ran through a good chunk of make. Unfortunately I keeping getting stopped up on undefined references to bzerror, ...
3
votes
2answers
1k views

Using YUM or installing APT on CentOS

I am having trouble with a centOS machine I am using. I need some packages, including john the ripper, but yum cannot find the packages. When I type sudo yum install john, I get back the nothing to ...
2
votes
2answers
1k views

How to unpack, modify, rebuild and install a SRPM

I would like to modify a Fedora 15 package (gnome-shell-extensions-alternative-status-menu). It's a small modification (reverting this commit). Using yumdownloader I'm able to download a SRPM ...
1
vote
1answer
101 views

Linux Fedora 20: how do I deal with “ import read failed(2)”?

I have been struggling to get yum to work when trying to install emacs in my recent installation of Fedora 20, and posted the question, on this site. "How can I get yum and the internet browser to ...