RPM is a package management system intended primarily for Linux distributions.

learn more… | top users | synonyms

1
vote
4answers
8k views

“The GPG keys listed for the ”atomicrocketturtle.com“ repository are already installed but they are not correct for this package.”

When running this on CentOS 6: yum update I accept the transaction summary that it presents and am then immediately presented with this: Downloading Packages: warning: rpmts_HdrFromFdno: Header V3 ...
0
votes
1answer
478 views

CentOS: what impact does a kernel update have?

When running this on CentOS 6: yum update I get this: --> Finished Dependency Resolution Error: Package: 2:irqbalance-1.0.4-6.el6.x86_64 (base) Requires: kernel >= 2.6.32-279 ...
0
votes
1answer
83 views

libmpg123 bugging up yum

I had to manually install some dependencies in my fumbling attempts to get netflix working yesterday with pipelight, and ultimately failed. I uninstalled everything I installed during that process, ...
1
vote
1answer
316 views

Install NCDU on Scientific from EPEL

Introduction The commands specified in the answers to this question and this documentation have been applied to install NCDU on Scientific using EPEL without success. According to this documentation ...
2
votes
2answers
3k views

How do I determine which configuration options an rpm package is built with?

This is my first question and I'm still pretty new so please forgive me if I've missed or botched something, or if this is an obvious solution. I'm using CentOS 5.8 (yes I know it's ancient) and ...
3
votes
2answers
5k views

How to automatically accept epel gpg key

The very first time that I install a package from epel, I am prompted if I want to import a GPG key. Notice how there are 2 'Is this ok' prompts when installing redis? [root@us-devops-build02 ...
0
votes
1answer
1k views

Cannot install Snort 2.9.6.1 due to “Not a compatible architecture”

I have Centos 6.5 installed on a Dell Inspirion Intel chip. When I entered uname -a I got Linux family.room 2.6.32-431.el6.i686 #1 SMP Fri Nov 22 00:26:36 UTC 2013 i686 i686 i386 GNU/Linux I ...
0
votes
1answer
972 views

How do you create RPM from .spec file?

I'm attempting to create an RPM from a spec file that was provided here: http://sauron.jyu.fi/docs/manual/x191.html Having not used rpm much, I assume that I execute the command rpmbuild and point ...
3
votes
2answers
6k views

check if latest openssh patch provided by RHEL is installed

We have encountered a security threat in one of our RHEL servers which says the SSH server is configured to use Cipher Block Chaining. As far as I know, the RHEL systems provide security updates ...
2
votes
1answer
831 views

What do all the letters and numbers in a Red Hat RPM version number mean e.g. openssl-devel-0.9.8e-27.el5_10.1?

What do all the letters and numbers in the rpm name openssl-devel-0.9.8e-27.el5_10.1 mean? I recognize the openssl-devel-0.9.8e part because that's the same number applied by the developement team at ...
0
votes
1answer
316 views

Saxon rpm build fails due to “ant: command not found”

Hopefully this is a question I can ask this community. I'm currently working on building zookeeper-3.4.5-13 for a CentOS 5 environment. During this process I've been going down a long list of required ...
1
vote
1answer
1k views

How to install mysql-server 5.6 on RHEL 5.8 (when MySQL-server 5.0 is already installed)

I want to install mysql-server 5.6 on RHEL 5.8, but when trying rpm -i or rpm -Uvh it complains that I already have version 5.0 on there. I am happy to replace, upgrade or install another instance. ...
1
vote
1answer
231 views

Pre-compiled Finale substitute for Fedora 20?

I recently lost my dual-booted HDD (with both Linux and Windows). It did some weird stuff and started changing all files to read-only on every start-up. So, I bought a new HDD and put Fedora 20 on it. ...
1
vote
1answer
698 views

What causes a csh script to sometimes not source /etc/csh.cshrc?

I have a csh post-installation script that is executed from an rpm %post with its interpreter line set to #!/bin/csh (without the -f option). This should cause the file /etc/csh.cshrc to be read ...
9
votes
2answers
26k views

why can't I install packages with rpm? I get “transaction lock”

I'm having problems with yum and I am trying to re-install it. I've download yum.3.2.0-40-el6.centos.noarch.rpm. When I try: $ rpm -ivh yum.3.2.0-40-el6.centos.noarch.rpm I get: error: can't ...
2
votes
2answers
3k views

yum translation of rpm -Uvh

I'm trying to understand what yum version of rpm -Uvh is. I found this question about that command and yum, but it doesn't have what I'm looking for. Looking at --help, would this be the equivalent of ...
4
votes
2answers
198 views

How do you separate /bin and /sbin when making an RPM?

I'm trying to make a redis RPM using fpm When I run the following commands, all binaries are installed to /tmp/installdir/usr/local/bin cd /tmp/redis2-8 PREFIX=/tmp/installdir/usr/local/ make ...
2
votes
1answer
2k views

Public key problem when installing ovirt on aws

I started an instance on AWS with centos 6.4. I ran the following two commands: $ yum localinstall http://resources.ovirt.org/releases/ovirt-release.noarch.rpm $ yum -y install ovirt-engine I got ...
3
votes
2answers
316 views

Why is “dir-or-file-in-usr-local” an error rather than a warning?

I'm building some rpm packages and checking for standards and style conformance using rpmlint. The packages are specific to systems at my place of work and they won't get pushed upstream. Our ...
3
votes
4answers
946 views

Can I use grep matches to execute command?

I need to upgrade php from 5.3 to 5.4. I've installed it with rpm. I want clean install: delete all 5.3 packages, and install all necessary 5.4. Here is the command to see all installed packages: rpm ...
1
vote
1answer
286 views

How to decide what to mention in .spec file 'Requires: ' filed

I am new in building rpm package.For Creating RPM for my binary I have following dependancies: [tejas@target]$ ldd exe linux-vdso.so.1 => (0x00007fff85bff000) libQtWebKit.so.4 => ...
0
votes
0answers
176 views

Centralized package management for RPM based distro

We have about 6 servers under Linux CentOS. And I want to have possibility to view (best will be some web-interface, but console-only useful too) outdated packages, which can be updated and have all ...
3
votes
1answer
4k views

Where are RPM postinstall scripts located?

I have found a bug in an RPM that I have been provided. rpm -qp --scripts foo.rpm > /tmp/badscript cat /tmp/badscript postinstall scriptlet (using /bin/sh): ... if [ 'some bug' == true ].... I ...
1
vote
1answer
2k views

Linux Fedora 20: how do I deal with “ import read failed(2)”?

I have been struggling to get yum to work when trying to install emacs in my recent installation of Fedora 20, and posted the question, on this site. "How can I get yum and the internet browser to ...
0
votes
1answer
51 views

rpm query does not give complete provided capabilities (commands)

For example, I know /usr/sbin/agetty is provided by the util-linux package with the following command: $ rpm -q --whatprovides /usr/sbin/agetty util-linux-2.24.1-1.fc20.x86_64 Then I would like to ...
0
votes
1answer
682 views

Can I Install packages on live linux os?

I want to install some more software on sabayon live and they should be remained in USB for later use. Can I install packages on live Linux OS?
0
votes
1answer
495 views

unpack and patch source rpm (rpmbuild -bp) safely

I want to unpack source RPM and apply patches to the upstream source. What is almost OK for me is rpm -i mypkg-*.src.rpm cd ~/rpmbuild rpmbuild -bp SPECS/mypkg.spec # frolic in BUILD/mypkg My ...
0
votes
1answer
2k views

Always getting “not a symbolic link” message, while installing any package

When I am installing any package in my centos 6.0 system, by yum or rpm, I always getting /sbin/ldconfig: /usr/lib64/libreadXMLnew.so.1 is not a symbolic link message. There is never a problem in ...
1
vote
1answer
6k views

RPM: Installed (but unpackaged) file(s) found on Centos 6 with CUPS 1.7.1

Trying to install CUPS 1.7.1 on Centos 6.5 via RPM, I use: # rpmbuild -ta cups-1.7.1-source.tar.bz2 --without dbus --without libusb1 but stops with below error: Checking for unpackaged file(s): ...
1
vote
1answer
468 views

sbt running but can't see on port 9000 centos 6.5

After downloading the sbt.rpm (version 0.13.1) and installing with yum it appears to be running successfully but when I go to http://mysite.com:9000 it's not found. Here is some of the output after ...
0
votes
1answer
2k views

Issue with yum - error in importing one of the python modules

I am trying to install rpm package on CentOS 6 using yum install command, but getting folowing error There was a problem importing one of the Python modules required to run yum. The error leading to ...
0
votes
2answers
5k views

specify PREFIX location when running make

I need to install redis 2.8.x into a specific directory so I can later use fpm to create an rpm. From my research, it seems that this should be possible by using make PREFIX= mkdir /tmp/installdir ...
5
votes
3answers
19k views

Install RPM file on Arch Linux?

I want to install sqldeveloper from Oracle on Arch Linux. The only Linux download option is RPM. I am not interested in using arch repositories to install sqldeveloper. I can only use what the vendor ...
1
vote
1answer
3k views

Error: requested datatype primary not available

By the error I can't install any packages. And also I can't update to the latest version. I don't know what to do now. Any help much appreciated. Error: requested datatype primary not available ...
1
vote
1answer
4k views

Depsolving for php-pecl-zip

I'm having trouble getting rid of my depsolving errors, and I've been left to figure this one out on my own. It all started when I wanted to upgrade from PHP 5.2 to PHP 5.3 (heaven forbid), and I was ...
1
vote
3answers
320 views

Installing ack on cpanel

I need to install ack on an instance of whm/cpanel (I have root access as it is a VPS) but I have not found any information on how to do that. I tried to install it using the WHM RPM manager, but the ...
2
votes
2answers
6k views

How To Locate Dependencies Needed by RPM Packages

I am trying to deal with keeping our RHEL 5 server patched up, but also dealing with our security constraints. This particular server is not allowed to talk to the Internet. So yum isn't really an ...
0
votes
4answers
862 views

Why does `make install` not produce an rpm?

A little Preface: I'm unable to copy+paste between my Windows PC and a Linux machine that I'm viewing through VNC Viewer and yes the Share Clipboard option is enabled in VNC Settings. Thus I came ...
1
vote
2answers
212 views

RPM specfile for C/C++ project: how do I know how to fill in Requires and BuildRequires fields?

I have several C/C++ projects with sources and makefiles and I'm trying to pack them into rpms. Defining the dependencies for the created packages has become a problem for me. Concretely I need to ...
1
vote
1answer
257 views

What problems should I expect when adding a CentOS yum repository to RHEL?

I've added the CentOS 6 Updates yum repository to my RHEL 6.4 machine. That's because RHEL doesn't ship with the php-snmp package - and the easiest one to find is on the CentOS site. Anyways, this ...
1
vote
2answers
267 views

How can I find out where an RPM came from?

I have an RPM that is sitting on a server I inherited. On the server is an RPM that is needed for one of the applications that it runs. xmlrpc-epi-0.54.2-1.x86_64.rpm Rather than using this ...
1
vote
1answer
27k views

Uninstall JDK rpm to reinstall

Where do I find the JDK install to uninstall? @terdon had explained using an rpm type download so it would be easier to uninstall, but I cannot find it.
0
votes
1answer
60 views

Rebuilding RPM results in “invalid numeric value”

I am attempting to add some config changes to Bash and repackage it as an RPM in CentOS x86. This is not something I've done before, so I'm at the mercy of info I've found around the internet. I am ...
0
votes
0answers
42 views

How to handle a mass rpmbuild for a new distribution?

How could I define and initiate a mass rpmbuild for a coresystem of a new distro? Which requisites beyond rpmbuild-dir are needed?
3
votes
1answer
487 views

What does rpm -H do?

I came across someone's RPM command that wrote: rpm -ivH .... and then noticed that option -H is not documented anywhere. Command rpm -H no longer works with newer version of rpm, however it runs ...
1
vote
2answers
127 views

What does the line $(rpm -E %fedora) mean?

I'm trying to add a new repository to my Fedora and was asked to introduce the following command: su -c 'yum localinstall --nogpgcheck ...
1
vote
2answers
62 views

Looking for the path of a particular file provided by a particular rpm in a spec

I want to know the path of apxs provided by httpd-devel, on a machine that might have other copies of apxs, that would be resolved by which first. I can be reasonably confident this command will work: ...
2
votes
3answers
3k views

Error while trying to create RPM for java app

I'm new to RPM packaging and I got stuck for quite a long time and cannot find root cause of the problem. I'm not quite sure I fully understand the concept of BuildRoot in the spec file. My RPM ...
19
votes
6answers
9k views

What's .deb and .rpm and how is it different from .msi?

What are these file formats and how do they differ from the .msi format in Windows? Also what are the pros and cons of these package management schemes?
1
vote
1answer
143 views

rpmbuild library register for 'requires'

Big Picture: I am building an in-house rpm for a customized php. I build an rpm which works, but generate library requirements that I can't seem to meet without using 'nodeps', which I want to avoid ...