RPM is a package management system intended primarily for Linux distributions.

learn more… | top users | synonyms

4
votes
2answers
113 views

Where can I find updated TAR.rpm for Oracle VM Server?

I'm using tar for my incremental backup script on Oracle VM Server 3.2.2 and it comes with tar 1.15.1 I need this command: tar -cf drive-C.full.tar --no-check-device \ ...
2
votes
1answer
73 views

Get Install File for Already Installed RPM

I would like to install this custom package, packageA, onto another Linux box. $yum list installed | grep packageA packageA.x86_64 But, I don't have access to the installation file, i.e. packageA ...
1
vote
2answers
318 views

How to make an application run automatically?

I am trying to run my application when a user logs in. So I've added a script in ~/.bash_profile as follows: # for Buluttdepo /usr/bin/myapp > /dev/null 2>&1 & export ...
0
votes
2answers
2k views

How to run a script when install a rpm package?

I try to build rpm package. I follow here. I want to run a script (bash or python) when run command as "rpm -Uvh mytest-1.0-1.el6.noarch.rpm" . Could run a script when install a rpm package? How?
4
votes
3answers
2k views

How to programmatically determine the highest version kernel RPM installed?

What I want to script is something along the lines of: if [ uname -r is not == highest version of kernel RPM installed ] then echo "You need to reboot to use the latest kernel" fi The problem is, ...
2
votes
2answers
537 views

How can a version of a package conflict with itself?

I want to install fillup and get: rpm -i fillup-1.42-268.1.x86_64.rpm file /usr/bin/fillup conflicts between attempted installs of \ fillup-1.42-268.1.x86_64 and fillup-1.42-268.1.x86_64 ...
3
votes
2answers
329 views

rpmbuild: Is there a way to specify recommended packages

So, search as I might, I can't find anything about specifying recommended packages in a spec file. I wouldn't even consider it possible if I hadn't seen it in the spec file for Mono 2.10.9. It reads ...
2
votes
1answer
157 views

rpmbuild: How can I 'Require' one package *or* another

So, I'm trying to fix a spec file right now for rpmbuild. On Suse, it looks like the X11 library development package is named "xorg-x11-libX11-devel" while on CentOS it seems to be named ...
8
votes
2answers
2k views

Installing a package locally to a user - best practices?

I want to install Git locally to a user on a RHEL server (I don't have root access) What would be your cleanest/ most organized way of installing software to a local user account? Installing ...
3
votes
1answer
47 views

RPM subpackage name

Is it possible to make a subpackage without the inherited prefix from the master package? I have a project that has a single install and need to split this into multiple packages, but the subpackages ...
0
votes
1answer
280 views

Does yum use package buildtime to decide if a package is newer?

Say I have installed mypkg-1.2.3-4567.noarch.rpm from some yum repo. Is it valid for the rpm publisher to re-publish mypkg with the same version and release and just run createrepo --update? Is it ...
0
votes
0answers
279 views

How to install cpp in RHEL 6.3?

I want to install gcc in RHEL 6.3, but it has cpp dependencies. So I go to cpp rpm download page, but it has no rpm for 6.3 version: Is there any other way to install cpp in RHEL 6.3?
1
vote
1answer
163 views

Why doesn't build of net-snmp 5.7.2. provide /etc/rc.d/init.d/snmptrapd?

I am packaging an RPM for RHEL6, built from net-snmp-5.7.2.tar.gz. I see that the file /etc/rc.d/init.d/snmpd gets created and packaged but I do not see the init file for /etc/rc.d/init.d/snmptrapd. ...
2
votes
2answers
489 views

How to list RPM packages installed in order of installation date

I'd like to see a list of software installed in the order of the date they were installed. The order doesn't matter (newest to oldest & vice-versa) as long as they're arranged by date. I'm mainly ...
0
votes
1answer
934 views

How to install RPM based Packages on OpenFiler

We bought One SuperMicro Server that will be used for Storage purposes and then we install the openfiler on it. The thing is that we need to install RAID controller and Im not familiar with OpenFiler ...
-1
votes
1answer
296 views

unrar for centos 5.7 needs unrar-4.20-2.mga3.nonfree.x86_64.rpm which causes an error

I'm trying to install unrar package for my cpanel. as some people suggested that I need this package unrar-4.20-2.mga3.nonfree.x86_64.rpm . So when I run rpm -ivh unrar-4.20-2.mga3.nonfree.x86_64.rpm ...
2
votes
2answers
282 views

AIX apache rpm dependencies

I am evaluating the Crowd SSO by Atlassian. Now to get apache to use CROWD for authentication, there is a connector available by the vendor. Problem Unfortunately they do not provide anything for ...
2
votes
1answer
118 views

What is the corresponding freebsd command of these rpm commands?

I know about rpm, but I am newbie about freebsd packaging system. I learnt about how to create package and know I want learn how to get some information about packages or files. Can somebody give me ...
3
votes
2answers
243 views

reposync exclude subdirs from mirror

Is there a way to make the reposync command ignore a subdir of a public repo when mirroring it ? It seems to only want to sync on the url that has the /repodata/ & /repoview/ dirs, but i'm ...
2
votes
3answers
1k views

Requires: perl(Compress::Raw::Zlib) = 2.052

Im trying to run a yum update but getting stopped by dependencies. I have installed rpmforge el6 which i need for other packages. Error: Package: perl-IO-Compress-2.052-1.el6.rfx.noarch ...
1
vote
1answer
4k views

What is the easiest way to install Meld on RedHat Linux RHEL 5.4?

My company has RedHat RHEL 5.4 on the Linux box, and I need to install Meld on it. How can it be done? $ sudo yum install meld No package meld available. Nothing to do $ sudo yum search meld No ...
6
votes
2answers
6k views

yum install in user home for non-admins

I am a non-admin user on a large computer system. I need some up to date packages that are not installed on the system. I want to use yum to install them. As a user without sudo, admin, or root ...
0
votes
1answer
6k views

Public key not found for RPM

I am trying to install package on Redhat 5.5 using YUM but it always give me this error [root@redhat64 Desktop]# yum install perl-Net-Server-0.97-1.el5.rf.noarch.rpm Loaded plugins: rhnplugin, ...
1
vote
1answer
102 views

Files in RPM packages

There is something strange with RPM packages. The listed contents, enumerated by rpm -ql differ from the actually presented files. For instance, I downloaded a openldap-servers-2.4.26-8.fc16.i686.rpm ...
2
votes
2answers
10k views

Error on application install: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

When I executed a command to install an application, the following error occurred /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory I was not aware on how to fix this problem. I ...
3
votes
0answers
602 views

recommended procedure to create a user/group during RPM install

after trying hard to search for RPM best practices guides and finding virtually none, to my surprise, I resort to the community - I need to ensure that some users and groups exist after the ...
1
vote
1answer
118 views

Where can I find mailfromd RPM's for CentOS 6?

I have been trying to locate an RPM for GNU Mailfromd and it's dependencies and have been quite surprised to find it absolutely nowhere on the 'net. Only place I could find any RPM's were for ...
1
vote
1answer
60 views

What to include in an RPM created from python packages

I'm looking to create a rpm for this tarball and couldn't figure out which files needed to be included in the package after the install. I am used to compiling some code and including the binary ...
1
vote
0answers
95 views

How do I install additional modules when building an Apache RPM?

We've been compiling and installing Apache under /usr/local/apache2 and in turn would tar the folder up to distribute to our other servers. I would like to convert this into an RPM package for easier ...
2
votes
1answer
265 views

Obtaining/Packaging RPM dependencies for Fedora/RHEL linux application — no network access

I currently have an RPM file with 2-3 dependencies specified in the 'Requires' section. When this application is installed using yum, it works fine and the dependencies are installed if they are ...
4
votes
1answer
453 views

How to make an rpm package that installs a Java environment if needed

I'm very new to RPM packaging and I'm curious if, during the installation of one RPM it is possible to conditionally install another RPM if needed. In a nutshell. My RPM requires a particular JRE. ...
1
vote
2answers
409 views

Installing RPMS on Centos

Is generally installing standalone rpms considered 'dangerous'? Are these affected by any system upgrades, package upgrades etc.? How about dependencies and libraries?
1
vote
1answer
1k views

Why did yum-builddep not provide the dependencies to install my rpm?

I am trying to rum my rpm package but getting this dependencies error. [root@localhost ~]# rpm -ivh /root/x86_64/asterisk-1.8.12.2-1.fc15.x86_64.rpm error: Failed dependencies: ...
1
vote
1answer
361 views

Automatically install build dependencies prior to building an RPM package

I am trying to build the .rpm package. i have just followed the steps to do that. Till now all step was gone fine but now i just stuck with this step. I just ran the following command and got this ...
3
votes
1answer
2k views

Meaning of the yum error “Package tuple (…) could not be found in rpmdb”

I just want to install two packages in my Fedora 15 but I am getting some weird error. Command: yum install @development-tools Error: Loaded plugins: langpacks, presto, refresh-packagekit ...
2
votes
2answers
266 views

Missing dependency during rpm install

When I install CodeAnalsyt, i get a failed dependency on libbfd-2.20.51 on Centos 6.3. Binutils is installed on my system and the failed dependency does exists at ...
1
vote
1answer
178 views

CentOS5, RHEL5, Java dependent Packages, Alternate JVM/JDK

Specifically regarding Java dependent packages, such as ant. Is it possible to install them via rpm, when using an alternate JVM/JDK? For example, If I install the Oracle JDK, can I use an ant ...
1
vote
1answer
3k views

64bit rpm can not resolve 32bit dependencies

Problem I'm having a RPM that contains mixed 64bit and 32bit binaries. One of the binaries depends on 32bit i686 packages. When I try to install the package yum gives me an error, noting that the ...
7
votes
3answers
1k views

Download ALL rpms for a product

I have two CentOS machines, one 6.3 box (A), and another CentOS 6.1. (B) 6.3 box is with internet connection, 6.1 box is without internet connection. I want to download ALL dependencies of a product ...
5
votes
2answers
4k views

Is it stable to use epel and rpmforge in the same time?

So after a fresh Scientific Linux 6.3 Desktop install, I: yum install rpmforge-release && yum update and yum install epel-release.noarch then: yum install wine gparted cups-pdf ...
1
vote
3answers
120 views

How to get RPM's that has been published after the install DVD?

So if I download a: SL-63-x86_64-2012-08-02-Install-DVD.iso and install it, and give out a "yum update" - then it will find many-many XY packages to update. Q: are there any methods/solutions to ...
3
votes
1answer
88 views

Removing information such as soft links from an RPM package on Linux

I provide an RPM package that contains both 32-bit and 64-bit applications, and can be installed in either mode, i.e. on both 32-bit and 64-bit platforms. As the package contains both applications, ...
2
votes
2answers
158 views

RPM skipping files on install

I am installing an rpm package and it appears to be skipping certain files without giving me any notice as to what the issue is. When I execute rpm -ivh package_name.rpm the rpm provides me with ...
0
votes
0answers
149 views

How can i specify directory user & group for files inside an RPM?

I am building RPMs using FPM. When using the --rpm-user and --rpm-group, I notice as advertised that in the specfile that the %defattr(-,user,group,-) is set under %files. This does indeed set the ...
1
vote
1answer
144 views

%post section of rpmbuild not interactive

Situation: I'm trying to build a custom rpm to place a config file in a particular location. The installation completes fine by placing config files in proper directories but the %post section is not ...
1
vote
1answer
833 views

How do I `yum localinstall` from my `yum search` result?

I'm trying to install some dependencies for thrift using yum. I've found, for example boost via yum search boost which gives me (after a load of fails as the PC not on the web, but has a local ...
4
votes
1answer
971 views

CentOS 4.8 and glibc 2.5

How would I go about installing glibc 2.5 on CentOS 4.8? I know CentOS 4.8 has been EOL'd, which is all good and well. However, the environment that I am working in is using this version, and will ...
0
votes
1answer
111 views

Can anyone tell me how to install broadcom-wl-5.10.91.9.3-1.fc12.noarch.rpm?

[root@localhost opt]# rpm -ivh wl-kmod-5.10.91.9.3-3.fc12.6.src.rpm warning: wl-kmod-5.10.91.9.3-3.fc12.6.src.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID a3a882c1 1:wl-kmod ...
1
vote
1answer
86 views

Software distribution

I have a set of servers with Red Hat on board and an internal software (it is set of many files with configs and so on) that is in permanent development. There are several types of servers: ...
1
vote
1answer
802 views

httpd-devel requires outdated version of glibc-common on CentOS 6.3

httpd-devel requires an outdated version of glibc-common on CentOS 6.3 x86_64 and Apache/2.2.15. It wants 2.12-1.80.el6 and I have 2.12-1.80.el6_3.3.x86_64 installed (via CentOS @update repo) Here is ...