RPM is a package management system intended primarily for Linux distributions.

learn more… | top users | synonyms

1
vote
2answers
1k views

How To Locate Dependencies Needed by RPM Packages

I am trying to deal with keeping our RHEL 5 server patched up, but also dealing with our security constraints. This particular server is not allowed to talk to the Internet. So yum isn't really an ...
1
vote
1answer
1k views

“Requires: perl(:MODULE_COMPAT_5.8.8)”

I use CentOS 6.5 for my server with below repository: IUS epel ces-standard-* base/upgrade/extras When I tried to update today (it's been a while I haven't updated this server), I got the ...
8
votes
3answers
3k views

How do I tell which GPG key an RPM package was signed with?

The cryptographic signature of an RPM can be verified with the rpm -K command. This returns a string containing gpg (or pgp) and ending in OK if the signature is in RPM's database and is valid. If ...
2
votes
3answers
27 views

get the apache document root using shell script

I am creating an RPM and in the pre stage, I want to determine apache's document root so I can copy the web application files there. First, I check if apache is installed. If apache is installed, ...
1
vote
0answers
25 views

get the apache document root using shell script [duplicate]

I am creating an RPM and in the pre stage, I want to determine apache's document root so I can copy the web application files there. First, I check if apache is installed. If apache is installed, the ...
0
votes
2answers
26 views

Install rpm file from a server

I understand how to install an rpm from a given url. Example: RUN yum -y install http://rpms.famillecollet.com/enterprise/remi-release-6.rpm So that is the easy part. My question is, how do I do the ...
0
votes
1answer
20 views

Conflicting answers regarding package from rpm, yum and repoquery

I have a few packages on a RHEL 6.5 system which exhibit the following puzzling behavior: The package is installed; rpm -q reports the package as installed; yum search shows that the package is ...
1
vote
0answers
37 views

32-bit package from a repo that should only contain the 64 bit packages

Trying to a do install of some packages and it seems that it is trying to pull a 32-bit package from a 64-bit repo. Installing for dependencies: cyrus-sasl-lib i686 ...
0
votes
1answer
29 views

How to fetch source iproute(2.6.32.130) not patches

I want to look at the source of below package. [root@ovs-1 ~]# rpm -qa | grep iproute iproute-2.6.32-130.el6ost.netns.3.x86_64 I tried to install the src rpm as below, it showing below error. ...
1
vote
1answer
19 views

createrepo fails with headerRead failed message

I execute createrepo -v --update epel-dir/ and at package number 14173, the process fails with a Python stack trace complaining that: headerRead failed: Header sanity check: OK So, I thought ...
3
votes
1answer
2k views

How can I downgrade a glibc version?

I upgraded glibc for a reason that isn't arround anymore so i want to downgrade it again. The stupid thing is a lot of programms rely on glibc at the moment. I still have the 2.4 version on the system ...
4
votes
3answers
110 views

How to merge config files interactively after “yum update”

After system packages are updated with "yum update", config files which could not be overwritten are not replaced, but we can find *.rpmnew files near by. By design system administrator must merge ...
2
votes
1answer
1k views

Unable to use yum repos whether with baseurl or mirrorlist in CentOS 6.5

Since a couple of days, I'm unable to retrieve repositories data with Yum, in my CentOS 6.5 server. I did yum clean all a dozen of times, it emptied all but didn't solved the problem. I tried to ...
2
votes
1answer
30 views

What are gpg-pubkey* packages?

I compared the packages list reported by RPM and YUM on a CentOS 6 and 7. I noticed the lists were slightly different (same issue with RHEL). See Listing installed packages with yum and rpm mismatch ...
4
votes
4answers
6k views

List all RPM packages installed from repo “X”

How can I get a list of all of the RPM packages that have been installed on my system from a particular repo (e.g., "epel")?
1
vote
1answer
26 views

how to find which repo does one rpm package belong to

How to know which repo does one rpm package belong to? I searched the yum manual, and I didn't find the option. And it is useless to use yum list installed.
0
votes
1answer
1k views

How to install RPM based Packages on OpenFiler

We bought One SuperMicro Server that will be used for Storage purposes and then we install the openfiler on it. The thing is that we need to install RAID controller and Im not familiar with OpenFiler ...
3
votes
1answer
465 views

Make RPM Satisfy Dependency Requirements of Other Installed Packages

So, I am installing a java app that I wrote which uses jnetpcap. This requires libpcap of at least v1.0.0. My CentOS 5.8 only has libpcap 0.9.4, which is required by other installed packages. I've ...
4
votes
0answers
92 views

Centos 7 boot up with custom kernel problem

I have installed centos 7 on virtualbox machine which has kernel-3.10.0-123.20.1.el7.x86_64. I am trying to build Linux kernel from kernel sources. I downloaded the kernel source files from: ...
1
vote
1answer
74 views

Bash script problem in RPM postinstall

I created an rpm package that extract a Node.js project into a specific folder and then I created a postinstall script that cd into that folder and perform an "npm install --production" #!/bin/bash ...
2
votes
2answers
2k views

Why does yum continue to complain about a missing dependency that is already installed?

I have a self-created rpm for mapserver 6.2.1 that I want to support Oracle, but I am having a lot of difficulties getting it all to work. I have installed the ...
5
votes
4answers
9k views

getting error “Can't create transaction lock” with rpm

I am slowly making progress on installing Fedora into a Logical Volume for a DomU using Package Management. I have (with the help of the wonderful people at Unix & Linux) resolved a number of ...
-1
votes
2answers
20 views

Where to find the RPM file of GIMP for installation?

I wanted to install GIMP just like installing it on Windows using the exe or msi file. Where can I find the RPM file so I can just issue the command rpm -ivh gimp-2.8.14-x86_64.rpm I like to ...
1
vote
0answers
36 views

writing systemd unit file and specfile for a python twistd application [closed]

I have given a task to write the systemd unit file for a python twistd application and create rpm of it. The application is open source and you can find it here: ...
0
votes
1answer
16 views

rpm -V inner workings

I have an rpm file that is used to install a package I made the package consists of java classes and shell scripts to run these java classes, in a .run file. So the rpm essentially only contains a ...
0
votes
1answer
37 views

Where does zypper source-install put the sources?

When using a command like zypper source-install kwrite where does zypper install the sources to?
1
vote
1answer
1k views

Error: requested datatype primary not available

By the error I can't install any packages. And also I can't update to the latest version. I don't know what to do now. Any help much appreciated. Error: requested datatype primary not available ...
111
votes
12answers
44k views

What are the pros/cons of deb vs. rpm?

For whatever reasons, I've always used RPM based distros (Fedora, Centos and currently openSUSE). I have often heard it stated that deb is better than rpm, but when asked why, have never been able to ...
1
vote
1answer
31 views

force zypper to install a specific ersion

i have my own personal repo with older versions of rpms in it. If i want to install boost-license version 1.36.0.11.17 i do the following zypper boost-license=1.36.0-11.17 this seems to be broken ...
0
votes
1answer
46 views

Can I install ALL required rpm to run wine without root permission?

I am logged in on a redhat linux computer, and I don't have root permissions. I have tried running/installing wine on a folder using ./configure , which outputs: configure: error: X 32-bit ...
1
vote
1answer
54 views

How to force rpm and yum to fail if a GPG signature is missing or cannot otherwise be verified?

How can I force rpm and yum to fail if a GPG signature is missing from a package or otherwise cannot be verified due to a missing key? For the example below, assume the RPM has been signed but the key ...
1
vote
1answer
26 views

Local installation of .rpms using YUM

I'm asking this question cautiously because I don't want to get this wrong. I have a program_name.rpm file saved locally on my server (CentOS 6.5). I have installed it previously just by navigating ...
2
votes
3answers
1k views

Error while trying to create RPM for java app

I'm new to RPM packaging and I got stuck for quite a long time and cannot find root cause of the problem. I'm not quite sure I fully understand the concept of BuildRoot in the spec file. My RPM ...
0
votes
1answer
305 views

Big trouble : rpm empty db, install V3 RSA/SHA1 Signature, key BAD, YumRepo Error

I'm little tired because I have spent hours solving problems, and can't find a solution on Centos 6.6. I have many troubles: rpm db is empty: try googling, find restore process, but always empty ...
0
votes
1answer
56 views

rpm -Uvh - How to replace modified config file

The question is a duplicate from Stackoverflow site I upgrade rpm package with rpm -Uvh command. Original and new configuration file is the same, but current file on disk has been changed. This ...
0
votes
0answers
89 views

upgrading Berkeley DB rpm in a Centos OS

I have a software which need Berkeley DB 4.5 or above. But in my CENTOS 5.11 x86_64 Server I have Package db4-4.3.29-10.el5_5.2.x86_64 already installed and latest version Package ...
1
vote
4answers
345 views

Why does `make install` not produce an rpm?

A little Preface: I'm unable to copy+paste between my Windows PC and a Linux machine that I'm viewing through VNC Viewer and yes the Share Clipboard option is enabled in VNC Settings. Thus I came ...
0
votes
1answer
39 views

How can i download a rpm

I have a local repo that has some rpms in it. The repo xmls etc are up to date. When i find an rpm i dont have i want to be able to down load it, not install it obviously, and put that rpm into the ...
1
vote
1answer
21 views

RPM %install section

So, I am somewhat puzzled by the rpmbuild process. I'm now maintaining a slew of scripts previously created and while most work, there are enough differences between them that finding a consistent ...
0
votes
1answer
27 views

What option specified the location of the generated RPM?

I have noticed that, when building rpm files, that most end up in /usr/src/redhat/RPMS/i386 (building 32bit). Some though, incl one we roll in-house, writes the rpm files to ./i386.... so the file ...
14
votes
2answers
10k views

CentOS: List the installed RPMs by date of installation/update?

I'm on a CentOS machine. I updated and installed some packages a few weeks back, but I don't remember the name of every package or the names of every dependency. I used yum. Can I list the packages ...
2
votes
4answers
68 views

How to find out which package a user belongs to?

In Linux distributions, some packages create user accounts. How can I determine which package created a given user? I want to know specifically for Fedora and Ubuntu, but answers for other ...
1
vote
0answers
18 views

Make a rpm package from the cpan compatible tree?

I always make my perl module following the CPAN-complient tree. I would like to use this tree to create a rpm file I could install on a hundreth servers. Is it possible to make a rpm package with ...
0
votes
1answer
16 views

rpm -R verses zypper info --requires

Consider the following: root# rpm -qR foobar rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadIsLzma) <= 4.4.6-1 root# zypper info --requires ...
1
vote
1answer
3k views

64bit rpm can not resolve 32bit dependencies

Problem I'm having a RPM that contains mixed 64bit and 32bit binaries. One of the binaries depends on 32bit i686 packages. When I try to install the package yum gives me an error, noting that the ...
2
votes
2answers
65 views

RPM Says Shared Object Is Missing But I Can Find It With ls

Having a problem installing an openssh rpm I hand-rolled today: [root@local_host ]# rpm -i openssh-6.7p1-1.i386.rpm error: Failed dependencies: libcrypto.so.1.0.0 is needed by ...
1
vote
4answers
5k views

“The GPG keys listed for the ”atomicrocketturtle.com“ repository are already installed but they are not correct for this package.”

When running this on CentOS 6: yum update I accept the transaction summary that it presents and am then immediately presented with this: Downloading Packages: warning: rpmts_HdrFromFdno: Header V3 ...
1
vote
0answers
40 views

How to upload package to my private YUM repository on Suse

I have created a private repository and populated it with RPMs. I can query and install via the zypper package from remote Suse boxes which is great. What is the neatest way to upload new packages to ...
1
vote
1answer
60 views

Installing RPM packages with circular dependency

I'm trying to follow an article to enable smart card login on my RHEL 6.6 desktop. When I attempt to install coolkey-1.1.0, it says ccid and pcsc-lite is needed. When attempt to install ...
0
votes
0answers
21 views

Where can I ask for help on how to build a RPM package?

Im really lost on how to build a RPM package to install in Citrix XenServer. (centos 5). The package maintainer didn't update the RPMs. I downloaded and installed Centos 5 and the rpm-build, gcc, etc ...