Python is an interpreted, general-purpose high-level programming language whose design philosophy emphasizes code readability.

learn more… | top users | synonyms

2
votes
1answer
314 views

Get 'python-keyring' to stop prompting for 'encrypted keyring' password

Situation: I followed these instructions (http://mercurial.selenic.com/wiki/KeyringExtension) on setting up the mercurial keyring-extension for mercurial. On a Ubuntu 12.04.4 (precise) machine it ...
2
votes
3answers
323 views

Replace multiline string in files

I have a number of files I want to update by replacing one multi-line string with another multi-line string. Something along the lines of: * Some text, * something else * another thing And I want ...
0
votes
0answers
267 views

errors while installing python-pip on ubuntu

When running sudo apt-get install python-pip I got the following error messages, what causes the problem and how to fix it? Thank you very much for any help. Err ...
0
votes
0answers
437 views

Unable to use python speech_recognition lib Microphone class due to ALSA

I am attempting to write a speech recognition program for the raspberry pi, however I am facing some issues using python's speech_recognition library. From the error messages (posted below) I think ...
2
votes
0answers
79 views

arecord until sound level drops low enough

I am trying to implement constant voice recognition on my Pi at the moment, I am achieving this by having two threads running, one constantly recording (with arecord in a bash script) for X amount of ...
1
vote
2answers
247 views

Installing older versions of python packages with apt-get (specifically wxpython)

I've been beating my head against the wall trying to troubleshoot a graphical program with a WX backend. We've found that wxPython 2.8.10 work fine, and seemingly any newer releases doesn't. Despite ...
14
votes
3answers
11k views

What is the proper way to manage multiple python versions?

I have a machine with Python 2.6 installed as the default Python. Then, I installed Python 2.7, and manually created /usr/bin/python as a symlink to the new installation. Then, I was running into ...
5
votes
2answers
418 views

If any spawned child processes fail, kill all and exit

In my script I split up a data set into input_aa, input_ab, etc. Then, I run each through the same Python script, as such: # Execute program on each split file for part in input_*; do python3 ...
4
votes
1answer
914 views

How do I make Kate indent with spaces on Python files but use tabs for text files and other files?

My goal is to set Kate up to work properly on Python files but to use different settings (tabs not spaces) on other documents. I'm sure others are doing this, but I can't figure out a convenient ...
2
votes
2answers
613 views

How to install PySide package for CentOS 7

I'm trying to install PySide on CentOS 7. Seems pretty straightforward, enable EPEL repo, and install. Except that EPEL doesn't seem to contain a PySide package (yum install python-pyside fails with ...
0
votes
2answers
174 views

Runs perfectly through the command line, will not work through systemd ExecStart

I've installed Butterfly http terminal server, written in python, on my Arch machine. I'm new to systemd, but I'm having an issue with one of the command line parameters. /usr/bin/butterfly.server.py ...
0
votes
0answers
7 views

What potential trouble may arise by copying module directly from one python sys path to another?

Our server is CentOS and sys python is in version 2.6, meanwhile there is also a python2.7 under /usr/local/bin I did yum install MySQL-python, but in python2.7 I can't import this module. So I ...
0
votes
2answers
1k views

Upgrading Python 2.6. libpython2.6.so.1.0 missing

I am upgrading python on an offline 64bit RHEL 6.4 box and am having to do it via RPM's rather than yum. I am trying to upgrade python from 2.4.3 to 2.6 so I can build nodejs from source. I am ...
2
votes
1answer
855 views

Why does apt-get in Ubuntu still want to install Python 2.7?

New Linux VPS, installing Python and a few other tools I like to use. Did apt-get update and apt-get upgrade, and I noticed when I did apt-get install python it defaulted to version 2.7. (I can, ...
2
votes
2answers
858 views

What should I do about Python 2.7.9 not looking for SSL certificates in the right place on FreeBSD?

I have a FreeBSD 10.0 system, and a couple of days ago, I upgraded my python27 port from Python 2.7.8 to Python 2.7.9, which enabled SSL verification by default. Unsurprisingly, it broke my existing ...
10
votes
7answers
960 views

Why does my Python background process end when SSH session is terminated?

I have a bash script that starts up a python3 script (let's call it startup.sh), with the key line: nohup python3 -u <script> & When I ssh in directly and call this script, the python ...
0
votes
1answer
72 views

/usr/lib/python2.4/site-packages/cElementTree.so: wrong ELF class: ELFCLASS32

yum update There was a problem importing one of the Python modules required to run yum. The error leading to this problem was: /usr/lib/python2.4/site-packages/cElementTree.so: wrong ELF class: ...
2
votes
2answers
427 views

How can I replace bash using Python?

According to the accepted answer for this SO question: , Python can make a great bash replacement. My question then, is this: how do I go about seamlessly make the switch? I think the main thing to ...
3
votes
3answers
1k views

Unable to run python script - Permission Denied

Trying to run a NZBGet (Python) Script, I've tried to run manually with: /mnt/local/ext001/MEDIA/NZBGet/scripts/videosort/VideoSort.py but this results in: bash: ...
1
vote
2answers
2k views

Running ipython notebook on Debian

I'm trying to get ipython notebook to run on my Debian machine without much success. I've installed ipython and ipython-notebook via apt-get, but when I try to start it up I get the following: $ ...
5
votes
1answer
289 views

Using OGG/Vorbis, is there a way to continue to record to an existing audio file?

I am using Vorbis/ogg to record audio (using arecord and then pipping to oggenc). I have downloaded oggvideotools, which gave me oggCat, which will let me join two previously recorded audio files into ...
4
votes
1answer
4k views

How to do a binary install of Python 2.7 on SUSE Linux Enterprise Server 11?

My SLES11 box came with Python 2.6 installed. I would like to upgrade to 2.7. What is the easiest way to do this?
0
votes
0answers
74 views

Setting different path for installation in python packaging

I am new to python packaging. My Command Line Interface (CLI) named virtdc modules has to be installed in /var/lib/virtdc. virtdc is the top folder structure /var/lib/virtdc/ framework/ ...
0
votes
1answer
90 views

Permissions when creating a simple Python package for pip

I'm trying to package a simple app I wrote, so that it can be installed on a system using python setup.py install and (later) using pip install awesomeapp. The app consists of two files in the same ...
5
votes
3answers
2k views

On Debian, how do I add a Python package in dist-packages to a virtualenv?

Given some python package in /usr/share/pyshared/ or /usr/lib/pythonX.Y/dist-packages/ (take python-numpy or python-scipy for example), how do I add that package to a virtualenv? When adding the ...
1
vote
0answers
103 views

Profiling memory, disk, cpu, and time from python

I have a workflow, implemented in python, and I would like to profile memory, disk (IO), cpu, and time information in python in an unobtrusive manner. This is NOT a question of profiling code, but ...
1
vote
2answers
342 views

Lots of unmet dependencies while updating Python

It was suggested that I uninstall and reinstall Python, so I deleted every directed labeled python until 'which python' and 'which python3.4' didn't show anything. Then I did apt-get remove python ...
6
votes
1answer
82 views

“ValueError: _system not initialized” when using apt.VersionCompare

I wrote a bash script that has to compare two version strings to decide to download new version or not. The test relies on a Python script that does apt.VersionCompare(), which does version comparison ...
0
votes
0answers
86 views

How to grant sudo permission for a .py script on a apache folder?

I've exemplo.py in an folder /opt/lampp/htdocs/cgi-local/exemplo.py folder. The script creates a socket that needs super user permissions. My question was a little confusing? I need to access ...
1
vote
0answers
59 views

How to monitor the integrity of a script that is running?

I want to make sure a running python script was not modified accidentally by some other process (or cosmic ray, or unexpected developer update). I've heard of comparing a checksum of the script (e.g. ...
3
votes
1answer
1k views

Can I upgrade to a new version of Python on an old version of Ubuntu?

I have Ubuntu 8.04.3 LTS and ran this: $ sudo apt-get install python2.7 I got this: Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find ...
2
votes
1answer
112 views

readline - why does does it only do carriage return and not a line feed when reaching end of line?

I developped a python application that uses the cmd module to make an interactive command-line interface. This cmd module uses readline for command-line management: completion, history... My issue ...
3
votes
1answer
118 views

How to catch mount events on Linux?

I want to somehow get notified if a mount or unmount occurs for a USB drive. At the moment I use udev and then wait for x seconds for a new entry in /proc/mounts. This works ok if the mounting is ...
18
votes
3answers
2k views

Why is coreutils sort slower than Python?

I wrote the following script to test the speed of Python's sort functionality: from sys import stdin, stdout lines = list(stdin) lines.sort() stdout.writelines(lines) I then compared this to the ...
-2
votes
1answer
868 views

What does PIP stand for? [closed]

What does pip stand for? Does it stands for Python Package Installer? No, I don't think so, it is PPI
1
vote
1answer
67 views

Pyajam in debian 7

I'm trying to make the installation package python Pyajam I tried to install for pip, I received an error 4Suite-XML package $ pip install Pyajam Installing collected packages: pyajam, 4Suite-XML ...
1
vote
1answer
318 views

How can I modify a python shared object (.so) file?

I have a python code (Running on a raspbian OS) which reads the value of a joystick axis and then sends the value to an arduino. At the start of the code I have typed: import pygame I can then use ...
2
votes
2answers
164 views

Cron job not behaving as expected

So I have a python script that pulls down git/svn/p4 repositories and does some writing to a database. I'm simply trying to automate the running of this script and based from what I see in syslog it ...
1
vote
0answers
261 views

Startup commands in /etc/rc.local won't work

I have a Python program and an nginx/uwsgi/django web setup. I want the program to start with the system, as well as the web server. Here's my /etc/rc.local: crawler_dir=/home/mohammed/git/crawler ...
0
votes
0answers
281 views

python error using an executable with Z shell

I'm getting this error from the Unix Z shell (I'm on Mac): python: posix_spawn: /System/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python: No such file or ...
2
votes
1answer
209 views

Why is my pip-installed Python script not executable for everyone?

In my Vagrant instance: vagrant@archlinux:~$ sudo pip2 install vcard Downloading/unpacking vcard Downloading vcard-0.9.tar.gz Running setup.py (path:/tmp/pip_build_root/vcard/setup.py) egg_info ...
0
votes
1answer
71 views

Installing Python without package manager

I need to install Python 2.7.x on a TI Sitara ARM processor (based on the BeagleBone Black) running a minimal custom version of Linux. In particular, the OS does not have any package manager, no gcc, ...
1
vote
0answers
107 views

Hotmail not receiving emails from a script, but works from the server

I have a working mail server running Debian stable, the following elements are working. SPF DKIM rDNS My IP is not listed in any backlist, I used: mxtoolbox.com for all this. My problem: Sending ...
2
votes
1answer
51 views

Ways to store data for command line API

I am developing an API in Unix environment for virtual machines. I have to store some information in a table about virtual machines. Currently I am using python dictionary of virtual machine objects ...
3
votes
1answer
127 views

Issues with Skyperious

I am trying to install Skyperious on Ubuntu 13.10, I have installed all the required dependencies, my python version is Python 2.7.5+. When I run the following code from terminal python main.py ...
4
votes
5answers
8k views

How can I upgrade pip on Ubuntu 10.04?

On Ubuntu 10.04 I've used apt-get install pip to install pip after which I installed django. Then I tried to uninstall django with pip via pip uninstall django which gives me: pip: error: No command ...
2
votes
1answer
27 views

How to use a custom library for certain programs?

Here's my situation. I'm running Centos 7, have the standard version of libcurl as provided by my package manager, and several programs that depend on libcurl. One of them is pycurl, a python ...
1
vote
0answers
294 views

How to suppress input overrun messages

I have a Raspberry Pi running Raspbian (a Debian flavor: Linux version 3.12-1-rpi (debian-kernel@lists.debian.org) (gcc version 4.7.2 (Debian 4.7.2-5+rpi1) ) #1 Debian 3.12.9-1+rpi1 (2014-05-19) ). ...
0
votes
1answer
56 views

Make python module as an installable API

I am developing an API in Unix environment for virtual machines. Most of the modules are developed in python. I have few questions on this. I want to make this as an installable API, I mean to ...
3
votes
2answers
172 views

Basic steps to develop python API in Unix environment

I am developing an API in Unix environment for virtual machines. Most of the modules are developed in python. I have few questions on this. I have the file extension as abc.py. I would like to make ...