Python is an interpreted, general-purpose high-level programming language whose design philosophy emphasizes code readability.

learn more… | top users | synonyms

3
votes
1answer
719 views

Python script run while screen is locked

I have a python script which seems to be failing to continue running its while True: ... sleep() loop my code is at http://github.com/xdaimon/xdaimonConky What happens is I autostart python on ...
3
votes
1answer
57 views

How to determine the current Enhanced Zoom factor in Compiz?

When I use Skype :( need to, rather than want to ), I find that I sometimes want to open the main menu, but it doesn't have a shortcut key assigned to it (well, not one that I can find). I have ...
1
vote
1answer
24 views

IPython Qt Console doesn't have a title in GNOME app switcher

When I use the app switcher in GNOME 3.16, the IPython Qt Console (version 3.1.0) doesn't have a title under its icon (see image, and compare with Chromium). I also noticed that the icon doesn't ...
1
vote
1answer
45 views

Installing VIM with Python support locally without sudo

I'm trying to install VIM with Python support on Linux without sudo, but for some reason VIM always gets installed without python ( -python in vim --version ) I first installed Python locally by ...
1
vote
1answer
50 views

Enable cursor keys in python shell over ssh

I run OpenElec on a Pi. I can ssh to the Pi and open a python shell. How do I enable the cursor keys to work like up getting to last command in the python shell, like it does on my Ubuntu box. Now ...
1
vote
1answer
130 views

How to run specific architecture (32/64) of Python in Centos6 when both are installed?

I have a Centos 6.6 Docker image being used for an automated build. It has the default x64 Python 2.6.6 installed. I need to run some things in a 32-bit Python environment. I snagged the ...
1
vote
1answer
420 views

How to install the pylzma python library on Linux?

The pylzma library is a requirement for another tool that I would like to use. I am new to python and programming and have a few questions: I have already followed the procedure to download and ...
1
vote
1answer
873 views

“except (IOError, OSError), e: SyntaxError: invalid syntax” when configuring python-lockfile

I am having trouble installing any new packages in Ubuntu because of python. I tried sudo apt-get install python3 python3-dev but I am getting the following output :: dpkg: error processing ...
1
vote
1answer
231 views

How Do I Package a Django Website for Debian (Not a Python Package or Egg)?

I have been searching for the last two weeks and chased myself into multiple dead ends trying to figure out the path that takes me where I want to go. However I finally have to admit that my answer ...
1
vote
1answer
1k views

Trouble installing lxml with custom install location for libxml2/libxslt

I am attempting to install a python module called lxml to my account on a supercomputer running RHEL. I do NOT have root access or super user status. lxml requires the dev/devel versions of libxml2 ...
1
vote
1answer
532 views

How can i fix the following gmp library dependency error while trying to install Charm?

I am trying to install Charm crypto python framework in ubuntu 11.04 with python 2.7. Requirements say that i should have gmp installed 5.*. I have successfully installed gmp lib and i have run all ...
1
vote
1answer
150 views

Change default python distribution for postgres from the system's python (to Enthought Canopy)

On an RHEL6 system, I'd like my postGIS implementation (ie my postgres/postgresql databases) to use Enthought's Canopy distribution of python, rather than the built-in GNU's distribution. (This is ...
1
vote
1answer
118 views

Virtual Python installation not allowing ez_setup?

I don't have root on my system, so I'm trying to create a virtual Python installation. I ran virtual-python.py, and it told me to run ez_setup.py. I found it online and ran it with the command ...
0
votes
1answer
17 views

Debian Lenny Adafruit_BBIO failure to install

Im sorry if i have this in the wrong forum, but im not sure where to put this. Google Groups is going to be too slow in a response (They are where i posted to first). I have Debian Lenny installed on ...
0
votes
1answer
126 views

Yum Corrupted on RHEL 6

I really need help. I am encountering the issue with my yum command. It seems to be exactly the same as the issue described on this site, Yum corrupted on CentOS 6.2, Problem importing one the python ...
0
votes
1answer
53 views

Local system doesn't forward to intended port defined in OpenShift proxy app

I've set up a proxy server via OpenShift based on this tutorial and used a few days by forwarding my local system's ports to remote app's ports: $ rhc port-forward AppName The result in the proper ...
0
votes
1answer
28 views

Start GTK apk based on python

How to start application based on python + glade? startx python apk.py doesn't working. I can run application like firefox from text mode -> startx firefox
0
votes
1answer
103 views

Python script: wait until job in tmux session has completed

I am trying to continuously run a python script with random parameters from another python script, where each run is in its own tmux session. A very simplified overview of what I'm trying to do goes ...
0
votes
1answer
882 views

Debian Stable (“wheezy”): was trying to build Python 3.4, and I ran sudo make install — am I in trouble now?

So, I wanted to run Python 3.4.x inside a virtualenv virtual environment. I learned that the first step should be to build Python 3.4.x. I was doing so in /usr/bin/Python3.4.x (a folder I created), ...
0
votes
0answers
57 views

how to retreive all income information from serial port /dev/ttyUSB0 with python an pexpect

i'im trying to write a script in order to automate firmware flashing with commotion wireless router when using serial: import serial import sys import time ser = ...
0
votes
0answers
39 views

csvkit Permission denied

I am on Mac and installed csvkit. When I run csvlook, I get a traceback with the following error message: IOError: [Errno 13] Permission denied: '/Library ...
0
votes
0answers
63 views

Process Being Killed due to low swap

I'm running a python (2.7) script on mac osx yosemite. The script is fairly computationally intensive, certainly bumping up against my machine's RAM limitations. The computer crashes and restarts ...
0
votes
0answers
20 views

Trigger a graphic window during kickstart

I have built some custom centOS instalaltion CD with the help of anaconda and kickstart, nothing really exciting here, everything is working fine, packet are installed, pre and post installation ...
0
votes
0answers
78 views

Opening a TCP port in Linux

I am trying to establish a TCP socket between my linux server and my client running on my laptop. The TCP server code I am running is, from socket import * HOST = '' PORT = 1999 ...
0
votes
0answers
43 views

Does python has a Key Derivation Function (kdf) module used in Wifi Protected Setup (WPS)?

I have tried browsing python's documentation website to determine if there is a Key Derivation Function (kdf) module. The kdf is a function used in the Wifi Protected Setup (WPS) to generate keys for ...
0
votes
0answers
30 views

Control TCP Connections in Python

For my college project I am trying to develop a python based traffic generator.I have created 2 CentOS machines on vmware and I am using 1 as my client and 1 as my server machine. I have used IP ...
0
votes
0answers
86 views

CentOS: Connection reset by Peer error while running python script

For my college project I am building one traffic generation tool using python. I have developed my own linux server and client on Vmware. I am using urllib2 for traffic generation in python. The ...
0
votes
0answers
157 views

How do I get Ubuntu to use Anaconda's python instead of the standard /usr/lib/python…?

I installed Anaconda using instructions provided on the main website, which are similar to those that can be seen here: http://askubuntu.com/questions/505919/installing-anaconda-python-on-ubuntu ...
0
votes
0answers
28 views

Do I have support for python in gdb or not?

I've been following this tutorial which requires running gdb with python support but I get following message: ┌─[wakatana@~] [63 files, 178Mb] └──> gdb --python gdb: unrecognized option '--python' ...
0
votes
0answers
54 views

running a python script in termin os x

I do not know why but I cannot run a python script though the terminal. my script: define_regions.py print "Hello World!" print "Hello Again" print "I like typing this." print "This is fun." print ...
0
votes
0answers
34 views

Using pyenv with sqlite3

I'm trying to install Python via pyenv and I would like to compile it with SQLite. I understand that this requires libsqlite3-dev or similar, but I don't have root access on this machine. I ...
0
votes
0answers
65 views

Sign a soap message from a JKS dynamically using Python Unix

I am currently calling a webservice using Curl command from unix . I have a requirement that I have to dynamically message sign the soap request every time I make a call to the webservice using my ...
0
votes
0answers
45 views

Xterm not printing python errors

I'm running a suite of bash and python scripts that (taken together) make up a large open source software project running on Ubuntu 14.10 under VirtualBox 4.3.22. I'm using python 2.7.8 and xterm ...
0
votes
0answers
61 views

broken yum/python

Yum seems to be broken and below is the error. 'import site' failed; use -v for traceback There was a problem importing one of the Python modules required to run yum. The error leading to this ...
0
votes
0answers
56 views

Testing outgoing FTP with fake data

I would like to implement a fake FTP transfer in a program I'm working on. Basically I just want there to be FTP traffic happening in the background for a variable length of time. Similar to how iperf ...
0
votes
0answers
31 views

Problem in running uberwriter (a python app)

I installed uberwriter on my archlinux using AUR. But when I want to run it this error will be shown: Traceback (most recent call last): File "/usr/bin/uberwriter", line 44, in <module> ...
0
votes
0answers
192 views

errors while installing python-pip on ubuntu

When running sudo apt-get install python-pip I got the following error messages, what causes the problem and how to fix it? Thank you very much for any help. Err ...
0
votes
0answers
285 views

Unable to use python speech_recognition lib Microphone class due to ALSA

I am attempting to write a speech recognition program for the raspberry pi, however I am facing some issues using python's speech_recognition library. From the error messages (posted below) I think ...
0
votes
0answers
4 views

What potential trouble may arise by copying module directly from one python sys path to another?

Our server is CentOS and sys python is in version 2.6, meanwhile there is also a python2.7 under /usr/local/bin I did yum install MySQL-python, but in python2.7 I can't import this module. So I ...
0
votes
0answers
53 views

Setting different path for installation in python packaging

I am new to python packaging. My Command Line Interface (CLI) named virtdc modules has to be installed in /var/lib/virtdc. virtdc is the top folder structure /var/lib/virtdc/ framework/ ...
0
votes
0answers
69 views

How to grant sudo permission for a .py script on a apache folder?

I've exemplo.py in an folder /opt/lampp/htdocs/cgi-local/exemplo.py folder. The script creates a socket that needs super user permissions. My question was a little confusing? I need to access ...
0
votes
0answers
157 views

Unable to install bsddb185, Python library for opening Berkeley DB version 1.85 files on Ubuntu

I am writing a python program that makes use of some legacy Berkeley DB 1.85 files. Unfortunately I am unable to install the bsddb185 Python package, either for Python version 2.x and for Python 3. ...
0
votes
0answers
52 views

Updating data sets from Online databases/Webservice

I want to have an idea as to how to update the data regularly from the source, if its stored locally in your server or local machine.Lets say MySQL database. Source:It will be a webservice data ...
0
votes
0answers
17 views

Is there any prompt decoration package available for iPython?

One can argue, that IPython can be a productive replacement for bash. I wonder, if anyone here have seen some sort of prompt decoration for IPython, that can be compared to the standard bash prompt, ...
0
votes
0answers
315 views

Installing iPython3 Fedora 20

It was very easy to install ipython and upgrade it to the newest version (2.0) using pip. However, I want to set up ipython3, which uses Python 3, and found it more difficult. I finally installed it ...
0
votes
0answers
627 views

Installation location of python modules?

How does one get python modules working on a local machine? I followed the doc here: https://docs.python.org/2/install/ to no avail. I tried putting a known working module in the following locations ...
0
votes
0answers
36 views

Need a different header path for compiling

I'm trying to update numpy, a python package, on my fresh install of debian. I have installed from source the latest version of python in /usr/local When trying to update numpy via pip, I get an ...
0
votes
0answers
93 views

Installing cppman

I've tried to install cppman in Fedora 19 or Linux mint 15 and it installs successfully. But when I try to use it I get the error: Python IOError: [Errno 13] Permission denied I've installed it in ...
0
votes
0answers
342 views

mod_python won't “./configure” because it can't determine httpd version

I'm trying to install mod_python 3.3.1 on Apache 2.4.3 and whenever I try to run ./configure (with apxs etc) and instead of configuring correctly, it says that Apache 2.x is required and my current ...
0
votes
0answers
276 views

python error using an executable with Z shell

I'm getting this error from the Unix Z shell (I'm on Mac): python: posix_spawn: /System/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python: No such file or ...